summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d95efba637f2..c2da62b45162 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc='Bitcoin Classic with bitcoind, bitcoin-tx, and bitcoin-cli'
arch=('i686' 'x86_64')
url="https://bitcoinclassic.com/"
license=('MIT')
-depends=('boost-libs' 'libevent' 'openssl' 'miniupnpc' 'zeromq')
+depends=('boost-libs' 'libevent' 'openssl-1.0' 'miniupnpc' 'zeromq')
makedepends=('boost')
provides=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-tx')
conflicts=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-tx')
@@ -22,7 +22,9 @@ sha256sums=('900218eb2cd40c96a357a601e17fc6eacc91970f369761462de5a695c20701d5'
build() {
cd "bitcoinclassic-$pkgver"
-
+ export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
+ export CXXFLAGS+=" -I/usr/include/openssl-1.0"
+ export LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl"
./autogen.sh
./configure --prefix=/usr --with-incompatible-bdb --with-gui=no --enable-hardening \
--enable-reduce-exports --disable-gui-tests --disable-maintainer-mode