summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD62
-rw-r--r--bitcoin.conf31
-rw-r--r--bitcoin.install50
-rw-r--r--bitcoin.logrotate11
5 files changed, 5 insertions, 175 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e89ba04f8035..a49f80343d83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,35 +5,9 @@ pkgbase = bitcoin-classic-git
pkgver = v1.2.1
pkgrel = 1
url = https://bitcoinclassic.com/
- install = bitcoin.install
arch = i686
arch = x86_64
license = MIT
- makedepends = boost
- makedepends = qt5-tools
- depends = boost-libs
- depends = desktop-file-utils
- depends = libevent
- depends = qt5-base
- depends = protobuf
- depends = openssl
- depends = miniupnpc
- depends = zeromq
- depends = qrencode
- provides = bitcoin-daemon
- provides = bitcoin-cli
- provides = bitcoin-qt
- provides = bitcoin-tx
- conflicts = bitcoin-daemon
- conflicts = bitcoin-cli
- conflicts = bitcoin-qt
- conflicts = bitcoin-tx
- source = git+https://github.com/bitcoinclassic/bitcoinclassic.git#branch=develop
- source = bitcoin.logrotate
- source = bitcoin.conf
- sha256sums = SKIP
- sha256sums = 7bf4bdad419c1ee30b88c7e4190707c5ff250da8b23d68d5adf14043f8e2ac73
- sha256sums = c8787560c6423605796c8d3e080cb522ed849cea12b5c23293c22e405a015a53
pkgname = bitcoin-classic-git
diff --git a/PKGBUILD b/PKGBUILD
index 2b127a6b8f6a..044480119180 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,67 +1,15 @@
# Maintainer: Tom Zander
-pkgname=bitcoin-classic-git
-pkgver=git
+pkgname=bitcoin-classic
+pkgver=1.3.8
pkgrel=1
-pkgdesc='Bitcoin Classic versions of Bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt, most recent stable branch, w/GUI and wallet'
+pkgdesc='Bitcoin Classic with bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt'
arch=('i686' 'x86_64')
url="https://bitcoinclassic.com/"
license=('MIT')
-depends=('boost-libs' 'libevent' 'desktop-file-utils' 'qt5-base' 'protobuf' 'openssl' 'miniupnpc' 'zeromq' 'qrencode')
-makedepends=('boost' 'qt5-tools')
-provides=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
-conflicts=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
-backup=("etc/bitcoin/bitcoin.conf")
-install=bitcoin.install
-source=("git+https://github.com/bitcoinclassic/bitcoinclassic.git#branch=master"
- "bitcoin.logrotate"
- "bitcoin.conf")
-sha256sums=('SKIP'
- "7bf4bdad419c1ee30b88c7e4190707c5ff250da8b23d68d5adf14043f8e2ac73"
- "c8787560c6423605796c8d3e080cb522ed849cea12b5c23293c22e405a015a53")
-
-pkgver() {
- cd "$srcdir/bitcoinclassic"
- git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
-}
-
-build() {
- cd "$srcdir/bitcoinclassic"
-
- ./autogen.sh
- ./configure --prefix=/usr --with-incompatible-bdb --with-gui=qt5 --enable-hardening \
- --enable-reduce-exports --disable-gui-tests --disable-maintainer-mode
- make
-}
-
-check() {
- "bitcoinclassic/src/test/test_bitcoin"
-}
package() {
- cd "bitcoinclassic"
-
- install -Dm755 "src/qt/bitcoin-qt" "$pkgdir/usr/bin/bitcoin-qt"
- install -Dm644 "share/pixmaps/bitcoin128.png" "$pkgdir/usr/share/pixmaps/bitcoin128.png"
- install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname"
- install -Dm644 "contrib/debian/bitcoin-qt.desktop" "$pkgdir/usr/share/applications/bitcoin.desktop"
-
- install -Dm644 "contrib/debian/examples/bitcoin.conf"\
- -t "$pkgdir/usr/share/doc/bitcoin/examples"
- install -Dm644 "contrib/debian/manpages/bitcoind.1"\
- -t "$pkgdir/usr/share/man/man1"
- install -Dm644 "contrib/debian/manpages/bitcoin.conf.5"\
- -t "$pkgdir/usr/share/man/man5"
-
- install -Dm 664 "$srcdir/bitcoin.conf" -t "$pkgdir/etc/bitcoin"
- sed 's/python2/python/' <share/rpcuser/rpcuser.py >rpcuser.py
- install -Dm 755 rpcuser.py -t "$pkgdir/etc/bitcoin"
- install -Dm 644 "contrib/init/bitcoind.service" -t "$pkgdir/usr/lib/systemd/system"
- install -Dm 644 "$srcdir/bitcoin.logrotate" "$pkgdir/etc/logrotate.d/bitcoin"
-
- install -Dm 644 contrib/bitcoind.bash-completion \
- "$pkgdir/usr/share/bash-completion/completions/bitcoind"
-
- install -Dm755 "src/bitcoind" "src/bitcoin-cli" "src/bitcoin-tx" -t "$pkgdir/usr/bin"
+ echo "******* Classic is discontinued http://bitcoinclassic.com/news/closing.html"
+ exit 1
}
diff --git a/bitcoin.conf b/bitcoin.conf
deleted file mode 100644
index 8d6e980515c3..000000000000
--- a/bitcoin.conf
+++ /dev/null
@@ -1,31 +0,0 @@
-# See a longer example at; /usr/share/doc/bitcoin/examples/bitcoin.conf
-
-# Defaults that are also passed in by systemd
-datadir=/var/lib/bitcoind
-pid=/var/lib/bitcoind/bitcoind.pid
-disablewallet=1
-
-# make the cookie go to /etc/bitcoin
-rpccookiefile=/etc/bitcoin/.cookie
-# make sure the cookie is readable by users able to read /etc/bitcoin
-sysperms=1
-
-# --rpcauth--
-# There additionally is the config option "rpcauth" to allow
-# multiple different users to use different credentials for login.
-#
-# The config option comes in the format:
-# rpcauth=USERNAME:SALT$HASH
-#
-# Where:
-# 1-USERNAME is desired username. Name doesn't have to be unique.
-# 2-SALT is the salt for the HMAC_SHA256 function
-# 3-HASH is a hex string that is the result of the HMAC_SHA256
-# function on the user's secret password plus the SALT as the key.
-#
-# A "canonical" password generating python script has been supplied
-# at "/etc/bitcoin/rpcuser.py". From the client-side, one connects
-# using the standard -rpcuser/-rpcpassword options.
-#
-# How to create an RPC user login credential.
-# $ python2 /etc/bitcoin/rpcuser.py <username>
diff --git a/bitcoin.install b/bitcoin.install
deleted file mode 100644
index a42cd1eea7e8..000000000000
--- a/bitcoin.install
+++ /dev/null
@@ -1,50 +0,0 @@
-_bc_user=bitcoin
-_bc_group=bitcoin
-
-post_install() {
- _mkuser
- _dir="/var/lib/bitcoind"
- _cnf="/etc/bitcoin"
- if test ! -d "$_dir"; then
- mkdir -m 750 "$_dir"
- # disable Copy-On-Write (btrfs directories only)
- # This avoids lots of known db-corruption issues
- _is_btrfs "$_dir" && chattr +C "$_dir"
- fi
- chown -R $_bc_user:$_bc_group "$_dir" "$_cnf"
- chmod 775 "$_cnf"
- printf "%b\n" "$bitcoin"
-}
-
-post_upgrade() {
- _mkuser
- printf "%b\n" "$bitcoin"
-}
-
-
-# ------------------------------------------------------------------------------
-# helper functions for creating bitcoin user / group
-# ------------------------------------------------------------------------------
-
-_mkuser() {
- getent passwd $_bc_user &>/dev/null || {
- echo -n "Creating bitcoin user... "
- grep -E "^$_bc_group:" /etc/group >/dev/null || groupadd $_bc_group
- useradd -m -d /etc/bitcoin -g $_bc_group -s /usr/bin/nologin $_bc_user 2>/dev/null
- echo "done"
- }
-}
-
-# ------------------------------------------------------------------------------
-# helper functions for disabling btrfs Copy-On-Write (CoW)
-# https://wiki.archlinux.org/index.php/Btrfs#Copy-On-Write_.28CoW.29
-# ------------------------------------------------------------------------------
-
-# check if dir is btrfs
-_is_btrfs() {
- if [[ $(findmnt --target $1 --output FSTYPE --noheadings) == 'btrfs' ]]; then
- return 0
- else
- return 1
- fi
-}
diff --git a/bitcoin.logrotate b/bitcoin.logrotate
deleted file mode 100644
index 159f63f266ce..000000000000
--- a/bitcoin.logrotate
+++ /dev/null
@@ -1,11 +0,0 @@
-/var/lib/bitcoind/debug.log
-{
- rotate 5
- copytruncate
- daily
- missingok
- notifempty
- compress
- delaycompress
- sharedscripts
-}