summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
-rw-r--r--bitcoin-scrypt-git-boost.patch12
3 files changed, 27 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1042af8de865..69e9a43bbc10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitcoin-scrypt-git-daemon
pkgdesc = Bitcoin Scrypt is a decentralised currency and using the Scrypt algorithm - daemon
- pkgver = 20140107.2ba1ffc
+ pkgver = 20150909.815a15f
pkgrel = 1
url = http://bitcoinscrypt.org/
arch = i686
@@ -8,14 +8,15 @@ pkgbase = bitcoin-scrypt-git-daemon
license = MIT
makedepends = boost
makedepends = automoc4
- makedepends = qrencode
- makedepends = miniupnpc
depends = boost-libs
+ depends = qrencode
depends = miniupnpc
- depends = openssl
+ depends = openssl-1.0
provides = bitcoin-scrypt-daemon
- source = bitcoin-scrypt::git://github.com/Omega6/Bitcoin-Scrypt.git
+ source = bitcoin-scrypt::git://github.com/bitcoin-scrypt/bitcoin-scrypt
+ source = bitcoin-scrypt-git-boost.patch
sha256sums = SKIP
+ sha256sums = 740ea08338d7c60338a79a4f56a5f9cb8509a0cf1f1077f7b42f9cde74009f52
pkgname = bitcoin-scrypt-git-daemon
provides = bitcoin-scrypt-daemon
diff --git a/PKGBUILD b/PKGBUILD
index 43bfad638bc9..20de07c44d8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,21 @@
# Donate BTCS: 13xcw57QyS8h6GuxtbatAH9S6igwytd7Uo
pkgname="bitcoin-scrypt-git-daemon"
pkgdesc="Bitcoin Scrypt is a decentralised currency and using the Scrypt algorithm - daemon"
-pkgver=20140107.2ba1ffc
+pkgver=20150909.815a15f
pkgrel=1
arch=("i686" "x86_64")
url="http://bitcoinscrypt.org/"
license=("MIT")
-depends=("boost-libs" "miniupnpc" "openssl")
-makedepends=("boost" "automoc4" "qrencode" "miniupnpc")
+depends=("boost-libs" "qrencode" "miniupnpc" "openssl-1.0")
+makedepends=("boost" "automoc4")
provides=("bitcoin-scrypt-daemon")
source=(
- "bitcoin-scrypt::git://github.com/Omega6/Bitcoin-Scrypt.git"
+ "bitcoin-scrypt::git://github.com/bitcoin-scrypt/bitcoin-scrypt"
+ "bitcoin-scrypt-git-boost.patch"
)
sha256sums=(
"SKIP"
+ "740ea08338d7c60338a79a4f56a5f9cb8509a0cf1f1077f7b42f9cde74009f52"
)
pkgver() {
@@ -24,8 +26,9 @@ pkgver() {
build() {
cd "${srcdir}/bitcoin-scrypt"
- qmake-qt4 USE_QRCODE=1 USE_DBUS=1 USE_UPNP=1 Bitcoin-sCrypt.pro
- make -f makefile.unix -C src CXXFLAGS="${CXXFLAGS}"
+ patch -Np1 -i ../bitcoin-scrypt-git-boost.patch
+ qmake-qt4 USE_QRCODE=1 USE_DBUS=1 USE_UPNP=1 OPENSSL_INCLUDE_PATH=/usr/include/openssl-1.0 OPENSSL_LIB_PATH=/usr/lib/openssl-1.0 Bitcoin-sCrypt.pro
+ OPENSSL_INCLUDE_PATH=/usr/include/openssl-1.0 OPENSSL_LIB_PATH=/usr/lib/openssl-1.0 make -f makefile.unix -C src CXXFLAGS="${CXXFLAGS}"
}
package() {
diff --git a/bitcoin-scrypt-git-boost.patch b/bitcoin-scrypt-git-boost.patch
new file mode 100644
index 000000000000..a32050a05d12
--- /dev/null
+++ b/bitcoin-scrypt-git-boost.patch
@@ -0,0 +1,12 @@
+diff -Nur bitcoin-scrypt/src/net.cpp bitcoin-scrypt-boost/src/net.cpp
+--- bitcoin-scrypt/src/net.cpp 2017-06-19 14:18:02.809218054 +0200
++++ bitcoin-scrypt-boost/src/net.cpp 2017-06-19 14:17:37.272436173 +0200
+@@ -50,7 +50,7 @@
+ static bool vfLimited[NET_MAX] = {};
+ static CNode* pnodeLocalHost = NULL;
+ uint64 nLocalHostNonce = 0;
+-array<int, THREAD_MAX> vnThreadsRunning;
++boost::array<int, THREAD_MAX> vnThreadsRunning;
+ static std::vector<SOCKET> vhListenSocket;
+ CAddrMan addrman;
+