summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD33
-rw-r--r--bitcore-qt.desktop11
-rw-r--r--bitcore-qt.install11
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..550ff196f6ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = bitcore-qt
+ pkgdesc = Cryptocurrency wallet(QT)
+ pkgver = 0.15.0
+ pkgrel = 3
+ url = https://bitcore.cc/
+ install = bitcore-qt.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = qt5-tools
+ depends = boost-libs
+ depends = qt5-base
+ depends = qrencode
+ depends = miniupnpc
+ depends = db4.8
+ depends = zeromq
+ depends = protobuf
+ depends = libevent
+ conflicts = bitcore
+ source = bitcore-qt::git+http://github.com/LIMXTEC/BitCore.git
+ source = bitcore-qt.desktop
+ sha256sums = SKIP
+ sha256sums = 1a3504e2daf78f7dd86fcca457f08dc97272d5a4d68ce5cc20c64c8d0807c07f
+
+pkgname = bitcore-qt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47e648a09a81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: metscoin <mets_coin@outlook.com>
+
+pkgname=bitcore-qt
+pkgver=0.15.0
+pkgrel=3
+arch=('i686' 'x86_64')
+url="https://bitcore.cc/"
+license=('MIT')
+pkgdesc="Cryptocurrency wallet(QT)"
+depends=(boost-libs qt5-base qrencode miniupnpc db4.8 zeromq protobuf libevent)
+makedepends=(boost qt5-tools)
+conflicts=(bitcore)
+install=bitcore-qt.install
+source=("${pkgname%-git}::git+http://github.com/LIMXTEC/BitCore.git"
+ "$pkgname.desktop")
+sha256sums=('SKIP'
+ '1a3504e2daf78f7dd86fcca457f08dc97272d5a4d68ce5cc20c64c8d0807c07f')
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh
+ ./configure --with-gui=qt5
+ make
+}
+
+
+package() {
+ install -Dm644 bitcore-qt.desktop "$pkgdir"/usr/share/applications/bitcore.desktop
+ cd "$srcdir/$pkgname"
+ install -Dm755 src/qt/bitcore-qt "$pkgdir"/usr/bin/bitcore-qt
+ install -Dm644 share/pixmaps/bitcore128.png "$pkgdir"/usr/share/pixmaps/bitcore128.png
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/bitcore-qt.desktop b/bitcore-qt.desktop
new file mode 100644
index 000000000000..4950a67763ed
--- /dev/null
+++ b/bitcore-qt.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Bitcore
+Comment=Bitcore P2P Cryptocurrency
+Exec=/usr/bin/bitcore-qt
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/bitcore128.png
+MimeType=x-scheme-handler/bitcore;
+Categories=Office;
+Name[en_US]=bitcore-qt.desktop
diff --git a/bitcore-qt.install b/bitcore-qt.install
new file mode 100644
index 000000000000..f98ba7338938
--- /dev/null
+++ b/bitcore-qt.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}