summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD53
-rw-r--r--bitfighter.desktop8
-rw-r--r--bitfighter.install11
-rw-r--r--bitfighter.pngbin0 -> 1458 bytes
5 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd0e5126a719
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by makepkg 4.2.1
+# Sun May 17 22:26:35 UTC 2015
+pkgbase = bitfighter
+ pkgdesc = A fast-paced team-based outer-space multi-player combat game
+ pkgver = 0.19e
+ pkgrel = 1
+ url = http://bitfighter.org/
+ install = bitfighter.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = libmariadbclient
+ makedepends = glu
+ depends = sdl2
+ depends = libpng
+ depends = libvorbis
+ depends = libmodplug
+ depends = openal
+ depends = speex
+ source = http://bitfighter.org/files/bitfighter-019e.tar.gz
+ source = https://bitfighter.googlecode.com/files/classic_level_pack.zip
+ source = bitfighter.png
+ source = bitfighter.desktop
+ md5sums = 66ff2a80f4ffd7cd354667e906323759
+ md5sums = cb32039b47026e176d3f1f3639bd1a9f
+ md5sums = 8b28490af9deadd0a1a104ae372f5b08
+ md5sums = 657e0ff146dd3dac682e15be5a74fbf0
+
+pkgname = bitfighter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6d58fc8bb88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Larry Hajali <larryhaja[at]gmail[dot]com>
+# Contributor: carstene1ns <arch carsten-teibes de>
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: archtux <antonio.arias99999 at gmail.com>
+
+pkgname=bitfighter
+pkgver=0.19e
+pkgrel=1
+pkgdesc="A fast-paced team-based outer-space multi-player combat game"
+arch=('i686' 'x86_64')
+url="http://bitfighter.org/"
+license=('GPL')
+depends=('sdl2' 'libpng' 'libvorbis' 'libmodplug' 'openal' 'speex')
+makedepends=('cmake' 'libmariadbclient' 'glu')
+install=${pkgname}.install
+source=("http://${pkgname}.org/files/${pkgname}-${pkgver/./}.tar.gz"
+ "https://$pkgname.googlecode.com/files/classic_level_pack.zip"
+ "$pkgname.png"
+ "$pkgname.desktop")
+md5sums=('66ff2a80f4ffd7cd354667e906323759'
+ 'cb32039b47026e176d3f1f3639bd1a9f'
+ '8b28490af9deadd0a1a104ae372f5b08'
+ '657e0ff146dd3dac682e15be5a74fbf0')
+
+build() {
+ cd ${pkgname}-${pkgver/./}/build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX:PATH="/usr" \
+ -DUSE_SDL2:BOOL=YES \
+ -DUSE_GLES:BOOL=YES \
+ -DCMAKE_BUILD_TYPE=Release \
+ ..
+
+ make VERBOSE=1
+}
+
+package() {
+ cd $pkgname-${pkgver/./}
+
+ # install game ressources and executable
+ install -d "$pkgdir"/usr/share/$pkgname "$pkgdir"/usr/bin
+ cp "${srcdir}"/classic_level_pack/* resource/levels
+ cp -r resource/* exe/*.ini "$pkgdir"/usr/share/$pkgname
+ install -m755 exe/$pkgname "$pkgdir"/usr/bin/$pkgname
+
+ # install a desktop entry
+ install -Dm644 ../$pkgname.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+
+ # install documentation and license
+ install -Dm644 doc/README.txt "$pkgdir"/usr/share/doc/$pkgname/README
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/bitfighter.desktop b/bitfighter.desktop
new file mode 100644
index 000000000000..6e1f283e1f27
--- /dev/null
+++ b/bitfighter.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Bitfighter
+Comment=A free multiplayer 2-D space combat game with Robotron-like controls
+Exec=bitfighter
+Icon=bitfighter
+Terminal=false
+Categories=Game;ArcadeGame;
diff --git a/bitfighter.install b/bitfighter.install
new file mode 100644
index 000000000000..5e5cfef4d9f6
--- /dev/null
+++ b/bitfighter.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-desktop-database -q
+}
diff --git a/bitfighter.png b/bitfighter.png
new file mode 100644
index 000000000000..a124290c2db7
--- /dev/null
+++ b/bitfighter.png
Binary files differ