summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
-rw-r--r--bitsquare.desktop9
-rw-r--r--bitsquare.sh2
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cae6d17d4d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = bitsquare-git
+ pkgdesc = Bitsquare is a cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges
+ pkgver = v0.3.1.r6.g6db8157
+ pkgrel = 1
+ url = https://bitsquare.io/
+ arch = x86_64
+ license = AGPL3
+ makedepends = maven
+ makedepends = openjfx
+ depends = bash
+ depends = java-runtime-openjdk=8
+ provides = bitsquare
+ source = bitsquare-git::git+https://github.com/bitsquare/bitsquare.git
+ source = bitsquare.sh
+ source = bitsquare.desktop
+ sha256sums = SKIP
+ sha256sums = b2e5e85f842f0bc9910087d62f78f5fd9fc1b6232849b59e785acbec5d8955cf
+ sha256sums = 15592a05a2a4d6cb65c757e9eec5e3818bf38e7397a3b98e7651a8a3b51f9ba9
+
+pkgname = bitsquare-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5456b6931a8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: David Parrish <daveparrish@gmail.com>
+
+pkgname=bitsquare-git
+pkgver=v0.3.1.r6.g6db8157
+pkgrel=1
+pkgdesc="Bitsquare is a cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges"
+arch=('x86_64')
+url="https://bitsquare.io/"
+license=('AGPL3')
+depends=('bash' 'java-runtime-openjdk=8')
+makedepends=('maven' 'openjfx')
+provides=('bitsquare')
+source=("${pkgname}::git+https://github.com/bitsquare/bitsquare.git"
+ "bitsquare.sh"
+ "bitsquare.desktop")
+sha256sums=('SKIP'
+ 'b2e5e85f842f0bc9910087d62f78f5fd9fc1b6232849b59e785acbec5d8955cf'
+ '15592a05a2a4d6cb65c757e9eec5e3818bf38e7397a3b98e7651a8a3b51f9ba9')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ mvn package
+}
+
+package() {
+ # Install executable.
+ install -D -m755 "bitsquare.sh" "${pkgdir}/usr/bin/bitsquare"
+ install -D -m644 "${srcdir}/${pkgname}/gui/target/shaded.jar" "${pkgdir}/usr/share/java/bitsquare/shaded.jar"
+
+ # Install desktop launcher.
+ install -Dm644 bitsquare.desktop "${pkgdir}/usr/share/applications/bitsquare.desktop"
+ install -Dm644 "${srcdir}/${pkgname}/package/linux/icon.png" "${pkgdir}/usr/share/pixmaps/bitsquare.png"
+}
diff --git a/bitsquare.desktop b/bitsquare.desktop
new file mode 100644
index 000000000000..d1bfc57c419f
--- /dev/null
+++ b/bitsquare.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Bitsquare
+GenericName=P2P Bitcoin Exchange
+Comment=Bitsquare is a cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges
+Exec=/usr/bin/bitsquare
+Icon=/usr/share/pixmaps/bitsquare.png
+Terminal=false
+Type=Application
+Categories=Utility;Finance;
diff --git a/bitsquare.sh b/bitsquare.sh
new file mode 100644
index 000000000000..268195b8712d
--- /dev/null
+++ b/bitsquare.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec "$JAVA_HOME/bin/java" -jar /usr/share/java/bitsquare/shaded.jar "$@"