summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.editorconfig20
-rw-r--r--.gitignore6
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD23
-rw-r--r--bizhawk-monort.install2
6 files changed, 53 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9a8dc330053..e2de40ce4e81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = bizhawk-monort
pkgdesc = A multi-system emulator on .NET. Features rerecording and tools for TASing. (Mono runtime)
- pkgver = 2.5.2
- pkgrel = 1
+ pkgver = 2.9.1
+ pkgrel = 2
url = https://gitlab.com/TASVideos/BizHawk#readme
+ install = bizhawk-monort.install
arch = x86_64
license = MIT
license = custom
- makedepends = dotnet-sdk>=5.0.0
depends = glibc
depends = lsb-release
- depends = mono>=6.10
+ depends = lua
+ depends = mono>=6.12
depends = openal
- optdepends = antimicro: to use unsupported controllers as keyboards
- optdepends = ffmpeg: to use built-in A/V capture, unstable
- provides = bizhawk=2.5.2
- source = https://github.com/TASVideos/BizHawk/releases/download/2.5.2/BizHawk-2.5.2.zip
- sha512sums = 9e4cdf5e2e311ca5ad5750b91ea5163d8e727813f9a88200d80013657c45b33b0a51112fd5816debe264b99b1244b8555c0f8b9eccfc6f87c45e67bbd1c28b06
+ optdepends = antimicro: to use unsupported controllers (by mapping to the keyboard)
+ provides = bizhawk=2.9.1
+ source = https://github.com/TASVideos/BizHawk/releases/download/2.9.1/BizHawk-2.9.1-linux-x64.tar.gz
+ sha512sums = bec7e558963416b3749ef558bc682d1a874a43df8fe3083224ec7c4c0326cdfea662ef5c604eea7c1743d2eeb13656ccf749f0cdb3a413f4985c4b305a95e742
pkgname = bizhawk-monort
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..29215c86a3df
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,20 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
+
+[*.json]
+indent_size = 2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9a3601c418fe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/.vscode/
+/src
+/pkg
+*.log
+*.pkg.*
+*.tar.*
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..552571b19757
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[bizhawk-monort]
+source = "github"
+github = "TASVideos/BizHawk"
+use_latest_release = true
diff --git a/PKGBUILD b/PKGBUILD
index fa9d4815ee06..d112287739f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,28 @@
-# Maintainer: James Groom <OSSYoshiRulz at gmail dot com>
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+# Contributor: James Groom <OSSYoshiRulz at gmail dot com>
pkgname=bizhawk-monort
_providesName=bizhawk
-pkgver=2.5.2
-_archiveName="BizHawk-2.5.2"
-pkgrel=1
+pkgver=2.9.1
+_archiveName="BizHawk-$pkgver-linux-x64.tar.gz"
+pkgrel=2
pkgdesc="A multi-system emulator on .NET. Features rerecording and tools for TASing. (Mono runtime)"
arch=("x86_64")
url="https://gitlab.com/TASVideos/BizHawk#readme"
license=("MIT" "custom")
-depends=("glibc" "lsb-release" "mono>=6.10" "openal")
+depends=("glibc" "lsb-release" "lua" "mono>=6.12" "openal")
optdepends=(
- "antimicro: to use unsupported controllers as keyboards"
- "ffmpeg: to use built-in A/V capture, unstable"
+ "antimicro: to use unsupported controllers (by mapping to the keyboard)"
)
-makedepends=("dotnet-sdk>=5.0.0")
provides=("$_providesName=$pkgver")
-source=("https://github.com/TASVideos/BizHawk/releases/download/$pkgver/$_archiveName.zip")
-sha512sums=("9e4cdf5e2e311ca5ad5750b91ea5163d8e727813f9a88200d80013657c45b33b0a51112fd5816debe264b99b1244b8555c0f8b9eccfc6f87c45e67bbd1c28b06")
+install="bizhawk-monort.install"
+source=("https://github.com/TASVideos/BizHawk/releases/download/$pkgver/$_archiveName")
+sha512sums=("bec7e558963416b3749ef558bc682d1a874a43df8fe3083224ec7c4c0326cdfea662ef5c604eea7c1743d2eeb13656ccf749f0cdb3a413f4985c4b305a95e742")
package() {
cd "$srcdir"
+ mkdir opt
+ tar -xf BizHawk*.tar.gz -C opt
+ cd opt
find . -type d -exec install -D -ggames -m775 -d "$pkgdir/opt/$_providesName/{}" \;
find . -type f -not -name *.sh -exec install -D -ggames -m664 "{}" "$pkgdir/opt/$_providesName/{}" \;
find . -type f -name *.sh -exec install -D -ggames -m774 "{}" "$pkgdir/opt/$_providesName/{}" \;
diff --git a/bizhawk-monort.install b/bizhawk-monort.install
index a6d439503cb2..fc0af2f35a86 100644
--- a/bizhawk-monort.install
+++ b/bizhawk-monort.install
@@ -1,3 +1,3 @@
post_install() {
- printf "%s\n" "Make sure you are in the games group (usermod -aG games \$(id -nu))."
+ printf "%s\n%s\n" "Make sure you are in the games group (usermod -aG games \$(id -nu))!" "The start script is /opt/bizhawk/EmuHawkMono.sh"
}