summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
-rw-r--r--bkchem.desktop18
-rw-r--r--bkchem.install6
4 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7707b8985d67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = bkchem
+ pkgdesc = Chemical drawing program
+ pkgver = 0.14.0_pre2
+ pkgrel = 3
+ url = http://bkchem.zirael.org
+ install = bkchem.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = tcl
+ depends = tk
+ optdepends = pycairo: alternative PNG/PDF export
+ optdepends = inchi: InChI generation
+ source = http://bkchem.zirael.org/download/bkchem-0.14.0-pre2.tar.gz
+ source = bkchem.install
+ source = bkchem.desktop
+ sha1sums = 9c17e8cbd0443d55b82c32f27f5965dd014033c5
+ sha1sums = eeb36aefd2b680ff018bb0f7ac55b7b6a45f564e
+ sha1sums = 0ec695c51ac51092d6665e3ccb14d4f53d7af3aa
+
+pkgname = bkchem
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5afaf7bc6a86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Xyne
+# Contributor: Michal Bozon <michal.bozon__at__gmail.com>
+pkgname=bkchem
+pkgver=0.14.0_pre2
+pkgver_=0.14.0-pre2
+pkgrel=3
+pkgdesc="Chemical drawing program"
+arch=('i686' 'x86_64')
+url="http://bkchem.zirael.org"
+license=('GPL')
+depends=('python2' 'tcl' 'tk')
+source=(http://bkchem.zirael.org/download/$pkgname-$pkgver_.tar.gz
+ bkchem.install
+ bkchem.desktop)
+install=bkchem.install
+optdepends=("pycairo: alternative PNG/PDF export"
+ "inchi: InChI generation")
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver_"
+ # Update for Python2
+ sed -i 's/python/python2/g' setup.py
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver_"
+ python2 setup.py install \
+ --prefix=/usr \
+ --root="$pkgdir" \
+ --strip="$pkgdir"
+ install -Dm644 "$srcdir/$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
+
+sha1sums=('9c17e8cbd0443d55b82c32f27f5965dd014033c5'
+ 'eeb36aefd2b680ff018bb0f7ac55b7b6a45f564e'
+ '0ec695c51ac51092d6665e3ccb14d4f53d7af3aa')
diff --git a/bkchem.desktop b/bkchem.desktop
new file mode 100644
index 000000000000..830fb59bb9a3
--- /dev/null
+++ b/bkchem.desktop
@@ -0,0 +1,18 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=BKchem
+GenericName=Structural formulas
+GenericName[de]=Strukturformeln
+GenericName[fr]=Formules développées
+GenericName[nl]=Structuurformule
+Comment=2D chemical structure formula editor for molecules
+Comment[de]=2D-Strukturformeln für Moleküle zeichnen
+Comment[fr]=Dessiner des formules développées planes
+Icon=/usr/share/bkchem/images/bkchem.png
+Exec=/usr/bin/bkchem
+Path=~
+Terminal=false
+MimeType=image/svg+xml;text/xml;
+Categories=Science;Chemistry;
+StartupNotify=true
diff --git a/bkchem.install b/bkchem.install
new file mode 100644
index 000000000000..ca0ec4d58254
--- /dev/null
+++ b/bkchem.install
@@ -0,0 +1,6 @@
+post_install() {
+ cat << EOT
+==> To enable InChI/InChIKey string generation in BKChem, you must install
+==> inchi and set the corresponding InChI binary path under the options menu.
+EOT
+}