summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8da2f4c80e90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Feb 8 03:39:29 UTC 2016
+pkgbase = bkeyd
+ pkgdesc = Lightweight hot-key daemon independent of X
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://sourceforge.net/projects/bkeyd
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = linux-api-headers
+ source = http://sourceforge.net/projects/bkeyd/files/bkeyd-0.1.0.tar.gz
+ md5sums = 05807e2007173619153704e84257c272
+
+pkgname = bkeyd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ab7636b8288
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Benjamin Bolton benjamin@bennybolton.com
+
+pkgname=bkeyd
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Lightweight hot-key daemon independent of X"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/bkeyd"
+license=('GPL')
+makedepends=(linux-api-headers)
+source=("http://sourceforge.net/projects/bkeyd/files/bkeyd-$pkgver.tar.gz")
+md5sums=('05807e2007173619153704e84257c272')
+
+build(){
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package(){
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}