summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--blackeye.patch13
-rw-r--r--blackeye.patch.sigbin566 -> 566 bytes
4 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd0fb8cb1ba0..ca55c459584d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = blackeye-git
pkgdesc = The most complete phishing tool - 38 website templates, updated version with ngrok
pkgver = 2020.10.07.g2304100
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/x3rz/blackeye
install = blackeye.install
arch = any
license = GPL3
makedepends = git
depends = php
- depends = wget
optdepends = ngrok: if not installed, the binary will be downloaded into the user cache
+ optdepends = wget: used to download the ngrok binary if none is found
provides = blackeye
conflicts = blackeye
source = git+https://github.com/x3rz/blackeye.git
@@ -17,7 +17,7 @@ pkgbase = blackeye-git
source = blackeye.patch.sig
validpgpkeys = 7A194E3F7A8F867BEA8A5339023F078862ACFE50
sha256sums = SKIP
- sha256sums = 2f30f40f2246ae77a987da5f9a9430411e4cdf00ab1a3694b1f22c19af91ee70
+ sha256sums = b520c32fdb2a053b2c5c9c7a13452ba360a48f6c66aeaac87b47b6d293b2e167
sha256sums = SKIP
pkgname = blackeye-git
diff --git a/PKGBUILD b/PKGBUILD
index be521cfbd0e6..3a38dbb05fff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=blackeye-git
pkgver() { git -C "${pkgname%-git}" log -n1 --format=%cs.g%h | tr - .; }
pkgver=2020.10.07.g2304100
-pkgrel=1
+pkgrel=2
pkgdesc='The most complete phishing tool - 38 website templates, updated version with ngrok'
arch=('any')
@@ -13,15 +13,16 @@ url="https://github.com/x3rz/${pkgname%-git}"
license=('GPL3')
makedepends=('git')
-depends=('php' 'wget')
-optdepends=('ngrok: if not installed, the binary will be downloaded into the user cache')
+depends=('php')
+optdepends=('ngrok: if not installed, the binary will be downloaded into the user cache'
+ 'wget: used to download the ngrok binary if none is found')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
install="${pkgname%-git}.install"
source=("git+$url.git" "${pkgname%-git}.patch" "${pkgname%-git}.patch.sig")
-sha256sums=('SKIP' '2f30f40f2246ae77a987da5f9a9430411e4cdf00ab1a3694b1f22c19af91ee70' 'SKIP')
+sha256sums=('SKIP' 'b520c32fdb2a053b2c5c9c7a13452ba360a48f6c66aeaac87b47b6d293b2e167' 'SKIP')
validpgpkeys=('7A194E3F7A8F867BEA8A5339023F078862ACFE50')
@@ -40,7 +41,7 @@ package() {
cp -sufr /usr/share/${pkgname%-git} "\${XDG_CACHE_HOME:-\$HOME/.cache}/"
cd "\${XDG_CACHE_HOME:-\$HOME/.cache}/${pkgname%-git}"
- exec ./${pkgname%-git}.sh
+ ./${pkgname%-git}.sh
EOF
}
diff --git a/blackeye.patch b/blackeye.patch
index 3362a66f2013..c2d22c04f506 100644
--- a/blackeye.patch
+++ b/blackeye.patch
@@ -1,6 +1,15 @@
diff -ru --color old/blackeye.sh new/blackeye.sh
---- old/blackeye.sh 2020-12-12 17:20:20.920485939 +0100
-+++ new/blackeye.sh 2020-12-12 17:32:23.941913566 +0100
+--- old/blackeye.sh 2020-12-12 19:37:48.130378733 +0100
++++ new/blackeye.sh 2020-12-12 19:50:22.552417197 +0100
+@@ -10,7 +10,7 @@
+ dependencies() {
+
+ command -v php > /dev/null 2>&1 || { echo >&2 "I require php but it's not installed. Install it. Aborting."; exit 1; }
+-command -v wget > /dev/null 2>&1 || { echo >&2 "I require wget but it's not installed. Install it. Aborting."; exit 1; }
++{ command -v wget || command -v ngrok; } > /dev/null 2>&1 || { echo >&2 "I require either ngrok or wget but neither of them is installed. Install one of those. Aborting."; exit 1; }
+ command -v unzip > /dev/null 2>&1 || { echo >&2 "I require unzip but it's not installed. Install it. Aborting."; exit 1; }
+ command -v curl > /dev/null 2>&1 || { echo >&2 "I require curl but it's not installed. Install it. Aborting."; exit 1; }
+
@@ -18,15 +18,15 @@
menu() {
diff --git a/blackeye.patch.sig b/blackeye.patch.sig
index f6537714de60..9861b0daedd8 100644
--- a/blackeye.patch.sig
+++ b/blackeye.patch.sig
Binary files differ