summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5298463e9ec..84a101a31e7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Fri May 10 00:29:34 UTC 2019
+# Sat May 11 13:01:58 UTC 2019
pkgbase = bleachbit-cli
pkgdesc = Deletes unneeded files to free disk space and maintain privacy. CLI version/no GUI.
pkgver = 2.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.bleachbit.org/
arch = any
license = GPL3
makedepends = python
+ depends = python2
provides = bleachbit=2.2
source = https://download.bleachbit.org/bleachbit-2.2.tar.bz2
sha256sums = 0318cd1bc83655971c9ffd6bf27f4866bbe57381e92cfbcf8a2a6833075b49fa
diff --git a/PKGBUILD b/PKGBUILD
index 0154e934f23c..96136a4f0857 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,13 @@
pkgname=bleachbit-cli
_pkgname=bleachbit
pkgver=2.2
-pkgrel=1
+pkgrel=2
pkgdesc='Deletes unneeded files to free disk space and maintain privacy. CLI version/no GUI.'
provides=("bleachbit=${pkgver}")
arch=(any)
url='https://www.bleachbit.org/'
license=(GPL3)
+depends=(python2)
makedepends=(python)
source=(https://download.bleachbit.org/$_pkgname-$pkgver.tar.bz2)
sha256sums=('0318cd1bc83655971c9ffd6bf27f4866bbe57381e92cfbcf8a2a6833075b49fa')
@@ -23,8 +24,8 @@ package() {
cd $_pkgname-$pkgver
make prefix=/usr DESTDIR="$pkgdir" PYTHON=python2 install
-
- # suggestion by Meow to force script to operate in cli mode
- sed -i 's/if 1/if 0/' "$pkgdir"/usr/bin/bleachbit
- rm -rf "$pkgdir"/usr/share/{applications,pixmaps}
+
+ # suggestion by Meow to force script to operate in cli mode
+ sed -i 's/if 1/if 0/' "$pkgdir"/usr/bin/bleachbit
+ rm -rf "$pkgdir"/usr/share/{applications,pixmaps}
}