summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
-rw-r--r--blender-ac3d.install3
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b5c169385d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = blender-ac3d
+ pkgdesc = AC3D (.ac) File format import/export within blender
+ pkgver = 20131105
+ pkgrel = 3
+ url = https://github.com/majic79/Blender-AC3D
+ install = blender-ac3d.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = blender
+ source = git://github.com/majic79/Blender-AC3D.git
+ md5sums = SKIP
+
+pkgname = blender-ac3d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5058949ce9dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: nic96 <jeromyreimer at gmail dot com>
+
+pkgname=blender-ac3d
+pkgver=20131105
+pkgrel=3
+pkgdesc="AC3D (.ac) File format import/export within blender"
+arch=('i686' 'x86_64')
+url="https://github.com/majic79/Blender-AC3D"
+depends=('python' 'blender')
+makedepends=('git')
+blender_version="`blender --version | head -n 1 | sed 's/.*\([0-9].[0-9][0-9]\).*/\1/g'`"
+license=('GPL')
+install='blender-ac3d.install'
+source=("git://github.com/majic79/Blender-AC3D.git")
+md5sums=('SKIP')
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/blender/$blender_version/scripts/addons
+ cp -r ${srcdir}/Blender-AC3D/io_scene_ac3d/ ${pkgdir}/usr/share/blender/$blender_version/scripts/addons/
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/blender-ac3d.install b/blender-ac3d.install
new file mode 100644
index 000000000000..4e444863dcc6
--- /dev/null
+++ b/blender-ac3d.install
@@ -0,0 +1,3 @@
+post_install() {
+echo "To use this script you need to enable it in Blender - open the user preferences window (File->User Preferences or Ctrl-Alt-U) and then go to the Add-on tab, click the button for Import-Export and then check the box on the right of \"Import-Export: AC3D (.ac)\""
+}