summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--collada1668.patch72
3 files changed, 83 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 807d90f690d9..1c8096709317 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = blender-fracture_modifier-git
pkgdesc = Development version of Blenders fracture_modifier branch
- pkgver = v2.79b.r2130.g9a21afd18d4
+ pkgver = v2.79b.r2154.gc8d6bba3cce
pkgrel = 1
url = http://blender.org/
install = blender.install
@@ -47,6 +47,7 @@ pkgbase = blender-fracture_modifier-git
source = version.patch
source = ffmpeg.patch
source = openvdb.patch
+ source = collada1668.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
@@ -59,6 +60,7 @@ pkgbase = blender-fracture_modifier-git
md5sums = 975cef0e17c77517ed8727701abc8a0c
md5sums = bb325c8c879d677ad1f1c54797268716
md5sums = fe709e616e52c1acc47c1cc0f77c2694
+ md5sums = 4e4423315f07bc724c7703c57c4481d7
pkgname = blender-fracture_modifier-git
diff --git a/PKGBUILD b/PKGBUILD
index 076cd33b6eb7..c067184b1ff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _sufix=${_branch}
_blenver=2.81
_fragment="#branch=${_branch}"
pkgname=blender-${_sufix}-git
-pkgver=v2.79b.r2130.g9a21afd18d4
+pkgver=v2.79b.r2154.gc8d6bba3cce
pkgrel=1
pkgdesc="Development version of Blenders ${_branch} branch"
arch=('i686' 'x86_64')
@@ -37,6 +37,7 @@ source=("git://git.blender.org/blender.git${_fragment}" \
version.patch \
ffmpeg.patch \
openvdb.patch \
+ collada1668.patch \
)
md5sums=('SKIP'
'SKIP'
@@ -49,7 +50,8 @@ md5sums=('SKIP'
'df6f12c3327678b0a05f9e48e9ace67c'
'975cef0e17c77517ed8727701abc8a0c'
'bb325c8c879d677ad1f1c54797268716'
- 'fe709e616e52c1acc47c1cc0f77c2694')
+ 'fe709e616e52c1acc47c1cc0f77c2694'
+ '4e4423315f07bc724c7703c57c4481d7')
# determine whether we can precompile CUDA kernels
_CUDA_PKG=`pacman -Qq cuda 2>/dev/null` || true
@@ -66,14 +68,15 @@ pkgver() {
prepare() {
cd "$srcdir/blender"
# update the submodules
- git submodule update --init --recursive
- git submodule foreach git checkout master
- git submodule foreach git pull --rebase origin master
+ git submodule update --init --recursive --remote
+# git submodule foreach git checkout master
+# git submodule foreach git pull --rebase origin master
git apply -v ${srcdir}/SelectCudaComputeArch.patch
git apply -v ${srcdir}/gcc8.patch
git apply -v ${srcdir}/ffmpeg.patch
git apply -v ${srcdir}/openvdb.patch
git apply -v ${srcdir}/version.patch
+ git apply -v ${srcdir}/collada1668.patch
}
build() {
diff --git a/collada1668.patch b/collada1668.patch
new file mode 100644
index 000000000000..535fca07dace
--- /dev/null
+++ b/collada1668.patch
@@ -0,0 +1,72 @@
+diff --git a/source/blender/collada/CMakeLists.txt b/source/blender/collada/CMakeLists.txt
+index 293049a1a05..c250384b989 100644
+--- a/source/blender/collada/CMakeLists.txt
++++ b/source/blender/collada/CMakeLists.txt
+@@ -25,6 +25,18 @@
+
+ remove_strict_flags()
+
++FIND_FILE(_opencollada_with_animation_clip
++ NAMES
++ COLLADAFWAnimationClip.h
++ PATHS
++ ${OPENCOLLADA_INCLUDE_DIRS}
++ NO_DEFAULT_PATH
++ )
++
++IF(_opencollada_with_animation_clip)
++ add_compile_definitions(OPENCOLLADA_WITH_ANIMATION_CLIP)
++ENDIF()
++
+ set(INC
+ .
+ ../blenkernel
+diff --git a/source/blender/collada/DocumentImporter.cpp b/source/blender/collada/DocumentImporter.cpp
+index 435eaa0208a..38757ff80cd 100644
+--- a/source/blender/collada/DocumentImporter.cpp
++++ b/source/blender/collada/DocumentImporter.cpp
+@@ -1340,6 +1340,19 @@ bool DocumentImporter::writeAnimationList(const COLLADAFW::AnimationList *animat
+ return anim_importer.write_animation_list(animationList);
+ }
+
++#if OPENCOLLADA_WITH_ANIMATION_CLIP
++// Since opencollada 1.6.68
++// called on post-process stage after writeVisualScenes
++bool DocumentImporter::writeAnimationClip(const COLLADAFW::AnimationClip *animationClip)
++{
++ if (mImportStage != General)
++ return true;
++
++ return true;
++ //return animation_clip_importer.write_animation_clip(animationClip); // TODO: implement import of AnimationClips
++}
++#endif
++
+ /** When this method is called, the writer must write the skin controller data.
+ * \return The writer should return true, if writing succeeded, false otherwise.*/
+ bool DocumentImporter::writeSkinControllerData(const COLLADAFW::SkinControllerData *skin)
+diff --git a/source/blender/collada/DocumentImporter.h b/source/blender/collada/DocumentImporter.h
+index 62f76dbc022..45fb2c74829 100644
+--- a/source/blender/collada/DocumentImporter.h
++++ b/source/blender/collada/DocumentImporter.h
+@@ -49,8 +49,6 @@
+ #include "MeshImporter.h"
+ #include "ImportSettings.h"
+
+-
+-
+ struct bContext;
+
+ /** Importer class. */
+@@ -108,6 +106,11 @@ public:
+
+ bool writeAnimationList(const COLLADAFW::AnimationList*);
+
++#if OPENCOLLADA_WITH_ANIMATION_CLIP
++ // Please enable this when building with Collada 1.6.65 or newer (also in DocumentImporter.cpp)
++ bool DocumentImporter::writeAnimationClip(const COLLADAFW::AnimationClip *animationClip);
++#endif
++
+ bool writeGeometry(const COLLADAFW::Geometry*);
+
+ bool writeMaterial(const COLLADAFW::Material*);