summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e1aadddd1bc..74a74df77234 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -34,7 +34,7 @@ pkgbase = blender-git
depends = python-numpy
optdepends = cuda: CUDA support in Cycles
optdepends = optix: OptiX support in Cycles
- optdepends = oidn: Intel Open Image Denoise support in compositing
+ optdepends = openimagedenoise: Intel Open Image Denoise support in compositing
provides = blender
conflicts = blender
source = git://git.blender.org/blender.git
diff --git a/PKGBUILD b/PKGBUILD
index ba5500d2bdb4..6a0e83b60cfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ depends=('alembic' 'libgl' 'python' 'desktop-file-utils' 'hicolor-icon-theme' 'o
'openvdb' 'opencollada' 'opensubdiv' 'openshadinglanguage' 'libtiff' 'libpng' 'python-numpy')
optdepends=('cuda: CUDA support in Cycles'
'optix: OptiX support in Cycles'
- 'oidn: Intel Open Image Denoise support in compositing')
+ 'openimagedenoise: Intel Open Image Denoise support in compositing')
makedepends=('git' 'cmake' 'boost' 'mesa' 'llvm')
provides=('blender')
conflicts=('blender')
@@ -28,7 +28,11 @@ source=('git://git.blender.org/blender.git' \
'blender-translations.git::git://git.blender.org/blender-translations.git' \
'blender-dev-tools.git::git://git.blender.org/blender-dev-tools.git' \
blender.desktop)
-md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'47e5bbe93fc221066882947211ff7812')
pkgver() {
@@ -54,7 +58,7 @@ if [ "$_OPTIX_PKG" != "" ]; then
fi
# check for open image denoise
-_OIDN_PKG=`pacman -Qq oidn 2>/dev/null` || true
+_OIDN_PKG=`pacman -Qq openimagedenoise 2>/dev/null` || true
if [ "$_OIDN_PKG" != "" ]; then
_EXTRAOPTS="$_EXTRAOPTS \
-DWITH_OPENIMAGEDENOISE=ON"