summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f12ee431a52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = blender-plugin-hdri-lighting-shortcut
+ pkgdesc = This is BLAM, a camera calibration toolkit for Blender in the form of an add-on, written in python, that facilitates modeling based on photographs.
+ pkgver = 1
+ pkgrel = 1
+ url = http://stuffmatic.github.io/
+ arch = any
+ license = GPL
+ makedepends = coreutils
+ depends = blender
+ source = https://github.com/Nikos-Prinios/HDRI-lighting-Shortcut/archive/ccef70cb7822e1a4826019ce798d2848e3a79b72.zip
+ md5sums = d8f5cece542b510e77be7a7ad3ae0d9c
+
+pkgname = blender-plugin-hdri-lighting-shortcut
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84fbd2167140
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=blender-plugin-hdri-lighting-shortcut
+pkgver=1
+pkgrel=1
+_blender=$(blender --version | grep -Po 'Blender \K[0-9]\...')
+pkgdesc="This is BLAM, a camera calibration toolkit for Blender in the form of an add-on, written in python, that facilitates modeling based on photographs."
+arch=('any')
+url="http://stuffmatic.github.io/"
+license=('GPL')
+depends=('blender')
+makedepends=('coreutils')
+conflicts=()
+_h=ccef70cb7822e1a4826019ce798d2848e3a79b72
+source=(https://github.com/Nikos-Prinios/HDRI-lighting-Shortcut/archive/$_h.zip)
+md5sums=(d8f5cece542b510e77be7a7ad3ae0d9c)
+
+package() {
+ mkdir -p "$pkgdir/usr/share/blender/$_blender/scripts/addons/"
+ cd "HDRI-lighting-Shortcut-$_h"
+ cp -r . "$pkgdir/usr/share/blender/$_blender/scripts/addons/hdri_lighting_shortcut"
+}