summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d7a662fdf86..21b54702a27b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = blight
pkgdesc = Basic general backlight utility written in python
- pkgver = 0.1.1
+ pkgver = 0.1.2
pkgrel = 1
- url = https://github.com/RPigott/blight
+ url = https://github.com/rpigott/blight
arch = any
license = custom:ISC
makedepends = scdoc
depends = python
depends = python-gobject
- source = blight-0.1.1.tar.gz::https://github.com/RPigott/blight/releases/download/v0.1.1/blight-0.1.1.tar.gz
- sha256sums = 04576d55d0448f56acb8335c7a14ca22bb06749db9b6560f85f6a14230054a52
+ source = blight-0.1.2.tar.gz::https://github.com/rpigott/blight/archive/refs/tags/v0.1.2.tar.gz
+ sha256sums = e2fa4f6b1436240ad047628e4e793506339460eb0bf650b8dbfb50152805a565
pkgname = blight
-
diff --git a/PKGBUILD b/PKGBUILD
index b5e84cf5978a..77ab74208193 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: Ronan Pigott <rpigott@berkeley.edu>
pkgname=blight
-pkgver=0.1.1
+pkgver=0.1.2
pkgrel=1
pkgdesc='Basic general backlight utility written in python'
-url='https://github.com/RPigott/blight'
+url='https://github.com/rpigott/blight'
arch=('any')
license=('custom:ISC')
-source=("$pkgname-$pkgver.tar.gz::$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
makedepends=('scdoc')
depends=('python' 'python-gobject')
-sha256sums=('04576d55d0448f56acb8335c7a14ca22bb06749db9b6560f85f6a14230054a52')
-
-# source+=("$pkgname-$pkgver.tar.gz.asc::$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz.asc")
-# sha256sums+=('SKIP')
-# validpgpkeys=('AE54EAF95DC5D7BB5F1CF422E8E098BBF6E920A0') # Ronan Pigott <rpigott@berkeley.edu>
+sha256sums=('e2fa4f6b1436240ad047628e4e793506339460eb0bf650b8dbfb50152805a565')
build() {
+ cd "$srcdir/$pkgname-$pkgver"
scdoc < blight.1.scd > blight.1
}
package() {
+ cd "$srcdir/$pkgname-$pkgver"
install -Dm755 blight.py "$pkgdir/usr/bin/blight"
install -Dm644 blight.1 "$pkgdir/usr/share/man/man1/blight.1"
install -Dm644 completion/zsh/_blight "$pkgdir/usr/share/zsh/site-functions/_blight"