summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7653309f864
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = blinky
+ pkgdesc = AUR-helper with minimal hassle
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/cherti/blinky
+ arch = any
+ license = GPLv3
+ depends = python
+ depends = pyalpm
+ depends = python-requests
+ depends = python-termcolor
+ options = !emptydirs
+ source = https://github.com/cherti/blinky/archive/v0.1.tar.gz
+ sha256sums = d784101f95b511331cf4816fb88e084065634b9faa2c4b1696e5c19a43da561a
+
+pkgname = blinky
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2809e41a6ef0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jonas 'cherti' Große Sundrup <aur@letopolis.de>
+
+pkgname=blinky
+pkgver=0.1
+pkgrel=1
+pkgdesc="AUR-helper with minimal hassle"
+arch=(any)
+url="https://github.com/cherti/blinky"
+license=('GPLv3')
+#groups=()
+depends=('python' 'pyalpm' 'python-requests' 'python-termcolor')
+#makedepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+options=(!emptydirs)
+#install=
+source=('https://github.com/cherti/blinky/archive/v0.1.tar.gz')
+sha256sums=('d784101f95b511331cf4816fb88e084065634b9faa2c4b1696e5c19a43da561a')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}