summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD56
-rw-r--r--fpic.patch14
3 files changed, 42 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e1ac1b3363f..8153a14b4720 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = blis-git
- pkgdesc = BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group
- pkgver = 0.8.1.r89.g2f7325b2
+ pkgdesc = BLAS-like Library Instantiation Software Framework
+ pkgver = 0.9.0.r134.ga72e4569f
pkgrel = 1
url = https://github.com/flame/blis
+ arch = i686
arch = x86_64
- license = custom:BSD
+ license = custom
+ makedepends = git
makedepends = python
depends = gcc-libs
- provides = blis
+ provides = blis=0.9.0.r134.ga72e4569f
provides = blas
+ provides = cblas
conflicts = blis
conflicts = blas
- options = !buildflags
- options = !emptydirs
+ conflicts = cblas
+ options = staticlibs
source = git+https://github.com/flame/blis.git
- sha512sums = SKIP
+ sha256sums = SKIP
pkgname = blis-git
diff --git a/PKGBUILD b/PKGBUILD
index 844af39d2e36..7e906ed507e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,51 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Previous maintainer: Stefan Husmann <stefan-husmann@t-online.de>
# Contributor: jdarch <jda -dot- cloud -plus- archlinux -at- gmail -dot- com>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=blis-git
-pkgver=0.8.1.r89.g2f7325b2
+pkgver=0.9.0.r134.ga72e4569f
pkgrel=1
-pkgdesc="BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group"
-arch=('x86_64')
-license=('custom:BSD')
+pkgdesc="BLAS-like Library Instantiation Software Framework"
+arch=('i686' 'x86_64')
+url="https://github.com/flame/blis"
+license=('custom')
depends=('gcc-libs')
-makedepends=('python')
-conflicts=('blis' 'blas')
-provides=('blis' 'blas')
-url='https://github.com/flame/blis'
-options=('!buildflags' '!emptydirs')
+makedepends=('git' 'python')
+provides=("blis=$pkgver" 'blas' 'cblas')
+conflicts=('blis' 'blas' 'cblas')
+options=('staticlibs')
source=("git+https://github.com/flame/blis.git")
-sha512sums=('SKIP')
+sha256sums=('SKIP')
+
pkgver() {
- cd "${pkgname%-git}"
- printf "%s" $(git describe --tags|sed 's+-+.r+'|tr - .)
+ cd "blis"
+
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {
- cd "${pkgname%-git}"
- CFLAGS+=" -fPIC" ./configure --prefix=/usr \
- --enable-static \
- --enable-shared \
- --enable-threading=openmp auto
- make BLIS_ENABLE_DYNAMIC_BUILD:=yes
+ cd "blis"
+
+ ./configure \
+ --prefix="/usr" \
+ --enable-cblas \
+ --enable-threading=openmp auto
+ make
}
check() {
- cd "${pkgname%-git}"
- make check
+ cd "blis"
+
+ #make check
}
package() {
- cd "${pkgname%-git}"
+ cd "blis"
- make DESTDIR="${pkgdir}" install
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/blis"
}
diff --git a/fpic.patch b/fpic.patch
deleted file mode 100644
index 58202e080dae..000000000000
--- a/fpic.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/config/x86_64/make_defs.mk b/config/x86_64/make_defs.mk
-index 2db7a8b8..30f41a62 100644
---- a/config/x86_64/make_defs.mk
-+++ b/config/x86_64/make_defs.mk
-@@ -52,7 +52,7 @@ endif
- # may specify additional flags here as needed.
- CPPROCFLAGS :=
- CMISCFLAGS :=
--CPICFLAGS :=
-+CPICFLAGS := -fPIC
- CWARNFLAGS :=
-
- ifneq ($(DEBUG_TYPE),off)
-