summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD55
2 files changed, 29 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 286f090c2a24..02fdffeb8456 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = blitz
pkgdesc = C++ Class library for scientific computing
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/blitzpp/blitz
arch = x86_64
- license = BSD
+ license = custom:Artistic
makedepends = cmake
makedepends = python
+ makedepends = onetbb
depends = boost
conflicts = blitz-cppqed-hg
source = blitz-1.0.2.tar.gz::https://github.com/blitzpp/blitz/archive/1.0.2.tar.gz
- md5sums = 195873ba25ae4c10b9cd374bf42c67c2
+ sha512sums = e5d82317c938d5dd2b0e6f99bc7dbcc982210f0f45961a21f4437466f01edbddafa01b92b3ccba707b0e01af697dc042846418011440b3574700afdf2bb08b47
pkgname = blitz
-
diff --git a/PKGBUILD b/PKGBUILD
index a7cfae2d7bdf..a88416b7f9af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,44 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
# Contributor: Lex Black <autumn-wind@web.de>
# Contributor: Yann Leprince <yann dot leprince at ylep dot fr>
-
pkgname=blitz
pkgver=1.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="C++ Class library for scientific computing"
arch=('x86_64')
-url="https://github.com/blitzpp/blitz"
+url="https://github.com/blitzpp/${pkgname}"
# The user is free to choose the license among ('Artistic2.0' 'BSD' 'LGPL3'),
# but we cannot express it here so we only mention the most permissive.
-license=('BSD')
-depends=('boost')
-makedepends=('cmake' 'python')
-conflicts=('blitz-cppqed-hg')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/blitzpp/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('195873ba25ae4c10b9cd374bf42c67c2')
-
+license=('custom:Artistic')
+depends=(boost)
+makedepends=(cmake python onetbb)
+conflicts=(blitz-cppqed-hg)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha512sums=('e5d82317c938d5dd2b0e6f99bc7dbcc982210f0f45961a21f4437466f01edbddafa01b92b3ccba707b0e01af697dc042846418011440b3574700afdf2bb08b47')
build() {
- local _conditional_options
- cd "$pkgname-$pkgver"
-
- mkdir -p build
- cd build
-
-
cmake \
+ -S ${pkgname}-${pkgver} \
+ -B build \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DCMAKE_INSTALL_LIBEXECDIR=/usr/lib \
- -DCMAKE_ENABLE_SERIALISATION=ON \
- ..
-
- make LDFLAGS="$LDFLAGS" lib
+ -DBUILD_SHARED_LIBS=TRUE \
+ -DBUILD_DOC=TRUE \
+ -DBUILD_TESTING=TRUE \
+ -DENABLE_SERIALISATION=TRUE \
+ -DSIMD_EXTENSION=TRUE \
+ -DTBB=TRUE
+ cmake --build build --target lib
}
-#check() {
-# cd "$pkgname-$pkgver/build"
-# make -k check-testsuite
-#}
+check() {
+ cmake --build build --target testsuite benchmark examples
+ ctest --test-dir build
+}
package() {
- cd "$pkgname-$pkgver/build"
- make DESTDIR="$pkgdir/" install
-
- cd ..
- install -D -m644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/COPYRIGHT"
+ DESTDIR="${pkgdir}" cmake --build build-cmake --target install
+ install -Dm 644 ${pkgname}-${pkgver}/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}