summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD50
2 files changed, 30 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbf131ffa2b2..286f090c2a24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = blitz
pkgdesc = C++ Class library for scientific computing
- pkgver = 1.0.1
+ pkgver = 1.0.2
pkgrel = 1
url = https://github.com/blitzpp/blitz
arch = x86_64
license = BSD
+ makedepends = cmake
+ makedepends = python
depends = boost
conflicts = blitz-cppqed-hg
- source = https://github.com/blitzpp/blitz/archive/1.0.1.tar.gz
- md5sums = fe43e2cf6c9258bc8b369264dd008971
+ source = blitz-1.0.2.tar.gz::https://github.com/blitzpp/blitz/archive/1.0.2.tar.gz
+ md5sums = 195873ba25ae4c10b9cd374bf42c67c2
pkgname = blitz
diff --git a/PKGBUILD b/PKGBUILD
index 6cb4db62f734..a7cfae2d7bdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
-# Maintainer: Yann Leprince <yann dot leprince at ylep dot fr>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Yann Leprince <yann dot leprince at ylep dot fr>
+
pkgname=blitz
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
pkgdesc="C++ Class library for scientific computing"
arch=('x86_64')
@@ -9,41 +11,39 @@ url="https://github.com/blitzpp/blitz"
# but we cannot express it here so we only mention the most permissive.
license=('BSD')
depends=('boost')
-makedepends=()
+makedepends=('cmake' 'python')
conflicts=('blitz-cppqed-hg')
-source=("https://github.com/blitzpp/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('fe43e2cf6c9258bc8b369264dd008971')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/blitzpp/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('195873ba25ae4c10b9cd374bf42c67c2')
-prepare() {
- cd "$pkgname-$pkgver"
- sed -i -e 's/python/python2/g' \
- blitz/generate/Makefile.in \
- blitz/generate/genstencils.py
-}
build() {
local _conditional_options
cd "$pkgname-$pkgver"
- # Fortran is needed for benchmarks only
- ./configure \
- --prefix=/usr \
- --enable-shared \
- --enable-serialization \
- --disable-fortran \
- --disable-cxx-flags-preset \
- ${_conditional_options}
+ mkdir -p build
+ cd build
+
+
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_INSTALL_LIBEXECDIR=/usr/lib \
+ -DCMAKE_ENABLE_SERIALISATION=ON \
+ ..
make LDFLAGS="$LDFLAGS" lib
}
-check() {
- cd "$pkgname-$pkgver"
- make -k check-testsuite
-}
+#check() {
+# cd "$pkgname-$pkgver/build"
+# make -k check-testsuite
+#}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+
+ cd ..
install -D -m644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/COPYRIGHT"
- make DESTDIR="$pkgdir/" install || return 1
}