summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD28
-rw-r--r--bloaty-no-bundled-sources.patch53
4 files changed, 77 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fb1ceeacac7..081906340466 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bloaty-git
pkgdesc = A size profiler for binaries
- pkgver = 1.0.r62.g7cf6c58
+ pkgver = 1.1.r264.g22a83c0
pkgrel = 1
url = https://github.com/google/bloaty
arch = x86_64
@@ -8,12 +8,15 @@ pkgbase = bloaty-git
license = Apache
makedepends = git
makedepends = cmake
+ makedepends = ninja
depends = re2
depends = capstone
depends = protobuf
+ depends = abseil-cpp
conflicts = bloaty
source = bloaty-git::git+https://github.com/google/bloaty
- sha512sums = SKIP
+ source = bloaty-no-bundled-sources.patch
+ b2sums = SKIP
+ b2sums = 4093cf847b4c42e5a82b7e3e5e801cc81bb8f9d4a4e431ba35e6edb7079891096ab3675aac6ca5b409560d00a8755fdbfd9a53978280f71cb84aaa5ba009d46a
pkgname = bloaty-git
-
diff --git a/.gitignore b/.gitignore
index 81e80b0c5b03..566cc46069a9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
src/
pkg/
/bloaty/
+/bloaty-git/
diff --git a/PKGBUILD b/PKGBUILD
index fe38bceb10be..04f45ee17626 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
# Contributor: Yamakaky <yamakaky@yamaworld.fr>
pkgname=bloaty-git
-pkgver=1.0.r62.g7cf6c58
+pkgver=1.1.r264.g22a83c0
pkgrel=1
pkgdesc='A size profiler for binaries'
arch=(x86_64 i686)
url=https://github.com/google/bloaty
license=(Apache)
-depends=(re2 capstone protobuf)
-makedepends=(git cmake)
+depends=(re2 capstone protobuf abseil-cpp)
+makedepends=(git cmake ninja)
conflicts=(bloaty)
-source=("${pkgname}::git+${url}")
-sha512sums=(SKIP)
+source=("${pkgname}::git+${url}"
+ bloaty-no-bundled-sources.patch)
+b2sums=('SKIP'
+ '4093cf847b4c42e5a82b7e3e5e801cc81bb8f9d4a4e431ba35e6edb7079891096ab3675aac6ca5b409560d00a8755fdbfd9a53978280f71cb84aaa5ba009d46a')
pkgver () {
cd "${pkgname}"
@@ -22,15 +24,19 @@ pkgver () {
)
}
+prepare () {
+ cd "${pkgname}"
+ git apply "${srcdir}/bloaty-no-bundled-sources.patch"
+}
+
build() {
- rm -rf "${srcdir}/build"
- mkdir "${srcdir}/build"
- cd "${srcdir}/build"
- cmake -G 'Unix Makefiles' \
+ rm -rf build
+ cmake -GNinja \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTING=OFF \
-DBLOATY_ENABLE_CMAKETARGETS=OFF \
- "${srcdir}/${pkgname}"
- make
+ -S"${srcdir}/${pkgname}" -Bbuild
+ ninja -Cbuild
}
package() {
diff --git a/bloaty-no-bundled-sources.patch b/bloaty-no-bundled-sources.patch
new file mode 100644
index 000000000000..d6dfd7405d8b
--- /dev/null
+++ b/bloaty-no-bundled-sources.patch
@@ -0,0 +1,53 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5a843b9..7337a22 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -58,11 +58,6 @@ if(NOT CMAKE_BUILD_TYPE)
+ FORCE)
+ endif()
+
+-# Check out Git submodules.
+-if (EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/.gitmodules")
+- execute_process (COMMAND git submodule update --init --recursive
+- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR})
+-endif()
+
+ # Add third_party libraries, disabling as much as we can of their builds.
+
+@@ -157,7 +152,6 @@ endif()
+
+ include_directories(.)
+ include_directories(src)
+-include_directories(third_party/abseil-cpp)
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}/src")
+
+ # Baseline build flags.
+@@ -244,28 +238,6 @@ add_library(libbloaty STATIC
+ src/util.cc
+ src/util.h
+ src/webassembly.cc
+- # Until Abseil has a proper CMake build system
+- third_party/abseil-cpp/absl/base/internal/raw_logging.cc # Grrrr...
+- third_party/abseil-cpp/absl/base/internal/throw_delegate.cc
+- third_party/abseil-cpp/absl/debugging/internal/demangle.cc
+- third_party/abseil-cpp/absl/numeric/int128.cc
+- third_party/abseil-cpp/absl/strings/ascii.cc
+- third_party/abseil-cpp/absl/strings/charconv.cc
+- third_party/abseil-cpp/absl/strings/escaping.cc
+- third_party/abseil-cpp/absl/strings/internal/charconv_bigint.cc
+- third_party/abseil-cpp/absl/strings/internal/charconv_parse.cc
+- third_party/abseil-cpp/absl/strings/internal/escaping.cc
+- third_party/abseil-cpp/absl/strings/internal/memutil.cc
+- third_party/abseil-cpp/absl/strings/internal/utf8.cc
+- third_party/abseil-cpp/absl/strings/match.cc
+- third_party/abseil-cpp/absl/strings/numbers.cc
+- third_party/abseil-cpp/absl/strings/str_cat.cc
+- third_party/abseil-cpp/absl/strings/string_view.cc
+- third_party/abseil-cpp/absl/strings/str_split.cc
+- third_party/abseil-cpp/absl/strings/substitute.cc
+- third_party/abseil-cpp/absl/types/bad_optional_access.cc
+- # One source file, no special build system needed.
+- third_party/demumble/third_party/libcxxabi/cxa_demangle.cpp
+ )
+ set_property(TARGET libbloaty PROPERTY FOLDER "bloaty")
+