summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD33
2 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10b461a512c5..6f3e2659e1fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = bloaty-git
pkgdesc = A size profiler for binaries
- pkgver = 0.0.0.r232.g340c0a7
+ pkgver = v1.0.r2.gfeaca23
pkgrel = 1
url = https://github.com/google/bloaty
arch = x86_64
- arch = x86
+ arch = i686
license = Apache
makedepends = git
makedepends = cmake
depends = gcc-libs
- source = git+https://github.com/google/bloaty
- md5sums = SKIP
+ conflicts = bloaty
+ source = bloaty-git::git+https://github.com/google/bloaty
+ sha512sums = SKIP
pkgname = bloaty-git
diff --git a/PKGBUILD b/PKGBUILD
index 1623c82c0c10..2abd3a83de4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
# Contributor: Yamakaky <yamakaky@yamaworld.fr>
pkgname=bloaty-git
-pkgver=0.0.0.r232.g340c0a7
+pkgver=v1.0.r2.gfeaca23
pkgrel=1
-pkgdesc="A size profiler for binaries"
-arch=("x86_64" "x86")
-url="https://github.com/google/bloaty"
-license=("Apache")
-depends=('gcc-libs')
-makedepends=('git' 'cmake')
-source=("git+https://github.com/google/bloaty")
-md5sums=("SKIP")
+pkgdesc='A size profiler for binaries'
+arch=(x86_64 i686)
+url=https://github.com/google/bloaty
+license=(Apache)
+depends=(gcc-libs)
+makedepends=(git cmake)
+conflicts=(bloaty)
+source=("${pkgname}::git+${url}")
+sha512sums=(SKIP)
-pkgver() {
- cd bloaty
- printf "0.0.0.r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+pkgver () {
+ cd "${pkgname}"
+ (
+ set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
@@ -23,7 +28,7 @@ build() {
cd "${srcdir}/build"
cmake -G 'Unix Makefiles' \
-DCMAKE_INSTALL_PREFIX=/usr \
- "${srcdir}/bloaty"
+ "${srcdir}/${pkgname}"
make
}
@@ -31,6 +36,6 @@ package() {
cd "${srcdir}/build"
install -Dm755 "${srcdir}/build/bloaty" \
"${pkgdir}/usr/bin/bloaty"
- install -Dm644 "${srcdir}/bloaty/README.md" \
+ install -Dm644 "${srcdir}/${pkgname}/README.md" \
"${pkgdir}/usr/share/doc/${pkgname}/README.md"
}