summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD14
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f87f60d49e3..6cb25a22c7d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
# Generated by mksrcinfo v8
-# Sun Jan 3 21:44:13 UTC 2016
+# Tue Mar 29 11:46:41 UTC 2016
pkgbase = blockify
pkgdesc = Mutes Spotify advertisements.
- pkgver = 3.3.1
+ pkgver = 3.4.0
pkgrel = 1
url = https://github.com/mikar/blockify
arch = any
license = MIT
+ makedepends = python-setuptools
depends = spotify
- depends = pulseaudio
depends = alsa-utils
depends = pygtk
depends = gst-python
depends = python-dbus
- depends = python-setuptools
- depends = python-docopt
+ optdepends = pulseaudio: mute spotify sink instead of system sound
+ optdepends = python-docopt: command-line interface
conflicts = blockify-git
- source = https://github.com/mikar/blockify/archive/v3.3.1.tar.gz
- sha256sums = 0bb4d8da4a294d3ad831726f690c9bfbcfa3f1683f56a094f39d1422495d71ab
+ source = https://github.com/mikar/blockify/archive/v3.4.0.tar.gz
+ sha256sums = 56b625d1050a5c19262e2b772dbf36ad28ca6feab1fe2af36529f74d14b93bab
pkgname = blockify
diff --git a/PKGBUILD b/PKGBUILD
index ab1a6135fea9..2c7a94ec00bd 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,20 @@
# Maintainer: demian <mikar ατ gmx δοτ de>
pkgname=blockify
-pkgver=3.3.1
+pkgver=3.4.0
pkgrel=1
pkgdesc="Mutes Spotify advertisements."
arch=("any")
url="https://github.com/mikar/${pkgname}"
license=("MIT")
conflicts=("blockify-git")
-depends=("spotify" "pulseaudio" "alsa-utils" "pygtk"
- "gst-python" "python-dbus" "python-setuptools" "python-docopt")
+depends=("spotify"
+ "alsa-utils"
+ "pygtk"
+ "gst-python"
+ "python-dbus")
+makedepends=("python-setuptools")
+optdepends=("pulseaudio: mute spotify sink instead of system sound"
+ "python-docopt: command-line interface")
source=("https://github.com/mikar/${pkgname}/archive/v${pkgver}.tar.gz")
package() {
@@ -16,4 +22,4 @@ package() {
python setup.py install --root="${pkgdir}"
}
-sha256sums=('0bb4d8da4a294d3ad831726f690c9bfbcfa3f1683f56a094f39d1422495d71ab')
+sha256sums=('56b625d1050a5c19262e2b772dbf36ad28ca6feab1fe2af36529f74d14b93bab')