summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD28
-rwxr-xr-xblockout22
-rw-r--r--blockout2.desktop10
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f4b07e5a088
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = blockout2
+ pkgdesc = 3D tetris, free adaptation of the original BlockOut DOS game edited by California Dreams in 1989
+ pkgver = 2.5
+ pkgrel = 1
+ url = http://www.blockout.net/blockout2/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libgl
+ depends = glu
+ depends = libxext
+ depends = sdl
+ depends = sdl_mixer
+ source = blockout2
+ source = blockout2.desktop
+ source = https://dl.dropboxusercontent.com/u/44746444/pro_aur/blockout.png
+ md5sums = 130e2c10b68b41bf12e67a764a2ea4fb
+ md5sums = 881916bdb782fd3c1bdbb6bb80d3f3a6
+ md5sums = 5c57fa70d62e823c7ab18f13072169e6
+ source_i686 = http://downloads.sourceforge.net/project/blockout/blockout/BlockOut%202.5/bl25-linux-x86.tar.gz
+ md5sums_i686 = 6e29242d76cd5bbf8caee62127f02e19
+ source_x86_64 = http://downloads.sourceforge.net/project/blockout/blockout/BlockOut%202.5/bl25-linux-x64.tar.gz
+ md5sums_x86_64 = 6155d0596d762852e3fbd1718d3d6455
+
+pkgname = blockout2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44f36194d34c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: pezcurrel <pezcurrel [at] tiscali.it>
+# Contributor: Piotr Beling <qwak [at] stud.ics.p.lodz.pl>
+
+pkgname=blockout2
+pkgver=2.5
+pkgrel=1
+pkgdesc="3D tetris, free adaptation of the original BlockOut DOS game edited by California Dreams in 1989"
+arch=("i686" "x86_64")
+url="http://www.blockout.net/blockout2/"
+depends=("libgl" "glu" "libxext" "sdl" "sdl_mixer")
+license=("GPL")
+source_x86_64=("http://downloads.sourceforge.net/project/blockout/blockout/BlockOut%202.5/bl25-linux-x64.tar.gz")
+source_i686=("http://downloads.sourceforge.net/project/blockout/blockout/BlockOut%202.5/bl25-linux-x86.tar.gz")
+source=("blockout2" "blockout2.desktop" "https://dl.dropboxusercontent.com/u/44746444/pro_aur/blockout.png")
+md5sums_x86_64=("6155d0596d762852e3fbd1718d3d6455")
+md5sums_i686=("6e29242d76cd5bbf8caee62127f02e19")
+md5sums=("130e2c10b68b41bf12e67a764a2ea4fb"
+ "881916bdb782fd3c1bdbb6bb80d3f3a6"
+ "5c57fa70d62e823c7ab18f13072169e6")
+
+package() {
+ install -d "$pkgdir"/{opt,usr/bin,usr/share/applications,usr/share/pixmaps}
+ chmod -x "$srcdir"/blockout/README.txt "$srcdir"/blockout/images/background.png "$srcdir"/blockout/sounds/music.ogg
+ mv "$srcdir"/blockout "$pkgdir"/opt/blockout2
+ cp -L "$srcdir"/blockout2 "$pkgdir"/usr/bin
+ cp -L blockout2.desktop "$pkgdir"/usr/share/applications
+ cp -L blockout.png "$pkgdir"/usr/share/pixmaps/blockout2.png
+}
diff --git a/blockout2 b/blockout2
new file mode 100755
index 000000000000..79af98d9ff78
--- /dev/null
+++ b/blockout2
@@ -0,0 +1,2 @@
+#!/bin/sh
+BL2_HOME="/opt/blockout2" /opt/blockout2/blockout
diff --git a/blockout2.desktop b/blockout2.desktop
new file mode 100644
index 000000000000..8295c4b7f390
--- /dev/null
+++ b/blockout2.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=Blockout II
+GenericName=3D tetris
+Comment=3D tetris, free adaptation of the original BlockOut DOS game edited by California Dreams in 1989
+Icon=blockout2
+Exec=blockout2
+Terminal=False
+Categories=Application;Game