summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--default_checks.patch15
3 files changed, 16 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8023bed03c84..831190a62413 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bluej-fri
pkgdesc = A custom version of the BlueJ Development Enviroment made for the University of Žilina
pkgver = 4.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/infjava/BlueJFRI
arch = any
license = GPL2
@@ -13,20 +13,18 @@ pkgbase = bluej-fri
provides = bluej=${pkgver}
conflicts = bluej
noextract = BlueJ-linux-422.deb
- noextract = checkstyle-extension-5.4-0.jar
+ noextract = checkstyle-extension-5.4-1.jar
source = https://www.bluej.org/download/files/BlueJ-linux-422.deb
- source = https://downloads.sourceforge.net/project/bluejcheckstyle/bluejcheckstyle/5.4-0/checkstyle-extension-5.4-0.jar
+ source = checkstyle::git+https://github.com/MetroCS/checkstyle4bluej
source = BlueJFRI::git+https://github.com/infjava/BlueJFRI
source = bluej
source = bluej.desktop
- source = default_checks.patch
source = bluej.xml
sha256sums = 5c2241f2208e98fcf9aad7c7a282bcf16e6fd543faa5fdb0b99b34d1023113c3
- sha256sums = 48a36cba5b981385baa8dfb3034549b65e30e6f7261aae158c6d37c9bf590a02
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = c1bdaad64fcf45b1efac00e010d5f750c417d64896cde80b9b7c5745277422b8
sha256sums = 47fa6f755cd0ec1b575b7029820f8fa8d7abb7413fa4709d053f120925edcc5f
- sha256sums = 5a0e105134c36f1aa97e36462d734b7c05ba1db5efa2b372d38f23f1c6ac3a6f
sha256sums = ca12278b71e4bd84875f10d24b74d1d24c51573825d796331d8a20794ce60c08
pkgname = bluej-fri
diff --git a/PKGBUILD b/PKGBUILD
index cd1e270f7e15..2da07a8b2025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bluej-fri
pkgver=4.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="A custom version of the BlueJ Development Enviroment made for the University of Žilina"
arch=('any')
url="https://github.com/infjava/BlueJFRI"
@@ -11,26 +11,24 @@ depends=('gtk2' 'archlinux-java-run' 'java-runtime=11' 'java-environment=11' 'ja
provides=('bluej=${pkgver}')
conflicts=("bluej")
source=("https://www.bluej.org/download/files/BlueJ-linux-${pkgver//.}.deb"
- "https://downloads.sourceforge.net/project/bluejcheckstyle/bluejcheckstyle/5.4-0/checkstyle-extension-5.4-0.jar"
+ "checkstyle::git+https://github.com/MetroCS/checkstyle4bluej"
"BlueJFRI::git+$url"
"bluej"
"bluej.desktop"
- "default_checks.patch"
"bluej.xml")
noextract=("BlueJ-linux-${pkgver//.}.deb"
- "checkstyle-extension-5.4-0.jar")
+ "checkstyle-extension-5.4-1.jar")
sha256sums=('5c2241f2208e98fcf9aad7c7a282bcf16e6fd543faa5fdb0b99b34d1023113c3'
- '48a36cba5b981385baa8dfb3034549b65e30e6f7261aae158c6d37c9bf590a02'
+ 'SKIP'
'SKIP'
'c1bdaad64fcf45b1efac00e010d5f750c417d64896cde80b9b7c5745277422b8'
'47fa6f755cd0ec1b575b7029820f8fa8d7abb7413fa4709d053f120925edcc5f'
- '5a0e105134c36f1aa97e36462d734b7c05ba1db5efa2b372d38f23f1c6ac3a6f'
'ca12278b71e4bd84875f10d24b74d1d24c51573825d796331d8a20794ce60c08')
prepare() {
cd "$srcdir"
ar p "BlueJ-linux-${pkgver//.}.deb" data.tar.xz | tar xJ
- patch --strip=1 < default_checks.patch
+ # patch --strip=1 < default_checks.patch
}
package() {
@@ -41,14 +39,20 @@ package() {
cp -r "usr/share/bluej" "$pkgdir/opt"
cp -r usr/share/doc/BlueJ/*/ "$pkgdir/usr/share/doc/bluej/examples/"
+ # Replace default templates with custom ones
rm -R "$pkgdir/opt/bluej/english/templates"
cp -r BlueJFRI/data/templates "$pkgdir/opt/bluej/english/templates"
+ # Copy custom files
install -Dm755 bluej "$pkgdir/usr/bin/bluej"
install -Dm644 bluej.desktop "$pkgdir/usr/share/applications/bluej.desktop"
install -Dm644 bluej.xml "$pkgdir/usr/share/mime/packages/bluej.xml"
+
+ # Install checkstyle extension and default_checks.xml
install -Dm644 BlueJFRI/data/checkstyle/default_checks.xml "$pkgdir/opt/bluej/extensions/default_checks.xml"
- install -Dm644 checkstyle-extension-5.4-0.jar "$pkgdir/opt/bluej/extensions/checkstyle-extension-5.4-0.jar"
+ install -Dm644 checkstyle/checkstyle-extension-5.4.1.jar "$pkgdir/opt/bluej/extensions/checkstyle-extension-5.4.1.jar"
+
+ # Copy icons and docs
install -Dm644 "usr/share/icons/hicolor/256x256/apps/bluej.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/bluej.png"
install -Dm644 "usr/share/icons/hicolor/48x48/apps/bluej.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/bluej.png"
install -Dm644 "usr/share/doc/BlueJ/README.TXT" "$pkgdir/usr/share/doc/bluej/README"
diff --git a/default_checks.patch b/default_checks.patch
deleted file mode 100644
index e69161fd1044..000000000000
--- a/default_checks.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --unified --recursive --text src/BlueJFRI/data/checkstyle/default_checks.xml src.new/BlueJFRI/data/checkstyle/default_checks.xml
---- src/BlueJFRI/data/checkstyle/default_checks.xml 2021-10-05 22:18:02.950219439 +0200
-+++ src.new/BlueJFRI/data/checkstyle/default_checks.xml 2021-10-05 22:18:42.923553639 +0200
-@@ -49,9 +49,7 @@
- <module name="MethodTypeParameterName"/>
-
- <!-- explicitné uvádzanie this ako adresáta správy a pri prístupe ku atribútom -->
-- <module name="RequireThis">
-- <property name="validateOnlyOverlapping" value="false"/>
-- </module>
--
-+ <module name="RequireThis"/>
-+
-
- <!-- IMPORTY -->