summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea5e5e9bf66d..57eae1fb96ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu Apr 28 09:04:19 UTC 2016
pkgbase = bluelog
pkgdesc = A highly configurable Linux Bluetooth scanner with optional web interface
pkgver = 1.1.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.digifail.com/software/bluelog.shtml
arch = i686
arch = x86_64
- license = GPL
+ license = GPL-2.0-only
+ makedepends = wget
depends = bluez
depends = bluez-libs
source = https://github.com/MS3FGX/Bluelog/archive/1.1.2.tar.gz
- md5sums = aedd6e0c3cd42560623008cff9bc9491
+ sha256sums = ebbc1357e14bc46cbddd8390cdbd29c0131b09b8ab680a1c382164ef076cb53e
pkgname = bluelog
-
diff --git a/PKGBUILD b/PKGBUILD
index b5ab2b13c01f..43ec47262c91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,32 @@
pkgname=bluelog
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
_pkgname=Bluelog
pkgdesc="A highly configurable Linux Bluetooth scanner with optional web interface"
arch=(i686 x86_64)
url="http://www.digifail.com/software/bluelog.shtml"
-license=('GPL')
+#url="https://github.com/MS3FGX/Bluelog"
+license=('GPL-2.0-only')
+makedepends=('wget')
depends=('bluez' 'bluez-libs')
source=("https://github.com/MS3FGX/Bluelog/archive/${pkgver}.tar.gz")
-md5sums=('aedd6e0c3cd42560623008cff9bc9491')
+sha256sums=('ebbc1357e14bc46cbddd8390cdbd29c0131b09b8ab680a1c382164ef076cb53e')
-
-build() {
+build()
+{
cd ${_pkgname}-${pkgver}
#./configure --prefix=/usr
make
}
-package() {
+package()
+{
cd ${_pkgname}-${pkgver}
make DESTDIR="${pkgdir}/" install
# license
- #install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}/"
# man
#install -Dm644 ${pkgname}.1 "${pkgdir}/usr/share/man/man1/${pkgname}.1"