summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD39
-rw-r--r--boblight.service10
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b82d2a151e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = boblight-v4l
+ pkgdesc = Collection of tools for driving lights connected to an external controller, compatible to new version of ffmpeg
+ pkgver = r395
+ pkgrel = 1
+ url = https://github.com/Nidhoggrr/boblight
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ makedepends = glu
+ makedepends = svn
+ depends = libusbx
+ depends = libxext
+ depends = libxrender
+ depends = mesa
+ depends = portaudio
+ depends = ffmpeg
+ provides = boblight
+ conflicts = boblight
+ source = svn+https://github.com/Nidhoggrr/boblight.git/trunk
+ source = boblight.service
+ md5sums = SKIP
+ md5sums = 465a99144ad2e86a20d3433b426320b2
+
+pkgname = boblight-v4l
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..480cb42819e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ronny <ronny-aur[at]adke*org>
+pkgname=boblight-v4l
+_svnrev=479
+pkgver=r395
+pkgrel=1
+pkgdesc="Collection of tools for driving lights connected to an external controller, compatible to new version of ffmpeg"
+url="https://github.com/Nidhoggrr/boblight"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('libusbx' 'libxext' 'libxrender' 'mesa' 'portaudio' 'ffmpeg')
+provides=('boblight')
+conflicts=('boblight')
+makedepends=('glu' 'svn')
+#source=("svn+https://boblight.googlecode.com/svn/trunk#revision=$_svnrev"
+source=("svn+https://github.com/Nidhoggrr/boblight.git/trunk"
+ "boblight.service")
+md5sums=('SKIP'
+ '465a99144ad2e86a20d3433b426320b2')
+
+pkgver() {
+ cd "$srcdir/trunk"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "$srcdir/trunk"
+
+ ./configure --prefix=/usr \
+ --disable-static \
+ --with-ffmpeg
+ make
+}
+
+package() {
+ cd "$srcdir/trunk"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "$srcdir/boblight.service" "$pkgdir/usr/lib/systemd/system/boblight.service"
+}
diff --git a/boblight.service b/boblight.service
new file mode 100644
index 000000000000..5fbee78c63d5
--- /dev/null
+++ b/boblight.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Boblight Ambient Lighting Daemon
+Before=vdr.service
+
+[Service]
+ExecStart=/usr/bin/boblightd
+Restart=on-abort
+
+[Install]
+WantedBy=multi-user.target \ No newline at end of file