summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a24a50bf317
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = boca
+ pkgdesc = A component library used by the fre:ac audio converter
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/enzo1982/BoCA
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = alsa-lib
+ depends = libcdio-paranoia
+ depends = expat
+ depends = libpulse
+ depends = uriparser
+ depends = smooth
+ provides = libboca-1.0.so=2-64
+ provides = freac_cdk
+ conflicts = freac_cdk
+ source = BoCA-1.0.tar.gz::https://github.com/enzo1982/BoCA/archive/v1.0.tar.gz
+ sha256sums = ceb2c79776f423f83421a5e63faab0ee22262a808aa34debecd0eeb28afeccbf
+
+pkgname = boca
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f252fdb48934
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=boca
+_pkgname=BoCA
+pkgver=1.0
+pkgrel=1
+pkgdesc="A component library used by the fre:ac audio converter"
+arch=('i686' 'x86_64')
+url="https://github.com/enzo1982/BoCA"
+license=('GPL2')
+depends=('alsa-lib' 'libcdio-paranoia' 'expat' 'libpulse' 'uriparser' 'smooth')
+provides=('libboca-1.0.so=2-64' 'freac_cdk')
+conflicts=('freac_cdk')
+source=("$_pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('ceb2c79776f423f83421a5e63faab0ee22262a808aa34debecd0eeb28afeccbf')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ find . -type f -exec sed -i 's|/usr/local|/usr|g' {} \;
+
+ sed -i 's/FOLDERS += coreaudioconnect/#FOLDERS += coreaudioconnect/g' \
+ components/encoder/Makefile
+}
+
+build() {
+ cd "$_pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}