summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--inc_boost_header.patch57
3 files changed, 65 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f4f077c47cd..abcc4ab30a6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Oct 12 15:36:34 UTC 2019
+# Sun Mar 15 18:31:26 UTC 2020
pkgbase = bombono-dvd
pkgdesc = DVD authoring program with nice and clean GUI
pkgver = 1.2.4
- pkgrel = 4
+ pkgrel = 5
url = http://www.bombono.org
install = bombono-dvd.install
arch = i686
@@ -29,6 +29,7 @@ pkgbase = bombono-dvd
source = fix_ptr2bool_cast.patch
source = fix_c++11_literal_warnings.patch
source = autoptr2uniqueptr.patch
+ source = inc_boost_header.patch
source = fix_deprecated_boost_api.patch
source = fix_throw_specifications.patch
source = fix_operator_ambiguity.patch
@@ -38,6 +39,7 @@ pkgbase = bombono-dvd
sha256sums = b0ff83b2fad27e39dfd77d12e00c25e554fe86ee1894c2f8fbe1915a2c46dd88
sha256sums = 28be98eb36eb6422717df7048c8ee74927495e7d7829e17cb54d746befc238c4
sha256sums = 4c29e9b19ba3bcf8c42c46aaea6c1411580629e581307a91f4d085fcdaa6eab6
+ sha256sums = 14687493ffe5f95c60d4397e4a9f7d7a8434159e2e4338570856b5ee3e683b50
sha256sums = a69f51f9d5bd6ebe26c13abeece9de012d110dcec944c76efbab59b6bc0ef915
sha256sums = 72b3d6c76cbf98fb9287f7ee5b7a57b6febe2a635d50758c2451e376e3e6ca02
sha256sums = 9d56f7d16c55a506b092dbec00789e4767963d6202d3d92b79ad389393d43c69
diff --git a/PKGBUILD b/PKGBUILD
index 1498def5e723..f344da1e31a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bombono-dvd
pkgver=1.2.4
-pkgrel=4
+pkgrel=5
pkgdesc="DVD authoring program with nice and clean GUI"
arch=('i686' 'x86_64')
url="http://www.bombono.org"
@@ -18,6 +18,7 @@ source=("https://github.com/muravjov/${pkgname}/archive/${pkgver}.tar.gz"
"fix_ptr2bool_cast.patch"
"fix_c++11_literal_warnings.patch"
"autoptr2uniqueptr.patch"
+ "inc_boost_header.patch"
"fix_deprecated_boost_api.patch"
"fix_throw_specifications.patch"
"fix_operator_ambiguity.patch"
@@ -28,6 +29,7 @@ sha256sums=('4f8c882a0c359ca8c182a627885c64aa271820eead2f9a64b34f1625c3b0a9d7'
'b0ff83b2fad27e39dfd77d12e00c25e554fe86ee1894c2f8fbe1915a2c46dd88'
'28be98eb36eb6422717df7048c8ee74927495e7d7829e17cb54d746befc238c4'
'4c29e9b19ba3bcf8c42c46aaea6c1411580629e581307a91f4d085fcdaa6eab6'
+ '14687493ffe5f95c60d4397e4a9f7d7a8434159e2e4338570856b5ee3e683b50'
'a69f51f9d5bd6ebe26c13abeece9de012d110dcec944c76efbab59b6bc0ef915'
'72b3d6c76cbf98fb9287f7ee5b7a57b6febe2a635d50758c2451e376e3e6ca02'
'9d56f7d16c55a506b092dbec00789e4767963d6202d3d92b79ad389393d43c69'
@@ -43,6 +45,7 @@ prepare() {
patch -Np1 -i "${srcdir}/fix_ffmpeg30.patch"
patch -Np1 -i "${srcdir}/fix_throw_specifications.patch"
patch -Np1 -i "${srcdir}/fix_operator_ambiguity.patch"
+ patch -Np1 -i "${srcdir}/inc_boost_header.patch"
# python2 fix
for file in $(find . -name '*.py' -print); do
sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file
diff --git a/inc_boost_header.patch b/inc_boost_header.patch
new file mode 100644
index 000000000000..9aab93555cfe
--- /dev/null
+++ b/inc_boost_header.patch
@@ -0,0 +1,57 @@
+diff -ruN old/src/mbase/project/table.cpp new/src/mbase/project/table.cpp
+--- old/src/mbase/project/table.cpp 2020-03-15 21:42:06.873029453 +0330
++++ new/src/mbase/project/table.cpp 2020-03-15 21:45:19.241211612 +0330
+@@ -29,6 +29,7 @@
+ #include "theme.h"
+
+ #include <mbase/resources.h>
++#include <boost/filesystem/directory.hpp>
+
+
+ const char* APROJECT_VERSION = "1.2.4";
+diff -ruN old/src/mgui/editor/toolbar.cpp new/src/mgui/editor/toolbar.cpp
+--- old/src/mgui/editor/toolbar.cpp 2020-03-15 21:43:22.593461317 +0330
++++ new/src/mgui/editor/toolbar.cpp 2020-03-15 21:42:16.569751981 +0330
+@@ -45,6 +45,8 @@
+ #include <mlib/sdk/logger.h>
+ #include <mlib/range/enumerate.h>
+
++#include <boost/filesystem/directory.hpp>
++
+ namespace Editor
+ {
+
+diff -ruN old/src/mgui/project/mconstructor.cpp new/src/mgui/project/mconstructor.cpp
+--- old/src/mgui/project/mconstructor.cpp 2020-03-15 21:43:22.596794669 +0330
++++ new/src/mgui/project/mconstructor.cpp 2020-03-15 21:42:16.569751981 +0330
+@@ -52,6 +52,8 @@
+ // COPY_N_PASTE_ETALON из go-file.c, проект Gnumeric, http://projects.gnome.org/gnumeric/
+ //
+
++#include <boost/filesystem/directory.hpp>
++
+ #ifndef GOFFICE_WITH_GNOME
+ static char *
+ check_program (char const *prog)
+diff -ruN old/src/mlib/filesystem.cpp new/src/mlib/filesystem.cpp
+--- old/src/mlib/filesystem.cpp 2020-03-15 21:42:06.876362806 +0330
++++ new/src/mlib/filesystem.cpp 2020-03-15 21:54:14.022647682 +0330
+@@ -30,6 +30,7 @@
+ #if BOOST_MINOR_VERSION >= 51
+ #define BOOST_FS_3 boost::filesystem
+ #include <boost/filesystem/path_traits.hpp> // boost::filesystem::convert()
++#include <boost/filesystem/directory.hpp>
+ #else
+ #define BOOST_FS_3 boost::filesystem3
+ #include <boost/filesystem/v3/path_traits.hpp>
+diff -ruN old/src/mlib/sdk/bfs.h new/src/mlib/sdk/bfs.h
+--- old/src/mlib/sdk/bfs.h 2020-03-15 21:43:22.596794669 +0330
++++ new/src/mlib/sdk/bfs.h 2020-03-15 21:42:16.569751981 +0330
+@@ -7,6 +7,7 @@
+ //#define BOOST_FILESYSTEM_NO_DEPRECATED
+
+ #include <boost/filesystem/path.hpp>
++#include <boost/filesystem/exception.hpp>
+ #include <boost/filesystem/operations.hpp>
+ #include <boost/filesystem/convenience.hpp> // fs::create_directories()
+