summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD32
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..193fce5e5c18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = boost171
+ pkgdesc = Free peer-reviewed portable C++ source libraries
+ pkgver = 1.71.0
+ pkgrel = 1
+ url = https://www.boost.org/
+ arch = i686
+ arch = x86_64
+ license = Boost Software License - Version 1.0
+ makedepends = gzip
+ makedepends = icu
+ makedepends = openmpi
+ makedepends = python
+ makedepends = python-numpy
+ makedepends = zlib
+ makedepends = zstd
+ optdepends = python: for python bindings
+ optdepends = python2: for python2 bindings
+ provides = boost
+ provides = boost-libs
+ conflicts = boost
+ conflicts = boost-libs
+ source = https://dl.bintray.com/boostorg/release/1.71.0/source/boost_1_71_0.tar.gz
+ sha256sums = 96b34f7468f26a141f6020efb813f1a2f3dfb9797ecf76a7d7cbd843cc95f5bd
+
+pkgname = boost171
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0099fdd73415
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Lukas Rose <public@lrose.de>
+pkgname=boost171
+pkgver=1.71.0
+pkgrel=1
+pkgdesc="Free peer-reviewed portable C++ source libraries"
+arch=('i686' 'x86_64')
+url="https://www.boost.org/"
+license=('Boost Software License - Version 1.0')
+optdepends=('python: for python bindings' 'python2: for python2 bindings')
+makedepends=('gzip' 'icu' 'openmpi' 'python' 'python-numpy' 'zlib' 'zstd')
+conflicts=('boost' 'boost-libs')
+provides=('boost' 'boost-libs')
+source=("https://dl.bintray.com/boostorg/release/1.71.0/source/boost_1_71_0.tar.gz")
+sha256sums=('96b34f7468f26a141f6020efb813f1a2f3dfb9797ecf76a7d7cbd843cc95f5bd')
+
+prepare() {
+ cd "boost_1_71_0"
+ ./bootstrap.sh
+}
+
+build() {
+ cd "boost_1_71_0"
+ ./b2
+}
+
+package() {
+ cd "boost_1_71_0"
+ mkdir -p "$pkgdir/usr/include/"
+ mkdir -p "$pkgdir/usr/lib/"
+ cp -r boost "$pkgdir/usr/include/"
+ cp -r stage/lib/* "$pkgdir/usr/lib/"
+}