summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--insertion-fix.patch172
-rw-r--r--remove-analytics.patch18
-rw-r--r--warning-fix.patch69
5 files changed, 226 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7252c2fc321..0f0a4eb51a08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = boostnote
pkgdesc = Open source note-taking app for programmers
pkgver = 0.8.18
- pkgrel = 1
+ pkgrel = 2
url = https://boostnote.io/
arch = any
license = GPL3
@@ -15,11 +15,13 @@ pkgbase = boostnote
source = boostnote.desktop
source = warning-fix.patch
source = remove-analytics.patch
+ source = insertion-fix.patch
sha512sums = 8c367f10b5460ebab1d5486537d120ed1cdee6a7507472aee7973bc0c84457b57601e4ec7cb0710119b72648b79d82dc05770ab10f3e7f933298d4913e2fe66d
sha512sums = f0abbdcca34d7f74d3dc66ffc2d0995416e7708c715d55fa58c4c2abc31d191ea42f3434e3105292b4817f83ac0ca89f456f5f93007ae80ab2426c8941f615f9
sha512sums = 18bcda13580da8ceeaa86793a77ec00a053b8fd51451dad7e2b1a19553fe1a467ac647b44b789212e783f3f6a80968cc9404e884ef7ff6b1f6588473b3229d40
- sha512sums = 87d883064a58b8bf0e92f42ad40c7da1f3eae4ab4eb1029b3f22f34c47233f6543430b3fe41cb385511d6e6aabcc8eef4c08d0963a7950e331f319f9ebcf0524
- sha512sums = 090406d39cd25409f4e8bc30c498d84ceb11ff01c83ccb3dbffdfbf10e3e8a6759f1c268b9b15ca7c52f47e2f65f71d12d34f5d78e2387bf8334daafe80be38c
+ sha512sums = a3c7d8212fb12ac0929b2f1baee041ccdebdf5395794694a0a29b2635859c9bd615f764edba4f6c79da235accde7359b7ed510056e1721961da95bddac9cefdf
+ sha512sums = df44d39b93adcbeeebae763caf1cb6fca502d4c3ce168838ef05cf66a9a931683563034ec4b6d38d6bb45d8a21f4869a5b7a40c9ca033da2098d3ff30c8bef94
+ sha512sums = 423ce4f638b4e0c322796ed4c3e5df8b9e9d7a13923f0f98d81551da86f069477253efb923ff77d8944d9e507732887ace533106172fd94ccf11fcfc060d56af
pkgname = boostnote
diff --git a/PKGBUILD b/PKGBUILD
index 307bc8b8508a..5701ca429a7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=boostnote
_pkgname=Boostnote
pkgver=0.8.18
-pkgrel=1
+pkgrel=2
pkgdesc="Open source note-taking app for programmers"
arch=('any')
url="https://boostnote.io/"
@@ -20,19 +20,22 @@ source=(
"${pkgname}.desktop"
"warning-fix.patch"
"remove-analytics.patch"
+ "insertion-fix.patch"
)
sha512sums=(
'8c367f10b5460ebab1d5486537d120ed1cdee6a7507472aee7973bc0c84457b57601e4ec7cb0710119b72648b79d82dc05770ab10f3e7f933298d4913e2fe66d'
'f0abbdcca34d7f74d3dc66ffc2d0995416e7708c715d55fa58c4c2abc31d191ea42f3434e3105292b4817f83ac0ca89f456f5f93007ae80ab2426c8941f615f9'
'18bcda13580da8ceeaa86793a77ec00a053b8fd51451dad7e2b1a19553fe1a467ac647b44b789212e783f3f6a80968cc9404e884ef7ff6b1f6588473b3229d40'
- '87d883064a58b8bf0e92f42ad40c7da1f3eae4ab4eb1029b3f22f34c47233f6543430b3fe41cb385511d6e6aabcc8eef4c08d0963a7950e331f319f9ebcf0524'
- '090406d39cd25409f4e8bc30c498d84ceb11ff01c83ccb3dbffdfbf10e3e8a6759f1c268b9b15ca7c52f47e2f65f71d12d34f5d78e2387bf8334daafe80be38c'
+ 'a3c7d8212fb12ac0929b2f1baee041ccdebdf5395794694a0a29b2635859c9bd615f764edba4f6c79da235accde7359b7ed510056e1721961da95bddac9cefdf'
+ 'df44d39b93adcbeeebae763caf1cb6fca502d4c3ce168838ef05cf66a9a931683563034ec4b6d38d6bb45d8a21f4869a5b7a40c9ca033da2098d3ff30c8bef94'
+ '423ce4f638b4e0c322796ed4c3e5df8b9e9d7a13923f0f98d81551da86f069477253efb923ff77d8944d9e507732887ace533106172fd94ccf11fcfc060d56af'
)
prepare() {
cd "${_pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/insertion-fix.patch"
patch -Np1 -i "${srcdir}/warning-fix.patch"
patch -Np1 -i "${srcdir}/remove-analytics.patch"
}
diff --git a/insertion-fix.patch b/insertion-fix.patch
new file mode 100644
index 000000000000..6942161a2781
--- /dev/null
+++ b/insertion-fix.patch
@@ -0,0 +1,172 @@
+diff -ura a/package.json b/package.json
+--- a/package.json 2017-12-03 03:51:11.000000000 +0100
++++ b/package.json 2017-12-03 17:30:46.687839000 +0100
+@@ -48,89 +48,89 @@
+ },
+ "homepage": "https://boostnote.io",
+ "dependencies": {
+- "@rokt33r/markdown-it-math": "^4.0.1",
+- "@rokt33r/season": "^5.3.0",
+- "aws-sdk": "^2.48.0",
+- "aws-sdk-mobile-analytics": "^0.9.2",
+- "codemirror": "^5.19.0",
+- "electron-config": "^0.2.1",
+- "electron-gh-releases": "^2.0.2",
+- "flowchart.js": "^1.6.5",
+- "font-awesome": "^4.3.0",
+- "immutable": "^3.8.1",
+- "js-sequence-diagrams": "^1000000.0.6",
+- "katex": "^0.7.1",
+- "lodash": "^4.11.1",
+- "lodash-move": "^1.1.1",
+- "markdown-it": "^6.0.1",
+- "markdown-it-checkbox": "^1.1.0",
+- "markdown-it-emoji": "^1.1.1",
+- "markdown-it-footnote": "^3.0.0",
+- "markdown-it-imsize": "^2.0.1",
+- "markdown-it-kbd": "^1.1.1",
+- "markdown-it-multimd-table": "^2.0.1",
+- "markdown-it-named-headers": "^0.0.4",
+- "markdown-it-plantuml": "^0.3.0",
+- "md5": "^2.0.0",
+- "mdurl": "^1.0.1",
+- "moment": "^2.10.3",
+- "node-ipc": "^8.1.0",
+- "raphael": "^2.2.7",
+- "react": "^15.5.4",
+- "react-codemirror": "^0.3.0",
+- "react-dom": "^15.0.2",
+- "react-redux": "^4.4.5",
+- "react-sortable-hoc": "^0.6.7",
+- "redux": "^3.5.2",
+- "sander": "^0.5.1",
+- "striptags": "^2.2.1",
+- "superagent": "^1.2.0",
+- "superagent-promise": "^1.0.3"
++ "@rokt33r/markdown-it-math": "4.0.2",
++ "@rokt33r/season": "5.3.1",
++ "aws-sdk": "2.48.0",
++ "aws-sdk-mobile-analytics": "0.9.2",
++ "codemirror": "5.26.0",
++ "electron-config": "0.2.1",
++ "electron-gh-releases": "2.0.4",
++ "flowchart.js": "1.6.6",
++ "font-awesome": "4.7.0",
++ "immutable": "3.8.1",
++ "js-sequence-diagrams": "1000000.0.6",
++ "katex": "0.7.1",
++ "lodash": "4.17.4",
++ "lodash-move": "1.1.1",
++ "markdown-it": "6.1.1",
++ "markdown-it-checkbox": "1.1.0",
++ "markdown-it-emoji": "1.3.0",
++ "markdown-it-footnote": "3.0.1",
++ "markdown-it-imsize": "2.0.1",
++ "markdown-it-kbd": "1.1.1",
++ "markdown-it-multimd-table": "2.0.1",
++ "markdown-it-named-headers": "0.0.4",
++ "markdown-it-plantuml": "0.3.0",
++ "md5": "2.2.1",
++ "mdurl": "1.0.1",
++ "moment": "2.18.1",
++ "node-ipc": "8.10.3",
++ "raphael": "2.2.7",
++ "react": "15.6.2",
++ "react-codemirror": "0.3.0",
++ "react-dom": "15.5.4",
++ "react-redux": "4.4.8",
++ "react-sortable-hoc": "0.6.7",
++ "redux": "3.6.0",
++ "sander": "0.5.1",
++ "striptags": "2.2.1",
++ "superagent": "1.8.5",
++ "superagent-promise": "1.1.0"
+ },
+ "devDependencies": {
+- "ava": "^0.16.0",
+- "babel-core": "^6.14.0",
+- "babel-loader": "^6.2.0",
+- "babel-plugin-react-transform": "^2.0.0",
+- "babel-plugin-webpack-alias": "^2.1.1",
+- "babel-preset-es2015": "^6.3.13",
+- "babel-preset-react": "^6.3.13",
+- "babel-preset-react-hmre": "^1.0.1",
+- "babel-register": "^6.11.6",
+- "concurrently": "^3.4.0",
+- "copy-to-clipboard": "^3.0.6",
+- "css-loader": "^0.19.0",
+- "devtron": "^1.1.0",
+- "dom-storage": "^2.0.2",
+- "electron-packager": "^6.0.0",
+- "electron": "^1.6.15",
+- "eslint": "^3.13.1",
+- "eslint-config-standard": "^6.2.1",
+- "eslint-config-standard-jsx": "^3.2.0",
+- "eslint-plugin-react": "^7.2.0",
+- "faker": "^3.1.0",
+- "grunt": "^0.4.5",
+- "grunt-electron-installer": "^1.2.0",
+- "history": "^1.17.0",
+- "jsdom": "^9.4.2",
+- "json-loader": "^0.5.4",
+- "merge-stream": "^1.0.0",
+- "nib": "^1.1.0",
+- "react-color": "^2.2.2",
+- "react-css-modules": "^3.7.6",
+- "react-input-autosize": "^1.1.0",
+- "react-router": "^2.4.0",
+- "react-router-redux": "^4.0.4",
+- "standard": "^8.4.0",
+- "style-loader": "^0.12.4",
+- "stylus": "^0.52.4",
+- "stylus-loader": "^2.3.1",
+- "webpack": "^1.12.2",
+- "webpack-dev-server": "^1.12.0"
++ "ava": "0.16.0",
++ "babel-core": "6.14.0",
++ "babel-loader": "6.2.0",
++ "babel-plugin-react-transform": "2.0.2",
++ "babel-plugin-webpack-alias": "2.1.2",
++ "babel-preset-es2015": "6.24.1",
++ "babel-preset-react": "6.24.1",
++ "babel-preset-react-hmre": "1.1.1",
++ "babel-register": "6.24.1",
++ "concurrently": "3.4.0",
++ "copy-to-clipboard": "3.0.6",
++ "css-loader": "0.19.0",
++ "devtron": "1.4.0",
++ "dom-storage": "2.0.2",
++ "electron-packager": "6.0.2",
++ "electron": "1.7.9",
++ "eslint": "3.19.0",
++ "eslint-config-standard": "6.2.1",
++ "eslint-config-standard-jsx": "3.3.0",
++ "eslint-plugin-react": "7.2.0",
++ "faker": "3.1.0",
++ "grunt": "0.4.5",
++ "grunt-electron-installer": "1.2.3",
++ "history": "1.17.0",
++ "jsdom": "9.12.0",
++ "json-loader": "0.5.4",
++ "merge-stream": "1.0.1",
++ "nib": "1.1.2",
++ "react-color": "2.11.7",
++ "react-css-modules": "3.7.10",
++ "react-input-autosize": "1.1.4",
++ "react-router": "2.8.1",
++ "react-router-redux": "4.0.8",
++ "standard": "8.6.0",
++ "style-loader": "0.12.4",
++ "stylus": "0.52.4",
++ "stylus-loader": "2.5.1",
++ "webpack": "1.15.0",
++ "webpack-dev-server": "1.16.5"
+ },
+ "optionalDependencies": {
+- "grunt-electron-installer-debian": "^0.2.0",
+- "grunt-electron-installer-redhat": "^0.3.1"
++ "grunt-electron-installer-debian": "0.2.0",
++ "grunt-electron-installer-redhat": "0.3.1"
+ },
+ "optional": false,
+ "ava": {
diff --git a/remove-analytics.patch b/remove-analytics.patch
index 32967c0451bb..11863fc44cee 100644
--- a/remove-analytics.patch
+++ b/remove-analytics.patch
@@ -280,14 +280,14 @@ diff -ura a/browser/main/NoteList/index.js b/browser/main/NoteList/index.js
})
.catch((err) => {
diff -ura a/package.json b/package.json
---- a/package.json 2017-12-03 03:51:11.000000000 +0100
-+++ b/package.json 2017-12-03 08:11:01.174380873 +0100
+--- a/package.json 2017-12-03 17:30:46.687839000 +0100
++++ b/package.json 2017-12-03 17:56:10.071440319 +0100
@@ -50,8 +50,6 @@
"dependencies": {
- "@rokt33r/markdown-it-math": "^4.0.1",
- "@rokt33r/season": "^5.3.0",
-- "aws-sdk": "^2.48.0",
-- "aws-sdk-mobile-analytics": "^0.9.2",
- "codemirror": "^5.19.0",
- "electron-config": "^0.2.1",
- "electron-gh-releases": "^2.0.2",
+ "@rokt33r/markdown-it-math": "4.0.2",
+ "@rokt33r/season": "5.3.1",
+- "aws-sdk": "2.48.0",
+- "aws-sdk-mobile-analytics": "0.9.2",
+ "codemirror": "5.26.0",
+ "electron-config": "0.2.1",
+ "electron-gh-releases": "2.0.4",
diff --git a/warning-fix.patch b/warning-fix.patch
index 877e35e16148..2d137a09ea3b 100644
--- a/warning-fix.patch
+++ b/warning-fix.patch
@@ -1,6 +1,6 @@
-diff -ura b/gruntfile.js a/gruntfile.js
---- b/gruntfile.js 2017-11-25 06:41:20.000000000 +0100
-+++ a/gruntfile.js 2017-11-25 08:41:59.315502962 +0100
+diff -ura a/gruntfile.js b/gruntfile.js
+--- a/gruntfile.js 2017-11-25 06:41:20.000000000 +0100
++++ b/gruntfile.js 2017-12-03 17:53:35.083275486 +0100
@@ -6,6 +6,7 @@
module.exports = function (grunt) {
@@ -30,42 +30,41 @@ diff -ura b/gruntfile.js a/gruntfile.js
grunt.registerTask('compile', function () {
var done = this.async()
-Alleen in a: node_modules
-diff -ura b/package.json a/package.json
---- b/package.json 2017-11-25 06:41:20.000000000 +0100
-+++ a/package.json 2017-11-25 08:59:51.466808693 +0100
+diff -ura a/package.json b/package.json
+--- a/package.json 2017-12-03 17:30:46.687839000 +0100
++++ b/package.json 2017-12-03 17:47:38.677436194 +0100
@@ -102,15 +102,15 @@
- "css-loader": "^0.19.0",
- "devtron": "^1.1.0",
- "dom-storage": "^2.0.2",
-- "electron-packager": "^6.0.0",
-+ "electron-packager": "^8.6.0",
- "electron": "^1.6.15",
- "eslint": "^3.13.1",
- "eslint-config-standard": "^6.2.1",
- "eslint-config-standard-jsx": "^3.2.0",
- "eslint-plugin-react": "^7.2.0",
- "faker": "^3.1.0",
-- "grunt": "^0.4.5",
-- "grunt-electron-installer": "^1.2.0",
-+ "grunt": "^1.0.1",
-+ "grunt-electron-installer": "^2.1.0",
- "history": "^1.17.0",
- "jsdom": "^9.4.2",
- "json-loader": "^0.5.4",
+ "css-loader": "0.19.0",
+ "devtron": "1.4.0",
+ "dom-storage": "2.0.2",
+- "electron-packager": "6.0.2",
++ "electron-packager": "8.6.0",
+ "electron": "1.7.9",
+ "eslint": "3.19.0",
+ "eslint-config-standard": "6.2.1",
+ "eslint-config-standard-jsx": "3.3.0",
+ "eslint-plugin-react": "7.2.0",
+ "faker": "3.1.0",
+- "grunt": "0.4.5",
+- "grunt-electron-installer": "1.2.3",
++ "grunt": "1.0.1",
++ "grunt-electron-installer": "2.1.0",
+ "history": "1.17.0",
+ "jsdom": "9.12.0",
+ "json-loader": "0.5.4",
@@ -123,15 +123,11 @@
- "react-router-redux": "^4.0.4",
- "standard": "^8.4.0",
- "style-loader": "^0.12.4",
-- "stylus": "^0.52.4",
-+ "stylus": "^0.54.5",
- "stylus-loader": "^2.3.1",
- "webpack": "^1.12.2",
- "webpack-dev-server": "^1.12.0"
+ "react-router-redux": "4.0.8",
+ "standard": "8.6.0",
+ "style-loader": "0.12.4",
+- "stylus": "0.52.4",
++ "stylus": "0.54.4",
+ "stylus-loader": "2.5.1",
+ "webpack": "1.15.0",
+ "webpack-dev-server": "1.16.5"
},
- "optionalDependencies": {
-- "grunt-electron-installer-debian": "^0.2.0",
-- "grunt-electron-installer-redhat": "^0.3.1"
+- "grunt-electron-installer-debian": "0.2.0",
+- "grunt-electron-installer-redhat": "0.3.1"
- },
"optional": false,
"ava": {