summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 291d9ff0b331..957ce15883e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = botan-git
pkgdesc = Cryptography library written in C++
- pkgver = 2.7.0.r3.gf639dae0a
+ pkgver = 3.0.0.rc1.r31.g70d06e464
pkgrel = 1
url = https://botan.randombit.net/
arch = i686
@@ -10,11 +10,10 @@ pkgbase = botan-git
makedepends = python
depends = glibc
depends = zlib
- provides = botan
+ provides = botan=3.0.0.rc1.r31.g70d06e464
conflicts = botan
options = staticlibs
source = git+https://github.com/randombit/botan.git
sha256sums = SKIP
pkgname = botan-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c76c99397c91..7a9ec9a7f872 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=botan-git
-pkgver=2.7.0.r3.gf639dae0a
+pkgver=3.0.0.rc1.r31.g70d06e464
pkgrel=1
pkgdesc="Cryptography library written in C++"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://botan.randombit.net/"
license=('BSD')
depends=('glibc' 'zlib')
makedepends=('git' 'python')
-provides=('botan')
+provides=("botan=$pkgver")
conflicts=('botan')
options=('staticlibs')
source=("git+https://github.com/randombit/botan.git")
@@ -41,5 +41,5 @@ package() {
cd "botan"
make DESTDIR="$pkgdir" install
- install -Dm644 "license.txt" "$pkgdir/usr/share/licenses/botan/license.txt"
+ install -Dm644 "license.txt" -t "$pkgdir/usr/share/licenses/botan"
}