summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08a81225d189
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bottles
+ pkgdesc = Easily manage wineprefix
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://git.mirko.pm/brombinmirko/Bottles
+ arch = any
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ depends = hicolor-icon-theme
+ depends = dconf
+ depends = python
+ source = bottles-2.0.1.tar.gz::https://git.mirko.pm/brombinmirko/Bottles/archive/2.0.1.tar.gz
+ sha256sums = c98d3201f3ba4b0a6226ed44b0401fe893fed57cc433e1a7f6f2dcd33f92399d
+
+pkgname = bottles
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bec3f8339494
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=bottles
+pkgver=2.0.1
+pkgrel=1
+pkgdesc='Easily manage wineprefix'
+arch=('any')
+url="https://git.mirko.pm/brombinmirko/Bottles"
+license=('GPL3')
+depends=('hicolor-icon-theme' 'dconf' 'python')
+makedepends=('meson' 'ninja')
+source=("${pkgname}-${pkgver}.tar.gz::https://git.mirko.pm/brombinmirko/Bottles/archive/${pkgver}.tar.gz")
+sha256sums=('c98d3201f3ba4b0a6226ed44b0401fe893fed57cc433e1a7f6f2dcd33f92399d')
+
+build() {
+ cd bottles
+ meson --prefix='/usr' build
+ ninja -C build
+}
+
+package() {
+ cd bottles
+ DESTDIR="${pkgdir}" ninja -C build install
+}