summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..442ee7a236c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = boundary-desktop
+ pkgdesc = Desktop Client for Boundary
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://releases.hashicorp.com/boundary-desktop/1.3.0/boundary-desktop_1.3.0_linux_amd64.deb
+ arch = x86_64
+ license = MPL-2.0
+ depends = gtk3
+ depends = libnotify
+ depends = nss
+ depends = libxtst
+ depends = xdg-utils
+ depends = at-spi2-core
+ depends = libdrm
+ depends = mesa
+ depends = libxcb
+ depends = gvfs
+ depends = glib2
+ source = boundary-desktop_1.3.0_linux_amd64.deb::https://releases.hashicorp.com/boundary-desktop/1.3.0/boundary-desktop_1.3.0_linux_amd64.deb
+ sha256sums = 96a63d9379eb8e470a59973f4e30817f13f8c0a7d7e38018f1011b0818a321fb
+
+pkgname = boundary-desktop
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..722b531d7cee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Josef Vybíhal <josef.vybihal@gmail.com>
+
+pkgname=boundary-desktop
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Desktop Client for Boundary"
+arch=('x86_64')
+url="https://releases.hashicorp.com/boundary-desktop/${pkgver}/${pkgname}_${pkgver}_linux_amd64.deb"
+license=('MPL-2.0')
+depends=("gtk3" "libnotify" "nss" "libxtst" "xdg-utils" "at-spi2-core" "libdrm" "mesa" "libxcb" "gvfs" "glib2")
+#FIXME: optdepends=("org.freedesktop.secrets")
+# Recommends: pulseaudio | libasound2
+# Suggests: gir1.2-gnomekeyring-1.0, libgnome-keyring0, lsb-release
+source=("${pkgname}_${pkgver}_linux_amd64.deb::https://releases.hashicorp.com/boundary-desktop/${pkgver}/${pkgname}_${pkgver}_linux_amd64.deb")
+sha256sums=('96a63d9379eb8e470a59973f4e30817f13f8c0a7d7e38018f1011b0818a321fb')
+
+package() {
+ msg2 "Extracting the data.tar.xz"
+ tar -xf data.tar.xz -C "${pkgdir}/"
+
+ # .deb has 775
+ cd ${pkgdir}
+ chmod 755 ${pkgdir}/usr
+ chmod 755 ${pkgdir}/usr/*
+ chmod 755 ${pkgdir}/usr/share/*
+}