summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
-rw-r--r--makefile_uname.patch11
4 files changed, 30 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f167ac660832..6b84a10d0314 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Fri Jan 5 00:29:10 UTC 2018
pkgbase = bowtie
- pkgdesc = Bowtie is an alignment tool for short nucleotide sequences against long templates
- pkgver = 1.2.2
- pkgrel = 2
- url = http://bowtie-bio.sf.net
+ pkgdesc = Alignment tool for short nucleotide sequences against long templates
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://bowtie-bio.sourceforge.net
arch = x86_64
arch = i686
- license = PerlArtistic
- source = https://github.com/BenLangmead/bowtie/archive/v1.2.2_p1.tar.gz
- source = makefile_uname.patch
- sha256sums = e1b02b2e77a0d44a3dd411209fa1f44f0c4ee304ef5cc83f098275085740d5a1
- sha256sums = 6b77e333a3ef10e3f787fd2983afd69cdb48e82347fc3316510c2ba5639742a3
+ license = Artistic2.0
+ depends = python
+ depends = perl
+ source = bowtie-1.3.1.tar.gz::https://github.com/BenLangmead/bowtie/archive/v1.3.1.tar.gz
+ sha256sums = 147d9fe9652f7c5f351bfc0eb012e06981986fb43bd6bdfe88a95c02eabc6573
pkgname = bowtie
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1970994f527a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/.SRCINFO
+!/.gitignore
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index aaed9211bd76..6111583aaedd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,29 @@
-# Maintainer: Athemis <alexander.minges[at]googlemail[dot]com>
+# Maintainer: a821
+# Contributor: Athemis <alexander.minges[at]googlemail[dot]com>
# Contributor: sauliusl
+
pkgname=bowtie
-pkgver=1.2.2
-pkgrel=2
-pkgdesc="Bowtie is an alignment tool for short nucleotide sequences against long templates"
-url="http://bowtie-bio.sf.net"
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Alignment tool for short nucleotide sequences against long templates"
+url="https://bowtie-bio.sourceforge.net"
arch=('x86_64' 'i686')
-license=('PerlArtistic')
-depends=()
-source=("https://github.com/BenLangmead/bowtie/archive/v${pkgver}_p1.tar.gz"
- "makefile_uname.patch")
-sha256sums=('e1b02b2e77a0d44a3dd411209fa1f44f0c4ee304ef5cc83f098275085740d5a1'
- '6b77e333a3ef10e3f787fd2983afd69cdb48e82347fc3316510c2ba5639742a3')
+license=('Artistic2.0')
+depends=('python' 'perl')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/BenLangmead/bowtie/archive/v${pkgver}.tar.gz")
+sha256sums=('147d9fe9652f7c5f351bfc0eb012e06981986fb43bd6bdfe88a95c02eabc6573')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}_p1"
- patch -Np0 -i ../makefile_uname.patch
- make NO_TBB=1 EXTRA_CXXFLAGS="-std=c++03"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}_p1"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make prefix=/usr DESTDIR="${pkgdir}" install
- install -d ${pkgdir}/usr/share/doc/${pkgname}
- install -Dm755 scripts/*.pl "${pkgdir}/usr/bin"
- install -Dm755 scripts/*.sh "${pkgdir}/usr/bin"
- find doc -type f -exec install -Dm644 "{}" "${pkgdir}/usr/share/doc/${pkgname}" \;
- install -Dm644 TUTORIAL "${pkgdir}/usr/share/doc/$pkgname/TUTORIAL"
- install -Dm644 MANUAL "$pkgdir/usr/share/doc/$pkgname/MANUAL"
- install -Dm644 MANUAL.markdown "$pkgdir/usr/share/doc/$pkgname/MANUAL.markdown"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -Dm755 -t "${pkgdir}/usr/share/${pkgname}/scripts/" scripts/*.{pl,sh}
+ install -Dm644 -t "${pkgdir}/usr/share/doc/$pkgname/" MANUAL{,.markdown} TUTORIAL AUTHORS NEWS
}
# vim:set ts=2 sw=2 et:
diff --git a/makefile_uname.patch b/makefile_uname.patch
deleted file mode 100644
index b9833cd6d4db..000000000000
--- a/makefile_uname.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile 2013-04-18 21:33:44.000000000 +0200
-+++ Makefile 2013-06-26 16:25:17.622402991 +0200
-@@ -107,7 +107,7 @@
- endif
-
- ifeq (1,$(LINUX))
-- ifeq (x86_64, $(shell uname -p))
-+ ifeq (x86_64, $(shell uname -m))
- BITS=64
- endif
- endif