summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--makefile_uname.patch11
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0caa7be4861d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bowtie
+ pkgdesc = Bowtie is an alignment tool for short nucleotide sequences against long templates
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = http://bowtie-bio.sf.net
+ arch = x86_64
+ arch = i686
+ license = PerlArtistic
+ source = http://downloads.sourceforge.net/bowtie-bio/bowtie-1.1.1-src.zip
+ source = makefile_uname.patch
+ sha256sums = 92aacb2d32065ebee433ce76eff673c24ed12591eb6c20e22ad7e4a790c48f72
+ sha256sums = 6b77e333a3ef10e3f787fd2983afd69cdb48e82347fc3316510c2ba5639742a3
+
+pkgname = bowtie
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec42206cfe4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Athemis <alexander.minges[at]googlemail[dot]com>
+# Contributor: sauliusl
+pkgname=bowtie
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Bowtie is an alignment tool for short nucleotide sequences against long templates"
+url="http://bowtie-bio.sf.net"
+arch=('x86_64' 'i686')
+license=('PerlArtistic')
+depends=()
+source=("http://downloads.sourceforge.net/bowtie-bio/${pkgname}-${pkgver}-src.zip"
+ "makefile_uname.patch")
+sha256sums=('92aacb2d32065ebee433ce76eff673c24ed12591eb6c20e22ad7e4a790c48f72'
+ '6b77e333a3ef10e3f787fd2983afd69cdb48e82347fc3316510c2ba5639742a3')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np0 -i ../makefile_uname.patch
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -d ${pkgdir}/usr/bin
+ install -d ${pkgdir}/usr/share/doc/${pkgname}
+ install -Dm755 bowtie ${pkgdir}/usr/bin
+ install -Dm755 bowtie-build* ${pkgdir}/usr/bin
+ install -Dm755 bowtie-inspect* ${pkgdir}/usr/bin
+ install -Dm755 bowtie-align* ${pkgdir}/usr/bin
+ install -Dm755 scripts/* ${pkgdir}/usr/bin
+ install -Dm644 doc/* ${pkgdir}/usr/share/doc/${pkgname}
+ install -Dm644 TUTORIAL "${pkgdir}/usr/share/doc/${pkgname}/TUTORIAL"
+ install -Dm644 MANUAL "$pkgdir/usr/share/doc/$pkgname/MANUAL"
+ install -Dm644 MANUAL.markdown "$pkgdir/usr/share/doc/$pkgname/MANUAL.markdown"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/makefile_uname.patch b/makefile_uname.patch
new file mode 100644
index 000000000000..b9833cd6d4db
--- /dev/null
+++ b/makefile_uname.patch
@@ -0,0 +1,11 @@
+--- Makefile 2013-04-18 21:33:44.000000000 +0200
++++ Makefile 2013-06-26 16:25:17.622402991 +0200
+@@ -107,7 +107,7 @@
+ endif
+
+ ifeq (1,$(LINUX))
+- ifeq (x86_64, $(shell uname -p))
++ ifeq (x86_64, $(shell uname -m))
+ BITS=64
+ endif
+ endif