summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f167ac660832..c976912c35d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Fri Jan 5 00:29:10 UTC 2018
pkgbase = bowtie
pkgdesc = Bowtie is an alignment tool for short nucleotide sequences against long templates
- pkgver = 1.2.2
- pkgrel = 2
+ pkgver = 1.2.3
+ pkgrel = 1
url = http://bowtie-bio.sf.net
arch = x86_64
arch = i686
license = PerlArtistic
- source = https://github.com/BenLangmead/bowtie/archive/v1.2.2_p1.tar.gz
+ source = https://github.com/BenLangmead/bowtie/archive/v1.2.3.tar.gz
source = makefile_uname.patch
- sha256sums = e1b02b2e77a0d44a3dd411209fa1f44f0c4ee304ef5cc83f098275085740d5a1
+ sha256sums = 86402114caeacbb3a3030509cb59f0b7e96361c7b3ee2dd50e2cd68200898823
sha256sums = 6b77e333a3ef10e3f787fd2983afd69cdb48e82347fc3316510c2ba5639742a3
pkgname = bowtie
diff --git a/PKGBUILD b/PKGBUILD
index aaed9211bd76..25a0c7d8b275 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
# Maintainer: Athemis <alexander.minges[at]googlemail[dot]com>
# Contributor: sauliusl
pkgname=bowtie
-pkgver=1.2.2
-pkgrel=2
+pkgver=1.2.3
+pkgrel=1
pkgdesc="Bowtie is an alignment tool for short nucleotide sequences against long templates"
url="http://bowtie-bio.sf.net"
arch=('x86_64' 'i686')
license=('PerlArtistic')
depends=()
-source=("https://github.com/BenLangmead/bowtie/archive/v${pkgver}_p1.tar.gz"
+source=("https://github.com/BenLangmead/bowtie/archive/v${pkgver}.tar.gz"
"makefile_uname.patch")
-sha256sums=('e1b02b2e77a0d44a3dd411209fa1f44f0c4ee304ef5cc83f098275085740d5a1'
+sha256sums=('86402114caeacbb3a3030509cb59f0b7e96361c7b3ee2dd50e2cd68200898823'
'6b77e333a3ef10e3f787fd2983afd69cdb48e82347fc3316510c2ba5639742a3')
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}_p1"
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
patch -Np0 -i ../makefile_uname.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
make NO_TBB=1 EXTRA_CXXFLAGS="-std=c++03"
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}_p1"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make prefix=/usr DESTDIR="${pkgdir}" install
install -d ${pkgdir}/usr/share/doc/${pkgname}
install -Dm755 scripts/*.pl "${pkgdir}/usr/bin"