summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD54
3 files changed, 36 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8524de5a9eb8..be13ac188d62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
-# Generated by mksrcinfo v8
-# Mon Jul 4 22:11:30 UTC 2016
pkgbase = bowtie2-git
- pkgdesc = Bowtie 2 is an ultrafast and memory-efficient tool for aligning sequencing reads to long reference sequence.
- pkgver = v2.2.9.r9.g9c90266
+ pkgdesc = Tool for aligning sequencing reads to long reference sequences
+ pkgver = 2.5.3.r0.ga43fa6f
pkgrel = 1
- url = http://bowtie-bio.sourceforge.net/bowtie2
- arch = any
- license = GPL3
- optdepends = intel-tbb: faster multithreading
+ url = https://bowtie-bio.sourceforge.net/bowtie2
+ arch = x86_64
+ license = GPL-3.0-only
+ makedepends = git
+ depends = perl
+ depends = python
provides = bowtie2
conflicts = bowtie2
- source = git://github.com/BenLangmead/bowtie2
- md5sums = SKIP
+ source = bowtie2-git::git+https://github.com/BenLangmead/bowtie2
+ sha256sums = SKIP
pkgname = bowtie2-git
-
diff --git a/.gitignore b/.gitignore
index 783d76e7bd7a..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,4 @@
-src/
-pkg/
-bowtie2/
-*.tar.gz
-*.tar.xz
-*.tar
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 6a115eb73f15..88184be2b004 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,36 @@
-# $Id$
-# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+# Maintainer: a821 < at mail dot de >
+# Contributor: Grey Christoforo <first name [at] last name [dot] net>
pkgname=bowtie2-git
-_pkgname=bowtie2
-pkgver=v2.2.9.r9.g9c90266
+pkgver=2.5.3.r0.ga43fa6f
pkgrel=1
-pkgdesc="Bowtie 2 is an ultrafast and memory-efficient tool for aligning sequencing reads to long reference sequence."
-arch=("any")
-optdepends=('intel-tbb: faster multithreading')
-url="http://bowtie-bio.sourceforge.net/bowtie2"
-license=('GPL3')
-source=('git://github.com/BenLangmead/bowtie2')
-md5sums=('SKIP')
+pkgdesc="Tool for aligning sequencing reads to long reference sequences"
+arch=("x86_64")
+url="https://bowtie-bio.sourceforge.net/bowtie2"
+license=('GPL-3.0-only')
+depends=('perl' 'python')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/BenLangmead/bowtie2")
conflicts=('bowtie2')
provides=('bowtie2')
+sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd $_pkgname
- make clean
+ cd $pkgname
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./g'
}
build() {
- cd $_pkgname
- if pacman -Q intel-tbb > /dev/null 2>/dev/null; then
- msg2 "Building with Intel's TBB multithreading support"
- WITH_TBB=1 make
- else
- msg2 "You haven't installed the intel-tbb package; building without Intel's TBB multithreading support"
- WITH_TBB=0 make
- fi
+ cd $pkgname
+ make PREFIX=/usr
}
package() {
- mkdir -p "${pkgdir}/opt/${_pkgname}"
- cp -a "${srcdir}/${_pkgname}"/* "${pkgdir}/opt/${_pkgname}"/.
- cd "${srcdir}/${_pkgname}"
- make prefix=/usr DESTDIR="${pkgdir}" install
- install -Dm644 "${srcdir}/${_pkgname}/MANUAL" -t "${pkgdir}/usr/share/doc/${_pkgname}"
- install -Dm644 "${srcdir}/${_pkgname}/LICENSE" -t "$pkgdir/usr/share/licenses/${_pkgname}"
+ cd $pkgname
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" \
+ AUTHORS BOWTIE2_VERSION MANUAL* NEWS README.md TUTORIAL
+ cp -r doc example "$pkgdir/usr/share/doc/$pkgname"
}
+
+# vim: set ts=4 sw=4 et: