summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee86936aa15f..cd6ec20f0250 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = box64-git
pkgdesc = Linux Userspace x86_64 Emulator with a twist
- pkgver = v0.1.6.r24.g40c5824
+ pkgver = v0.2.0.r6.g554f4889
pkgrel = 1
url = https://github.com/ptitSeb/box64
arch = x86_64
arch = aarch64
+ arch = riscv64
license = MIT
makedepends = git
makedepends = cmake
diff --git a/PKGBUILD b/PKGBUILD
index 3a8ca4e00074..6ad6748f9622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
_pkgname=box64
pkgname=${_pkgname}-git
-pkgver=v0.1.6.r24.g40c5824
+pkgver=v0.2.0.r6.g554f4889
pkgrel=1
pkgdesc='Linux Userspace x86_64 Emulator with a twist'
-arch=('x86_64' 'aarch64')
+arch=('x86_64' 'aarch64' 'riscv64')
url='https://github.com/ptitSeb/box64'
license=('MIT')
depends=('gcc-libs')
@@ -33,6 +33,11 @@ build() {
-DLD80BITS=1 -DNOALIGN=1 \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
+ elif [[ $CARCH == "riscv64" ]]; then
+ cmake -B build -S . \
+ -DRV64=1 \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr
fi
make -C build
}
@@ -43,6 +48,8 @@ package() {
make DESTDIR=${pkgdir} install
elif [[ $CARCH == "x86_64" ]]; then
install -Dm755 box64 -t "${pkgdir}/usr/bin/"
+ elif [[ $CARCH == "riscv64" ]]; then
+ make DESTDIR=${pkgdir} install
fi
install -Dm644 ../LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}/"