summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b98e34061c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bpm-git
+ pkgdesc = Blue Pink Metronome for Qt5. Easy to use metronome controlled by the keyboard.
+ pkgver = 4fc659c
+ pkgrel = 1
+ url = https://github.com/cfillion/bpm
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = tup
+ depends = qt5-base
+ depends = qt5-multimedia
+ source = git://github.com/cfillion/bpm
+ md5sums = SKIP
+
+pkgname = bpm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0759b150a0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Lukas Sabota <LTsmooth42 _at_ gmail _dot_ com>
+pkgname=bpm-git
+pkgver=4fc659c
+pkgrel=1
+pkgdesc="Blue Pink Metronome for Qt5. Easy to use metronome controlled by the keyboard".
+arch=('i686' 'x86_64')
+url="https://github.com/cfillion/bpm"
+license=('GPL')
+depends=('qt5-base' 'qt5-multimedia' )
+makedepends=('tup')
+source=(git://github.com/cfillion/bpm)
+md5sums=('SKIP')
+
+pkgver() {
+ cd bpm
+ git describe --always| sed 's/-/./g'
+}
+
+
+build() {
+ cd bpm
+ tup
+}
+
+package() {
+ cd bpm
+ install -D -m755 bin/bpm "$pkgdir/usr/bin/bpm"
+}
+