summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
-rw-r--r--REVERT-enable-GlobalMediaControlsCastStartStop.patch32
-rw-r--r--REVERT-roll-src-third_party-ffmpeg-m102.patch333
-rw-r--r--REVERT-roll-src-third_party-ffmpeg-m106.patch55
-rw-r--r--angle-wayland-include-protocol.patch38
-rw-r--r--re-fix-TFLite-build-error-on-linux-with-system-zlib.patch41
-rw-r--r--unbundle-jsoncpp-avoid-CFI-faults-with-is_cfi-true.patch38
-rw-r--r--use-oauth2-client-switches-as-default.patch17
9 files changed, 40 insertions, 576 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7ffbb855c97..775e0ea4554a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -37,6 +37,26 @@ pkgbase = brave
depends = systemd
depends = ttf-liberation
depends = xdg-utils
+ depends = fontconfig
+ depends = woff2
+ depends = aom
+ depends = brotli
+ depends = libjpeg
+ depends = icu
+ depends = dav1d
+ depends = flac
+ depends = snappy
+ depends = libxml2
+ depends = ffmpeg
+ depends = libwebp
+ depends = minizip
+ depends = opus
+ depends = harfbuzz
+ depends = re2
+ depends = jsoncpp
+ depends = libxslt
+ depends = libpng
+ depends = freetype2
optdepends = pipewire: WebRTC desktop sharing under Wayland
optdepends = kdialog: support for native dialogs in Plasma
optdepends = org.freedesktop.secrets: password storage backend
diff --git a/PKGBUILD b/PKGBUILD
index 17b854c34219..4e9f3b20148c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -92,24 +92,18 @@ source=("brave-browser::git+https://github.com/brave/brave-browser.git#tag=v$pkg
brave-1.43-bitcoin-core_remove-serialize.h.patch
brave-1.43-brave_today-base_utf_string_conversions.patch
brave-1.43-debounce-debounce_navigation_throttle_fix.patch
- brave-1.43-ntp_background_images-std-size_t.patch
- "https://raw.githubusercontent.com/archlinux/svntogit-packages/master/chromium/trunk/angle-wayland-include-protocol.patch"
- "https://raw.githubusercontent.com/archlinux/svntogit-packages/master/chromium/trunk/re-fix-TFLite-build-error-on-linux-with-system-zlib.patch"
- "https://raw.githubusercontent.com/archlinux/svntogit-packages/master/chromium/trunk/unbundle-jsoncpp-avoid-CFI-faults-with-is_cfi-true.patch"
- "https://raw.githubusercontent.com/archlinux/svntogit-packages/master/chromium/trunk/use-oauth2-client-switches-as-default.patch"
- "https://raw.githubusercontent.com/archlinux/svntogit-packages/master/chromium/trunk/REVERT-enable-GlobalMediaControlsCastStartStop.patch"
- "https://raw.githubusercontent.com/archlinux/svntogit-packages/master/chromium/trunk/REVERT-roll-src-third_party-ffmpeg-m102.patch"
- "https://raw.githubusercontent.com/archlinux/svntogit-packages/master/chromium/trunk/REVERT-roll-src-third_party-ffmpeg-m106.patch"
-)
-#_arch_revision=bf2401407df5bcc938382eb03748fbef41e41c89
-#_patches=(unbundle-jsoncpp-avoid-CFI-faults-with-is_cfi-true.patch
-# REVERT-enable-GlobalMediaControlsCastStartStop.patch
-# REVERT-roll-src-third_party-ffmpeg-m102.patch
-# REVERT-roll-src-third_party-ffmpeg-m106.patch
-# angle-wayland-include-protocol.patch)
-#for _patch in "${_patches[@]}"; do
-# source+=("$_patch::https://raw.githubusercontent.com/archlinux/svntogit-packages/$_arch_revision/trunk/$_patch")
-#done
+ brave-1.43-ntp_background_images-std-size_t.patch)
+_arch_revision=a4877c0840780910faa5ec4506e8e1267f8eb942
+_patches=(REVERT-enable-GlobalMediaControlsCastStartStop.patch
+ REVERT-roll-src-third_party-ffmpeg-m102.patch
+ REVERT-roll-src-third_party-ffmpeg-m106.patch
+ angle-wayland-include-protocol.patch
+ re-fix-TFLite-build-error-on-linux-with-system-zlib.patch
+ unbundle-jsoncpp-avoid-CFI-faults-with-is_cfi-true.patch
+ use-oauth2-client-switches-as-default.patch)
+for _patch in "${_patches[@]}"; do
+ source+=("https://raw.githubusercontent.com/archlinux/svntogit-packages/$_arch_revision/chromium/trunk/$_patch")
+done
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -126,13 +120,13 @@ sha256sums=('SKIP'
'ca7f3edbf17aeca84ec595b0cedcca47fb098fa8600651dcea6b396af3af8d93'
'30a6a9ca2a6dd965cb2d9f02639079130948bf45d483f0c629f2cf8394a1c22f'
'ea0cd714ccaa839baf7c71e9077264016aa19415600f16b77d5398fd49f5a70b'
+ '779fb13f2494209d3a7f1f23a823e59b9dded601866d3ab095937a1a04e19ac6'
+ '30df59a9e2d95dcb720357ec4a83d9be51e59cc5551365da4c0073e68ccdec44'
+ '4c12d31d020799d31355faa7d1fe2a5a807f7458e7f0c374adf55edb37032152'
'cd0d9d2a1d6a522d47c3c0891dabe4ad72eabbebc0fe5642b9e22efa3d5ee572'
'9015b9d6d5b4c1e7248d6477a4b4b6bd6a3ebdc57225d2d8efcd79fc61790716'
'b908f37c5a886e855953f69e4dd6b90baa35e79f5c74673f7425f2cdb642eb00'
- 'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
- '779fb13f2494209d3a7f1f23a823e59b9dded601866d3ab095937a1a04e19ac6'
- '30df59a9e2d95dcb720357ec4a83d9be51e59cc5551365da4c0073e68ccdec44'
- '4c12d31d020799d31355faa7d1fe2a5a807f7458e7f0c374adf55edb37032152')
+ 'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
@@ -164,8 +158,12 @@ declare -gA _system_libs=(
_unwanted_bundled_libs=(
"$(printf "%s\n" ${!_system_libs[@]} | sed 's/^libjpeg$/&_turbo/')"
)
+for _dep in "${_system_libs[@]}"; do
+ depends+=($_dep)
+done
prepare() {
+
cd chromium-launcher-$_launcher_ver
patch -Np1 -i ../chromium-launcher-electron-app.patch
diff --git a/REVERT-enable-GlobalMediaControlsCastStartStop.patch b/REVERT-enable-GlobalMediaControlsCastStartStop.patch
deleted file mode 100644
index e0d4544de482..000000000000
--- a/REVERT-enable-GlobalMediaControlsCastStartStop.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From b58f0f2725a8c1a8a131f9984b5fd53b54119dba Mon Sep 17 00:00:00 2001
-From: Muyao Xu <muyaoxu@google.com>
-Date: Thu, 20 Jan 2022 23:46:21 +0000
-Subject: [PATCH] [Zenith] Enable GlobalMediaControlsCastStartStop flag by
- default
-
-The feature is rolled out to 100% stable through finch for M96+.
-This CL enables it by default and fixes some unit tests failures.
-
-Bug: 1287242, 1287305
-Change-Id: I7e5c9625b77379fef253c41ef292a0dd6fc366fb
-Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3388416
-Reviewed-by: Takumi Fujimoto <takumif@chromium.org>
-Commit-Queue: Muyao Xu <muyaoxu@google.com>
-Cr-Commit-Position: refs/heads/main@{#961658}
----
- chrome/browser/media/router/media_router_feature.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/chrome/browser/media/router/media_router_feature.cc b/chrome/browser/media/router/media_router_feature.cc
-index f28f9b0b802..a8d544f7d6d 100644
---- a/chrome/browser/media/router/media_router_feature.cc
-+++ b/chrome/browser/media/router/media_router_feature.cc
-@@ -33,7 +33,7 @@ const base::Feature kMediaRouter{"MediaRouter",
- const base::Feature kCastAllowAllIPsFeature{"CastAllowAllIPs",
- base::FEATURE_DISABLED_BY_DEFAULT};
- const base::Feature kGlobalMediaControlsCastStartStop{
-- "GlobalMediaControlsCastStartStop", base::FEATURE_DISABLED_BY_DEFAULT};
-+ "GlobalMediaControlsCastStartStop", base::FEATURE_ENABLED_BY_DEFAULT};
- const base::Feature kAllowAllSitesToInitiateMirroring{
- "AllowAllSitesToInitiateMirroring", base::FEATURE_DISABLED_BY_DEFAULT};
- const base::Feature kDialMediaRouteProvider{"DialMediaRouteProvider",
diff --git a/REVERT-roll-src-third_party-ffmpeg-m102.patch b/REVERT-roll-src-third_party-ffmpeg-m102.patch
deleted file mode 100644
index e739b40a2733..000000000000
--- a/REVERT-roll-src-third_party-ffmpeg-m102.patch
+++ /dev/null
@@ -1,333 +0,0 @@
-From 6e554a30893150793c2638e3689cf208ffc8e375 Mon Sep 17 00:00:00 2001
-From: Dale Curtis <dalecurtis@chromium.org>
-Date: Sat, 2 Apr 2022 05:13:53 +0000
-Subject: [PATCH] Roll src/third_party/ffmpeg/ 574c39cce..32b2d1d526 (1125
- commits)
-
-https://chromium.googlesource.com/chromium/third_party/ffmpeg.git/+log/574c39cce323..32b2d1d526
-
-Created with:
- roll-dep src/third_party/ffmpeg
-
-Fixed: 1293918
-Cq-Include-Trybots: luci.chromium.try:mac_chromium_asan_rel_ng,linux_chromium_asan_rel_ng,linux_chromium_chromeos_asan_rel_ng
-Change-Id: I41945d0f963e3d1f65940067bac22f63b68e37d2
-Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3565647
-Auto-Submit: Dale Curtis <dalecurtis@chromium.org>
-Reviewed-by: Dan Sanders <sandersd@chromium.org>
-Commit-Queue: Dale Curtis <dalecurtis@chromium.org>
-Cr-Commit-Position: refs/heads/main@{#988253}
----
- .../clear_key_cdm/ffmpeg_cdm_audio_decoder.cc | 29 ++++++++++---------
- media/ffmpeg/ffmpeg_common.cc | 11 +++----
- media/filters/audio_file_reader.cc | 9 +++---
- media/filters/audio_file_reader_unittest.cc | 6 ++--
- .../filters/audio_video_metadata_extractor.cc | 11 +++++--
- .../filters/ffmpeg_aac_bitstream_converter.cc | 7 +++--
- ...ffmpeg_aac_bitstream_converter_unittest.cc | 2 +-
- media/filters/ffmpeg_audio_decoder.cc | 13 +++++----
- 8 files changed, 51 insertions(+), 37 deletions(-)
-
-diff --git a/media/cdm/library_cdm/clear_key_cdm/ffmpeg_cdm_audio_decoder.cc b/media/cdm/library_cdm/clear_key_cdm/ffmpeg_cdm_audio_decoder.cc
-index e4fc3f460e2..9b1ad9f7675 100644
---- a/media/cdm/library_cdm/clear_key_cdm/ffmpeg_cdm_audio_decoder.cc
-+++ b/media/cdm/library_cdm/clear_key_cdm/ffmpeg_cdm_audio_decoder.cc
-@@ -74,7 +74,7 @@ void CdmAudioDecoderConfigToAVCodecContext(
- codec_context->sample_fmt = AV_SAMPLE_FMT_NONE;
- }
-
-- codec_context->channels = config.channel_count;
-+ codec_context->ch_layout.nb_channels = config.channel_count;
- codec_context->sample_rate = config.samples_per_second;
-
- if (config.extra_data) {
-@@ -124,8 +124,8 @@ void CopySamples(cdm::AudioFormat cdm_format,
- case cdm::kAudioFormatPlanarS16:
- case cdm::kAudioFormatPlanarF32: {
- const int decoded_size_per_channel =
-- decoded_audio_size / av_frame.channels;
-- for (int i = 0; i < av_frame.channels; ++i) {
-+ decoded_audio_size / av_frame.ch_layout.nb_channels;
-+ for (int i = 0; i < av_frame.ch_layout.nb_channels; ++i) {
- memcpy(output_buffer, av_frame.extended_data[i],
- decoded_size_per_channel);
- output_buffer += decoded_size_per_channel;
-@@ -185,13 +185,14 @@ bool FFmpegCdmAudioDecoder::Initialize(
- // Success!
- decoding_loop_ = std::make_unique<FFmpegDecodingLoop>(codec_context_.get());
- samples_per_second_ = config.samples_per_second;
-- bytes_per_frame_ = codec_context_->channels * config.bits_per_channel / 8;
-+ bytes_per_frame_ =
-+ codec_context_->ch_layout.nb_channels * config.bits_per_channel / 8;
- output_timestamp_helper_ =
- std::make_unique<AudioTimestampHelper>(config.samples_per_second);
- is_initialized_ = true;
-
- // Store initial values to guard against midstream configuration changes.
-- channels_ = codec_context_->channels;
-+ channels_ = codec_context_->ch_layout.nb_channels;
- av_sample_format_ = codec_context_->sample_fmt;
-
- return true;
-@@ -291,17 +292,19 @@ cdm::Status FFmpegCdmAudioDecoder::DecodeBuffer(
- for (auto& frame : audio_frames) {
- int decoded_audio_size = 0;
- if (frame->sample_rate != samples_per_second_ ||
-- frame->channels != channels_ || frame->format != av_sample_format_) {
-+ frame->ch_layout.nb_channels != channels_ ||
-+ frame->format != av_sample_format_) {
- DLOG(ERROR) << "Unsupported midstream configuration change!"
- << " Sample Rate: " << frame->sample_rate << " vs "
-- << samples_per_second_ << ", Channels: " << frame->channels
-- << " vs " << channels_ << ", Sample Format: " << frame->format
-- << " vs " << av_sample_format_;
-+ << samples_per_second_
-+ << ", Channels: " << frame->ch_layout.nb_channels << " vs "
-+ << channels_ << ", Sample Format: " << frame->format << " vs "
-+ << av_sample_format_;
- return cdm::kDecodeError;
- }
-
- decoded_audio_size = av_samples_get_buffer_size(
-- nullptr, codec_context_->channels, frame->nb_samples,
-+ nullptr, codec_context_->ch_layout.nb_channels, frame->nb_samples,
- codec_context_->sample_fmt, 1);
- if (!decoded_audio_size)
- continue;
-@@ -320,9 +323,9 @@ bool FFmpegCdmAudioDecoder::OnNewFrame(
- size_t* total_size,
- std::vector<std::unique_ptr<AVFrame, ScopedPtrAVFreeFrame>>* audio_frames,
- AVFrame* frame) {
-- *total_size += av_samples_get_buffer_size(nullptr, codec_context_->channels,
-- frame->nb_samples,
-- codec_context_->sample_fmt, 1);
-+ *total_size += av_samples_get_buffer_size(
-+ nullptr, codec_context_->ch_layout.nb_channels, frame->nb_samples,
-+ codec_context_->sample_fmt, 1);
- audio_frames->emplace_back(av_frame_clone(frame));
- return true;
- }
-diff --git a/media/ffmpeg/ffmpeg_common.cc b/media/ffmpeg/ffmpeg_common.cc
-index 87ca8969626..76f03d6608e 100644
---- a/media/ffmpeg/ffmpeg_common.cc
-+++ b/media/ffmpeg/ffmpeg_common.cc
-@@ -345,10 +345,11 @@ bool AVCodecContextToAudioDecoderConfig(const AVCodecContext* codec_context,
- codec_context->sample_fmt, codec_context->codec_id);
-
- ChannelLayout channel_layout =
-- codec_context->channels > 8
-+ codec_context->ch_layout.nb_channels > 8
- ? CHANNEL_LAYOUT_DISCRETE
-- : ChannelLayoutToChromeChannelLayout(codec_context->channel_layout,
-- codec_context->channels);
-+ : ChannelLayoutToChromeChannelLayout(
-+ codec_context->ch_layout.u.mask,
-+ codec_context->ch_layout.nb_channels);
-
- int sample_rate = codec_context->sample_rate;
- switch (codec) {
-@@ -401,7 +402,7 @@ bool AVCodecContextToAudioDecoderConfig(const AVCodecContext* codec_context,
- extra_data, encryption_scheme, seek_preroll,
- codec_context->delay);
- if (channel_layout == CHANNEL_LAYOUT_DISCRETE)
-- config->SetChannelsForDiscrete(codec_context->channels);
-+ config->SetChannelsForDiscrete(codec_context->ch_layout.nb_channels);
-
- #if BUILDFLAG(ENABLE_PLATFORM_AC3_EAC3_AUDIO)
- // These are bitstream formats unknown to ffmpeg, so they don't have
-@@ -470,7 +471,7 @@ void AudioDecoderConfigToAVCodecContext(const AudioDecoderConfig& config,
-
- // TODO(scherkus): should we set |channel_layout|? I'm not sure if FFmpeg uses
- // said information to decode.
-- codec_context->channels = config.channels();
-+ codec_context->ch_layout.nb_channels = config.channels();
- codec_context->sample_rate = config.samples_per_second();
-
- if (config.extra_data().empty()) {
-diff --git a/media/filters/audio_file_reader.cc b/media/filters/audio_file_reader.cc
-index 5f257bdfaa6..e1be5aa9a5b 100644
---- a/media/filters/audio_file_reader.cc
-+++ b/media/filters/audio_file_reader.cc
-@@ -113,14 +113,15 @@ bool AudioFileReader::OpenDecoder() {
-
- // Verify the channel layout is supported by Chrome. Acts as a sanity check
- // against invalid files. See http://crbug.com/171962
-- if (ChannelLayoutToChromeChannelLayout(codec_context_->channel_layout,
-- codec_context_->channels) ==
-+ if (ChannelLayoutToChromeChannelLayout(
-+ codec_context_->ch_layout.u.mask,
-+ codec_context_->ch_layout.nb_channels) ==
- CHANNEL_LAYOUT_UNSUPPORTED) {
- return false;
- }
-
- // Store initial values to guard against midstream configuration changes.
-- channels_ = codec_context_->channels;
-+ channels_ = codec_context_->ch_layout.nb_channels;
- audio_codec_ = CodecIDToAudioCodec(codec_context_->codec_id);
- sample_rate_ = codec_context_->sample_rate;
- av_sample_format_ = codec_context_->sample_fmt;
-@@ -223,7 +224,7 @@ bool AudioFileReader::OnNewFrame(
- if (frames_read < 0)
- return false;
-
-- const int channels = frame->channels;
-+ const int channels = frame->ch_layout.nb_channels;
- if (frame->sample_rate != sample_rate_ || channels != channels_ ||
- frame->format != av_sample_format_) {
- DLOG(ERROR) << "Unsupported midstream configuration change!"
-diff --git a/media/filters/audio_file_reader_unittest.cc b/media/filters/audio_file_reader_unittest.cc
-index 2aba7927a31..1f45a50cace 100644
---- a/media/filters/audio_file_reader_unittest.cc
-+++ b/media/filters/audio_file_reader_unittest.cc
-@@ -121,11 +121,11 @@ class AudioFileReaderTest : public testing::Test {
- EXPECT_FALSE(reader_->Open());
- }
-
-- void RunTestFailingDecode(const char* fn) {
-+ void RunTestFailingDecode(const char* fn, int expect_read = 0) {
- Initialize(fn);
- EXPECT_TRUE(reader_->Open());
- std::vector<std::unique_ptr<AudioBus>> decoded_audio_packets;
-- EXPECT_EQ(reader_->Read(&decoded_audio_packets), 0);
-+ EXPECT_EQ(reader_->Read(&decoded_audio_packets), expect_read);
- }
-
- void RunTestPartialDecode(const char* fn) {
-@@ -219,7 +219,7 @@ TEST_F(AudioFileReaderTest, AAC_ADTS) {
- }
-
- TEST_F(AudioFileReaderTest, MidStreamConfigChangesFail) {
-- RunTestFailingDecode("midstream_config_change.mp3");
-+ RunTestFailingDecode("midstream_config_change.mp3", 42624);
- }
- #endif
-
-diff --git a/media/filters/audio_video_metadata_extractor.cc b/media/filters/audio_video_metadata_extractor.cc
-index 185819eb936..69ff508c221 100644
---- a/media/filters/audio_video_metadata_extractor.cc
-+++ b/media/filters/audio_video_metadata_extractor.cc
-@@ -113,6 +113,15 @@ bool AudioVideoMetadataExtractor::Extract(DataSource* source,
- if (!stream)
- continue;
-
-+ void* display_matrix =
-+ av_stream_get_side_data(stream, AV_PKT_DATA_DISPLAYMATRIX, nullptr);
-+ if (display_matrix) {
-+ rotation_ = VideoTransformation::FromFFmpegDisplayMatrix(
-+ static_cast<int32_t*>(display_matrix))
-+ .rotation;
-+ info.tags["rotate"] = base::NumberToString(rotation_);
-+ }
-+
- // Extract dictionary from streams also. Needed for containers that attach
- // metadata to contained streams instead the container itself, like OGG.
- ExtractDictionary(stream->metadata, &info.tags);
-@@ -255,8 +264,6 @@ void AudioVideoMetadataExtractor::ExtractDictionary(AVDictionary* metadata,
- if (raw_tags->find(tag->key) == raw_tags->end())
- (*raw_tags)[tag->key] = tag->value;
-
-- if (ExtractInt(tag, "rotate", &rotation_))
-- continue;
- if (ExtractString(tag, "album", &album_))
- continue;
- if (ExtractString(tag, "artist", &artist_))
-diff --git a/media/filters/ffmpeg_aac_bitstream_converter.cc b/media/filters/ffmpeg_aac_bitstream_converter.cc
-index 6f231c85729..ca5e5fb927d 100644
---- a/media/filters/ffmpeg_aac_bitstream_converter.cc
-+++ b/media/filters/ffmpeg_aac_bitstream_converter.cc
-@@ -195,14 +195,15 @@ bool FFmpegAACBitstreamConverter::ConvertPacket(AVPacket* packet) {
- if (!header_generated_ || codec_ != stream_codec_parameters_->codec_id ||
- audio_profile_ != stream_codec_parameters_->profile ||
- sample_rate_index_ != sample_rate_index ||
-- channel_configuration_ != stream_codec_parameters_->channels ||
-+ channel_configuration_ !=
-+ stream_codec_parameters_->ch_layout.nb_channels ||
- frame_length_ != header_plus_packet_size) {
- header_generated_ =
- GenerateAdtsHeader(stream_codec_parameters_->codec_id,
- 0, // layer
- stream_codec_parameters_->profile, sample_rate_index,
- 0, // private stream
-- stream_codec_parameters_->channels,
-+ stream_codec_parameters_->ch_layout.nb_channels,
- 0, // originality
- 0, // home
- 0, // copyrighted_stream
-@@ -214,7 +215,7 @@ bool FFmpegAACBitstreamConverter::ConvertPacket(AVPacket* packet) {
- codec_ = stream_codec_parameters_->codec_id;
- audio_profile_ = stream_codec_parameters_->profile;
- sample_rate_index_ = sample_rate_index;
-- channel_configuration_ = stream_codec_parameters_->channels;
-+ channel_configuration_ = stream_codec_parameters_->ch_layout.nb_channels;
- frame_length_ = header_plus_packet_size;
- }
-
-diff --git a/media/filters/ffmpeg_aac_bitstream_converter_unittest.cc b/media/filters/ffmpeg_aac_bitstream_converter_unittest.cc
-index 1fd4c5ccd7d..f59bcd8fdaf 100644
---- a/media/filters/ffmpeg_aac_bitstream_converter_unittest.cc
-+++ b/media/filters/ffmpeg_aac_bitstream_converter_unittest.cc
-@@ -34,7 +34,7 @@ class FFmpegAACBitstreamConverterTest : public testing::Test {
- memset(&test_parameters_, 0, sizeof(AVCodecParameters));
- test_parameters_.codec_id = AV_CODEC_ID_AAC;
- test_parameters_.profile = FF_PROFILE_AAC_MAIN;
-- test_parameters_.channels = 2;
-+ test_parameters_.ch_layout.nb_channels = 2;
- test_parameters_.extradata = extradata_header_;
- test_parameters_.extradata_size = sizeof(extradata_header_);
- }
-diff --git a/media/filters/ffmpeg_audio_decoder.cc b/media/filters/ffmpeg_audio_decoder.cc
-index 6a56c675f7d..4615fdeb3fb 100644
---- a/media/filters/ffmpeg_audio_decoder.cc
-+++ b/media/filters/ffmpeg_audio_decoder.cc
-@@ -28,7 +28,7 @@ namespace media {
-
- // Return the number of channels from the data in |frame|.
- static inline int DetermineChannels(AVFrame* frame) {
-- return frame->channels;
-+ return frame->ch_layout.nb_channels;
- }
-
- // Called by FFmpeg's allocation routine to allocate a buffer. Uses
-@@ -231,7 +231,7 @@ bool FFmpegAudioDecoder::OnNewFrame(const DecoderBuffer& buffer,
- // Translate unsupported into discrete layouts for discrete configurations;
- // ffmpeg does not have a labeled discrete configuration internally.
- ChannelLayout channel_layout = ChannelLayoutToChromeChannelLayout(
-- codec_context_->channel_layout, codec_context_->channels);
-+ codec_context_->ch_layout.u.mask, codec_context_->ch_layout.nb_channels);
- if (channel_layout == CHANNEL_LAYOUT_UNSUPPORTED &&
- config_.channel_layout() == CHANNEL_LAYOUT_DISCRETE) {
- channel_layout = CHANNEL_LAYOUT_DISCRETE;
-@@ -348,11 +348,11 @@ bool FFmpegAudioDecoder::ConfigureDecoder(const AudioDecoderConfig& config) {
- // Success!
- av_sample_format_ = codec_context_->sample_fmt;
-
-- if (codec_context_->channels != config.channels()) {
-+ if (codec_context_->ch_layout.nb_channels != config.channels()) {
- MEDIA_LOG(ERROR, media_log_)
- << "Audio configuration specified " << config.channels()
- << " channels, but FFmpeg thinks the file contains "
-- << codec_context_->channels << " channels";
-+ << codec_context_->ch_layout.nb_channels << " channels";
- ReleaseFFmpegResources();
- state_ = DecoderState::kUninitialized;
- return false;
-@@ -403,7 +403,7 @@ int FFmpegAudioDecoder::GetAudioBuffer(struct AVCodecContext* s,
- if (frame->nb_samples <= 0)
- return AVERROR(EINVAL);
-
-- if (s->channels != channels) {
-+ if (s->ch_layout.nb_channels != channels) {
- DLOG(ERROR) << "AVCodecContext and AVFrame disagree on channel count.";
- return AVERROR(EINVAL);
- }
-@@ -436,7 +436,8 @@ int FFmpegAudioDecoder::GetAudioBuffer(struct AVCodecContext* s,
- ChannelLayout channel_layout =
- config_.channel_layout() == CHANNEL_LAYOUT_DISCRETE
- ? CHANNEL_LAYOUT_DISCRETE
-- : ChannelLayoutToChromeChannelLayout(s->channel_layout, s->channels);
-+ : ChannelLayoutToChromeChannelLayout(s->ch_layout.u.mask,
-+ s->ch_layout.nb_channels);
-
- if (channel_layout == CHANNEL_LAYOUT_UNSUPPORTED) {
- DLOG(ERROR) << "Unsupported channel layout.";
diff --git a/REVERT-roll-src-third_party-ffmpeg-m106.patch b/REVERT-roll-src-third_party-ffmpeg-m106.patch
deleted file mode 100644
index b2a113791734..000000000000
--- a/REVERT-roll-src-third_party-ffmpeg-m106.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From ded379824f5de39357b6b1894578101aba5cdf05 Mon Sep 17 00:00:00 2001
-From: Eugene Zemtsov <eugene@chromium.org>
-Date: Fri, 29 Jul 2022 04:41:04 +0000
-Subject: [PATCH] Roll src/third_party/ffmpeg/ 880df5ede..b71ecd02b (279
- commits)
-
-https://chromium.googlesource.com/chromium/third_party/ffmpeg.git/+log/880df5ede50a..b71ecd02b479
-
-$ git log 880df5ede..b71ecd02b --date=short --no-merges --format='%ad %ae %s'
-2022-07-27 eugene Roll for M106
-2022-07-25 andreas.rheinhardt avcodec/x86/pngdsp: Remove obsolete ff_add_bytes_l2_mmx()
-2022-07-22 andreas.rheinhardt avcodec/hevcdec: Output MD5-message in one piece
-2022-07-24 epirat07 configure: properly require libx264 if enabled
-2022-07-24 zane avformat/argo_cvg: expose loop/reverb/checksum via metadata
-(...)
-2022-05-03 leo.izen avcodec/libjxldec: properly tag output colorspace
-2022-06-25 ffmpeg avfilter/Makefile: always make colorspace.o
-2022-03-02 brad avutil/ppc/cpu: Use proper header for OpenBSD PPC CPU detection
-2022-06-24 jamrial avformat/http: include version.h
-2022-05-16 mbonda-at-nvidia.com AV1 VDPAU hwaccel Decode support
-
-Created with:
- roll-dep src/third_party/ffmpeg
-
-ffmpeg usage fix:
- Switch from AVFrame::pkt_duration to AVFrame::duration,
- AVFrame::pkt_duration is deprecated
-
-Bug: 1344646
-Change-Id: Iaa3abf48ef81dae6d282bca8f0fa2a8dffeeba25
-Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3788638
-Reviewed-by: Will Cassella <cassew@chromium.org>
-Commit-Queue: Eugene Zemtsov <eugene@chromium.org>
-Cr-Commit-Position: refs/heads/main@{#1029623}
----
- media/filters/audio_file_reader.cc | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/media/filters/audio_file_reader.cc b/media/filters/audio_file_reader.cc
-index e1be5aa9a5b..951c003956f 100644
---- a/media/filters/audio_file_reader.cc
-+++ b/media/filters/audio_file_reader.cc
-@@ -243,10 +243,10 @@ bool AudioFileReader::OnNewFrame(
- // silence from being output. In the case where we are also discarding some
- // portion of the packet (as indicated by a negative pts), we further want to
- // adjust the duration downward by however much exists before zero.
-- if (audio_codec_ == AudioCodec::kAAC && frame->pkt_duration) {
-+ if (audio_codec_ == AudioCodec::kAAC && frame->duration) {
- const base::TimeDelta pkt_duration = ConvertFromTimeBase(
- glue_->format_context()->streams[stream_index_]->time_base,
-- frame->pkt_duration + std::min(static_cast<int64_t>(0), frame->pts));
-+ frame->duration + std::min(static_cast<int64_t>(0), frame->pts));
- const base::TimeDelta frame_duration =
- base::Seconds(frames_read / static_cast<double>(sample_rate_));
-
diff --git a/angle-wayland-include-protocol.patch b/angle-wayland-include-protocol.patch
deleted file mode 100644
index 1245b172b020..000000000000
--- a/angle-wayland-include-protocol.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -upr third_party/angle.orig/BUILD.gn third_party/angle/BUILD.gn
---- third_party/angle.orig/BUILD.gn 2022-08-17 19:38:11.000000000 +0000
-+++ third_party/angle/BUILD.gn 2022-08-18 11:04:09.061751111 +0000
-@@ -489,6 +489,12 @@ config("angle_vulkan_wayland_config") {
- if (angle_enable_vulkan && angle_use_wayland &&
- defined(vulkan_wayland_include_dirs)) {
- include_dirs = vulkan_wayland_include_dirs
-+ } else if (angle_enable_vulkan && angle_use_wayland) {
-+ include_dirs = [
-+ "$wayland_gn_dir/src/src",
-+ "$wayland_gn_dir/include/src",
-+ "$wayland_gn_dir/include/protocol",
-+ ]
- }
- }
-
-@@ -1073,6 +1079,7 @@ if (angle_use_wayland) {
- include_dirs = [
- "$wayland_dir/egl",
- "$wayland_dir/src",
-+ "$wayland_gn_dir/include/protocol",
- ]
- }
-
-diff -upr third_party/angle.orig/src/third_party/volk/BUILD.gn third_party/angle/src/third_party/volk/BUILD.gn
---- third_party/angle.orig/src/third_party/volk/BUILD.gn 2022-08-17 19:38:12.000000000 +0000
-+++ third_party/angle/src/third_party/volk/BUILD.gn 2022-08-18 11:04:36.499828006 +0000
-@@ -21,6 +21,9 @@ source_set("volk") {
- configs += [ "$angle_root:angle_no_cfi_icall" ]
- public_deps = [ "$angle_vulkan_headers_dir:vulkan_headers" ]
- if (angle_use_wayland) {
-- include_dirs = [ "$wayland_dir/src" ]
-+ include_dirs = [
-+ "$wayland_dir/src",
-+ "$wayland_gn_dir/include/protocol",
-+ ]
- }
- }
diff --git a/re-fix-TFLite-build-error-on-linux-with-system-zlib.patch b/re-fix-TFLite-build-error-on-linux-with-system-zlib.patch
deleted file mode 100644
index 13d504d3e792..000000000000
--- a/re-fix-TFLite-build-error-on-linux-with-system-zlib.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From dda01a706453ded8c01c41775707cb5ef4e316f8 Mon Sep 17 00:00:00 2001
-From: Andres Salomon <dilinger@queued.net>
-Date: Tue, 25 Oct 2022 21:11:46 +0000
-Subject: [PATCH] Re-fix TFLite build error on linux when using the system zlib
-
-In commit ae0f9adb7e14c0d19ca695ef6ad40b321a8cb64c, I fixed some build
-errors related to minizip patch inclusion in TFLite. However, after that
-when TFLite Support was rolled to HEAD, a small part of that patch got
-dropped. The result is the following build error with 107.0.5304.62:
-
-../../third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc:22:10: fatal error: 'contrib/minizip/ioapi.h' file not found
- ^~~~~~~~~~~~~~~~~~~~~~~~~
-1 error generated.
-
-This commit re-adds the lost fix.
-
-R=junzou@chromium.org
-
-Change-Id: Ie96c3571894b5100a1e2a2771da29699eff0beb3
-Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3972087
-Reviewed-by: Robert Ogden <robertogden@chromium.org>
-Commit-Queue: Robert Ogden <robertogden@chromium.org>
-Auto-Submit: Andres Salomon <dilinger@queued.net>
-Cr-Commit-Position: refs/heads/main@{#1063478}
----
- .../metadata/cc/utils/zip_readonly_mem_file.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc b/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
-index 392b6b411fe..525ae4a2b45 100644
---- a/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
-+++ b/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
-@@ -19,7 +19,7 @@ limitations under the License.
- #include <cstdio>
-
- #include "absl/strings/string_view.h" // from @com_google_absl
--#include "contrib/minizip/ioapi.h"
-+#include "third_party/zlib/contrib/minizip/ioapi.h"
-
- namespace tflite {
- namespace metadata {
diff --git a/unbundle-jsoncpp-avoid-CFI-faults-with-is_cfi-true.patch b/unbundle-jsoncpp-avoid-CFI-faults-with-is_cfi-true.patch
deleted file mode 100644
index 7bf1b5c701d8..000000000000
--- a/unbundle-jsoncpp-avoid-CFI-faults-with-is_cfi-true.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From ed8d931e35f81d8566835a579caf7d61368f85b7 Mon Sep 17 00:00:00 2001
-From: Evangelos Foutras <evangelos@foutrelis.com>
-Date: Tue, 27 Sep 2022 22:20:41 +0000
-Subject: [PATCH] unbundle/jsoncpp: avoid CFI faults with is_cfi=true
-
-Ensure jsoncpp symbols have public visibility and are thus excluded from
-CFI checks and whole-program optimization. This is achieved by defining
-JSON_DLL_BUILD which in turn causes json/config.h to define JSON_API as
-__attribute__((visibility("default"))). The latter macro is used to tag
-jsoncpp classes and namespace functions throughout jsoncpp's headers.
-
-BUG=1365218
-
-Change-Id: I56277737b7d9ecaeb5e17c8d21a2e55f3d5d5bc9
-Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3919652
-Reviewed-by: Thomas Anderson <thomasanderson@chromium.org>
-Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
-Cr-Commit-Position: refs/heads/main@{#1052077}
----
- build/linux/unbundle/jsoncpp.gn | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/build/linux/unbundle/jsoncpp.gn b/build/linux/unbundle/jsoncpp.gn
-index 544f9d13c9..e84a0ef27a 100644
---- a/build/linux/unbundle/jsoncpp.gn
-+++ b/build/linux/unbundle/jsoncpp.gn
-@@ -3,6 +3,11 @@ import("//build/shim_headers.gni")
-
- pkg_config("jsoncpp_config") {
- packages = [ "jsoncpp" ]
-+
-+ # Defining JSON_DLL_BUILD applies public visibility to jsoncpp classes
-+ # thus deactivating CFI checks for them. This avoids CFI violations in
-+ # virtual calls to system jsoncpp library (https://crbug.com/1365218).
-+ defines = [ "JSON_DLL_BUILD" ]
- }
-
- shim_headers("jsoncpp_shim") {
diff --git a/use-oauth2-client-switches-as-default.patch b/use-oauth2-client-switches-as-default.patch
deleted file mode 100644
index 9d9c57bfb0d2..000000000000
--- a/use-oauth2-client-switches-as-default.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -upr chromium-89.0.4389.58.orig/google_apis/google_api_keys.cc chromium-89.0.4389.58/google_apis/google_api_keys.cc
---- chromium-89.0.4389.58.orig/google_apis/google_api_keys.cc 2021-02-24 22:37:18.494007649 +0000
-+++ chromium-89.0.4389.58/google_apis/google_api_keys.cc 2021-02-24 22:35:00.865777600 +0000
-@@ -154,11 +154,11 @@ class APIKeyCache {
-
- std::string default_client_id = CalculateKeyValue(
- GOOGLE_DEFAULT_CLIENT_ID,
-- STRINGIZE_NO_EXPANSION(GOOGLE_DEFAULT_CLIENT_ID), nullptr,
-+ STRINGIZE_NO_EXPANSION(GOOGLE_DEFAULT_CLIENT_ID), ::switches::kOAuth2ClientID,
- std::string(), environment.get(), command_line, gaia_config);
- std::string default_client_secret = CalculateKeyValue(
- GOOGLE_DEFAULT_CLIENT_SECRET,
-- STRINGIZE_NO_EXPANSION(GOOGLE_DEFAULT_CLIENT_SECRET), nullptr,
-+ STRINGIZE_NO_EXPANSION(GOOGLE_DEFAULT_CLIENT_SECRET), ::switches::kOAuth2ClientSecret,
- std::string(), environment.get(), command_line, gaia_config);
-
- // We currently only allow overriding the baked-in values for the