summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x[-rw-r--r--].SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 25 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 321b496631c2..98c4ba2691cb 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = breeze-flat
- pkgdesc = Breeze Light and Dark with opaque backgrounds and without shadows
- pkgver = 1.1
+ pkgdesc = Breeze Light and Dark, but opaque and not shadowed
+ pkgver = 1.2
pkgrel = 1
url = https://store.kde.org/p/1215691/
arch = any
license = LGPL3
depends = plasma-framework
- source = breeze-flat::git+https://framagit.org/ariasuni/breeze-flat.git#tag=v1.1
- md5sums = SKIP
+ source = https://framagit.org/ariasuni/breeze-flat/-/archive/v1.2/breeze-flat-v1.2.tar.gz
+ sha256sums = 0381be8571c1aeb2644b532fe91889296e91aef399015a20d0969c7673633cb1
pkgname = breeze-light-flat
- pkgdesc = Breeze Light with opaque backgrounds and without shadows
+ pkgdesc = Breeze Light, but opaque and not shadowed
pkgname = breeze-dark-flat
- pkgdesc = Breeze Dark with opaque backgrounds and without shadows
+ pkgdesc = Breeze Dark, but opaque and not shadowed
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..244420686313
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 49f06c1c9409..d2106054c928 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,33 @@
pkgbase=breeze-flat
pkgname=(breeze-light-flat breeze-dark-flat)
-pkgver=1.1
+pkgver=1.2
pkgrel=1
-_pkgdesc="with opaque backgrounds and without shadows"
-pkgdesc="Breeze Light and Dark ${_pkgdesc}"
+_pkgdesc="but opaque and not shadowed"
+pkgdesc="Breeze Light and Dark, ${_pkgdesc}"
arch=('any')
url='https://store.kde.org/p/1215691/'
license=('LGPL3')
depends=('plasma-framework')
-source=("${pkgbase}::git+https://framagit.org/ariasuni/${pkgbase}.git#tag=v${pkgver}")
-md5sums=('SKIP')
+source=("https://framagit.org/ariasuni/breeze-flat/-/archive/v${pkgver}/${pkgbase}-v${pkgver}.tar.gz")
+sha256sums=('0381be8571c1aeb2644b532fe91889296e91aef399015a20d0969c7673633cb1')
+
+build() {
+ cd ${srcdir}/${pkgbase}-v${pkgver}
+ sh scripts/symlink.sh
+}
package_breeze-light-flat() {
- pkgdesc="Breeze Light ${_pkgdesc}"
- package
+ pkgdesc="Breeze Light, ${_pkgdesc}"
+ copy_theme
}
package_breeze-dark-flat() {
- pkgdesc="Breeze Dark ${_pkgdesc}"
- package
+ pkgdesc="Breeze Dark, ${_pkgdesc}"
+ copy_theme
}
-package() {
+copy_theme() {
install -dm755 "${pkgdir}/usr/share/plasma/desktoptheme"
- cp -r ${srcdir}/${pkgbase}/${pkgname} ${pkgdir}/usr/share/plasma/desktoptheme
+ cp -r ${srcdir}/${pkgbase}-v${pkgver}/${pkgname} ${pkgdir}/usr/share/plasma/desktoptheme
}