summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..321b496631c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = breeze-flat
+ pkgdesc = Breeze Light and Dark with opaque backgrounds and without shadows
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://store.kde.org/p/1215691/
+ arch = any
+ license = LGPL3
+ depends = plasma-framework
+ source = breeze-flat::git+https://framagit.org/ariasuni/breeze-flat.git#tag=v1.1
+ md5sums = SKIP
+
+pkgname = breeze-light-flat
+ pkgdesc = Breeze Light with opaque backgrounds and without shadows
+
+pkgname = breeze-dark-flat
+ pkgdesc = Breeze Dark with opaque backgrounds and without shadows
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49f06c1c9409
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mélanie Chauvel (ariasuni) <perso at hack-libre dot org>
+
+pkgbase=breeze-flat
+pkgname=(breeze-light-flat breeze-dark-flat)
+pkgver=1.1
+pkgrel=1
+_pkgdesc="with opaque backgrounds and without shadows"
+pkgdesc="Breeze Light and Dark ${_pkgdesc}"
+arch=('any')
+url='https://store.kde.org/p/1215691/'
+license=('LGPL3')
+depends=('plasma-framework')
+source=("${pkgbase}::git+https://framagit.org/ariasuni/${pkgbase}.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+package_breeze-light-flat() {
+ pkgdesc="Breeze Light ${_pkgdesc}"
+ package
+}
+
+package_breeze-dark-flat() {
+ pkgdesc="Breeze Dark ${_pkgdesc}"
+ package
+}
+
+package() {
+ install -dm755 "${pkgdir}/usr/share/plasma/desktoptheme"
+ cp -r ${srcdir}/${pkgbase}/${pkgname} ${pkgdir}/usr/share/plasma/desktoptheme
+}