summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--fix_strcasestr.patch33
3 files changed, 4 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89868f54557c..93b22ced5b62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brickd
pkgdesc = a brick daemon for tinkerforge brick(let)s
pkgver = 2.4.4
- pkgrel = 2
+ pkgrel = 1
url = http://www.tinkerforge.com/
install = brickd.install
arch = aarch64
@@ -13,9 +13,7 @@ pkgbase = brickd
depends = libusb
source = https://download.tinkerforge.com/apt/debian/pool/main/t/tinkerforge-brickd/tinkerforge-brickd_2.4.4.tar.xz
source = brickd.install
- source = fix_strcasestr.patch
sha256sums = 97f78d24921870717a6bb7c62e363f9d2afe82d7742a982536aa13e068092222
sha256sums = c70f47a66e5c538e255bfd93111fe1a4ea15894db9c377ed133f8a0351403589
- sha256sums = bcb9a742a15b29925a279c5d66c3f784681569a0081871e60a1b44e9f9b3e9ce
pkgname = brickd
diff --git a/PKGBUILD b/PKGBUILD
index 7775ac512f32..2a606e3e78f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,22 +5,16 @@
pkgname=brickd
pkgver=2.4.4
_pkgver=${pkgver}
-pkgrel=2
+pkgrel=1
pkgdesc="a brick daemon for tinkerforge brick(let)s"
url="http://www.tinkerforge.com/"
license=("GPL2")
arch=('aarch64' 'armv6h' 'armv7h' 'i686' 'x86_64')
depends=('libusb')
-source=(https://download.tinkerforge.com/apt/debian/pool/main/t/tinkerforge-${pkgname}/tinkerforge-${pkgname}_${_pkgver}.tar.xz brickd.install fix_strcasestr.patch)
+source=(https://download.tinkerforge.com/apt/debian/pool/main/t/tinkerforge-${pkgname}/tinkerforge-${pkgname}_${_pkgver}.tar.xz brickd.install)
sha256sums=('97f78d24921870717a6bb7c62e363f9d2afe82d7742a982536aa13e068092222'
- 'c70f47a66e5c538e255bfd93111fe1a4ea15894db9c377ed133f8a0351403589'
- 'bcb9a742a15b29925a279c5d66c3f784681569a0081871e60a1b44e9f9b3e9ce')
+ 'c70f47a66e5c538e255bfd93111fe1a4ea15894db9c377ed133f8a0351403589')
install='brickd.install'
-
-prepare() {
- patch --directory="$srcdir/tinkerforge-$pkgname-$_pkgver" --forward --strip=1 --input="${srcdir}/fix_strcasestr.patch"
-}
-
build() {
cd $srcdir/tinkerforge-$pkgname-$_pkgver/brickd
make
diff --git a/fix_strcasestr.patch b/fix_strcasestr.patch
deleted file mode 100644
index fd727a48a758..000000000000
--- a/fix_strcasestr.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --unified --recursive --text tinkerforge-brickd-2.4.4/daemonlib/utils.c tinkerforge-brickd-2.4.4_patched/daemonlib/utils.c
---- tinkerforge-brickd-2.4.4/daemonlib/utils.c 2023-01-16 14:57:51.000000000 +0100
-+++ tinkerforge-brickd-2.4.4_patched/daemonlib/utils.c 2023-10-04 09:26:13.896264957 +0200
-@@ -581,14 +581,14 @@
-
- #include <ctype.h>
-
--char *strcasestr(char *haystack, char *needle) {
-- char *p, *startn = NULL, *np = NULL;
-+char *strcasestr(const char *haystack, const char *needle) {
-+ const char *p, *startn = NULL, *np = NULL;
-
- for (p = haystack; *p != '\0'; ++p) {
- if (np != NULL) {
- if (toupper(*p) == toupper(*np)) {
- if (*++np == '\0') {
-- return startn;
-+ return (char *)startn;
- }
- } else {
- np = NULL;
-diff --unified --recursive --text tinkerforge-brickd-2.4.4/daemonlib/utils.h tinkerforge-brickd-2.4.4_patched/daemonlib/utils.h
---- tinkerforge-brickd-2.4.4/daemonlib/utils.h 2023-01-16 14:57:51.000000000 +0100
-+++ tinkerforge-brickd-2.4.4_patched/daemonlib/utils.h 2023-10-04 09:26:07.109580350 +0200
-@@ -59,7 +59,7 @@
- uint64_t millitime(void);
-
- #if !defined _GNU_SOURCE && !defined __APPLE__ && !defined __ANDROID__
--char *strcasestr(char *haystack, char *needle);
-+char *strcasestr(const char *haystack, const char *needle);
- #endif
-
- int red_brick_uid(uint32_t *uid /* always little endian */);