summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52f9e5db2fa0..9bd5a2075472 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
-# Generated by mksrcinfo v8
-# Thu Apr 4 04:11:29 UTC 2019
pkgbase = brisk-menu
pkgdesc = Modern, efficient menu for the MATE Desktop Environment.
- pkgver = 0.6.0.r31.g3d5e639
- pkgrel = 1
+ pkgver = 0.6.2
+ pkgrel = 2
+ epoch = 1
url = https://github.com/getsolus/brisk-menu
arch = i686
arch = x86_64
@@ -17,8 +16,9 @@ pkgbase = brisk-menu
makedepends = ninja
depends = mate-panel
depends = libnotify
- source = https://github.com/getsolus/brisk-menu/archive/3d5e63975d7c56cf2c63a0708065a694d6e54456.zip
- md5sums = 39ba48d21bd06fcd4f56bae9ac812cc0
+ options = !debug
+ options = !lto
+ source = https://github.com/getsolus/brisk-menu/releases/download/v0.6.2/brisk-menu-v0.6.2.tar.xz
+ sha256sums = 5a87f4dcf7365e81a571128bf0b8199eb06a6fcd7e15ec7739be0ccff1326488
pkgname = brisk-menu
-
diff --git a/PKGBUILD b/PKGBUILD
index 7ea6f5dd9711..cea8d2aae87f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
# Maintainer: Dustin Falgout <dustin@antergos.com>
pkgname=brisk-menu
-# git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-_commit=3d5e63975d7c56cf2c63a0708065a694d6e54456
-pkgver=0.6.0.r31.g3d5e639
-pkgrel=1
+pkgver=0.6.2
+pkgrel=2
+epoch=1
pkgdesc='Modern, efficient menu for the MATE Desktop Environment.'
arch=('i686' 'x86_64')
url='https://github.com/getsolus/brisk-menu'
@@ -12,25 +11,25 @@ license=('GPL2')
groups=('mate')
depends=('mate-panel' 'libnotify')
makedepends=('gnome-common' 'gettext' 'itstool' 'vala>=0.36' 'meson' 'ninja' )
-source=("https://github.com/getsolus/${pkgname}/archive/${_commit}.zip")
-md5sums=('39ba48d21bd06fcd4f56bae9ac812cc0')
-
+source=("https://github.com/getsolus/brisk-menu/releases/download/v${pkgver}/brisk-menu-v$pkgver.tar.xz")
+sha256sums=('5a87f4dcf7365e81a571128bf0b8199eb06a6fcd7e15ec7739be0ccff1326488')
+options=(!debug !lto)
build() {
- cd "${srcdir}/${pkgname}-${_commit}"
- mkdir build
+ cd "${srcdir}/${pkgname}-${pkgver}"
- meson build \
+ meson --buildtype plain build \
--prefix=/usr \
--bindir=/usr/bin \
--libexecdir=/usr/lib/${pkgname}
- ninja -C build
+ ninja -C build -j$(($(getconf _NPROCESSORS_ONLN)+1))
}
package() {
- cd "${srcdir}/${pkgname}-${_commit}/build"
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
DESTDIR="${pkgdir}" ninja install
}
+