summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--fix-launch.patch12
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11604f6b22e7..5cc1f9097606 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brisk-menu
pkgdesc = Modern, efficient menu for the MATE Desktop Environment.
pkgver = 0.5.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/getsolus/brisk-menu
arch = i686
arch = x86_64
@@ -17,8 +17,10 @@ pkgbase = brisk-menu
depends = libnotify
source = https://github.com/solus-project/brisk-menu/releases/download/v0.5.0/brisk-menu-v0.5.0.tar.xz
source = mate-122.patch
+ source = fix-launch.patch
sha256sums = 1377ffbb784e576c290bb4d11a2dd376bc0ad017bb9f56a080bccdbc4fbe88ce
sha256sums = 80326a5b98d0dfd6c7d9a362907edf576e24683032ffb62926f68e3f16abff71
+ sha256sums = 580f7f78b51107cb8e594b361d36eebbedb38b77a5248b9813dc4bc8961bd775
pkgname = brisk-menu
diff --git a/PKGBUILD b/PKGBUILD
index b5a2c2e91c2e..d8363dc72baf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=brisk-menu
pkgver=0.5.0
-pkgrel=2
+pkgrel=3
pkgdesc='Modern, efficient menu for the MATE Desktop Environment.'
arch=('i686' 'x86_64')
url='https://github.com/getsolus/brisk-menu'
@@ -11,13 +11,16 @@ groups=('mate')
depends=('mate-panel' 'libnotify')
makedepends=('gnome-common' 'gettext' 'itstool' 'vala>=0.36' 'meson' 'ninja' )
source=("https://github.com/solus-project/${pkgname}/releases/download/v${pkgver}/${pkgname}-v${pkgver}.tar.xz"
-mate-122.patch)
+mate-122.patch
+fix-launch.patch)
prepare() {
cd "$srcdir/${pkgname}-v${pkgver}"
# This patch fixes building with mate 1.22.x
patch -Np1 -i "${srcdir}/mate-122.patch"
+ # This fixes starting with mate 1.22.x but removes categories icon for now
+ patch -Np1 -i "${srcdir}/fix-launch.patch"
}
@@ -40,4 +43,5 @@ package() {
DESTDIR="${pkgdir}" ninja install
}
sha256sums=('1377ffbb784e576c290bb4d11a2dd376bc0ad017bb9f56a080bccdbc4fbe88ce'
- '80326a5b98d0dfd6c7d9a362907edf576e24683032ffb62926f68e3f16abff71')
+ '80326a5b98d0dfd6c7d9a362907edf576e24683032ffb62926f68e3f16abff71'
+ '580f7f78b51107cb8e594b361d36eebbedb38b77a5248b9813dc4bc8961bd775')
diff --git a/fix-launch.patch b/fix-launch.patch
new file mode 100644
index 000000000000..765c2257c47d
--- /dev/null
+++ b/fix-launch.patch
@@ -0,0 +1,12 @@
+diff --git a/src/backend/apps/apps-section.c b/src/backend/apps/apps-section.c
+index 97dcbdb..e333589 100644
+--- a/src/backend/apps/apps-section.c
++++ b/src/backend/apps/apps-section.c
+@@ -69,7 +69,8 @@ static void brisk_apps_section_update_directory(BriskAppsSection *self,
+ self->id =
+ g_strdup_printf("%s.mate-directory", matemenu_tree_directory_get_menu_id(directory));
+ self->name = g_strdup(matemenu_tree_directory_get_name(directory));
+- self->icon = matemenu_tree_directory_get_icon(directory);
++ //self->icon = matemenu_tree_directory_get_icon(directory);
++ self->icon = NULL;
+ }