summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--fix-launch.patch12
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd207cd32ae2..5949867d9431 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brisk-menu-git
pkgdesc = Modern, efficient menu for the MATE Desktop Environment - git version
pkgver = v0.5.0.r30.gc274131
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/getsolus/brisk-menu
arch = i686
arch = x86_64
@@ -23,8 +23,10 @@ pkgbase = brisk-menu-git
options = !emptydirs
source = git+https://github.com/getsolus/brisk-menu.git
source = mate-122.patch
+ source = fix-launch.patch
sha1sums = SKIP
sha1sums = 64641c7c67e357220cab52e48a7518e1d99a04b1
+ sha1sums = 57a888511a70142ee4c1b192cc50ee12661e84d7
pkgname = brisk-menu-git
diff --git a/PKGBUILD b/PKGBUILD
index 563089d8fa36..f292d5ab14a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=brisk-menu-git
_gitname=brisk
pkgver=v0.5.0.r30.gc274131
-pkgrel=1
+pkgrel=2
pkgdesc='Modern, efficient menu for the MATE Desktop Environment - git version'
arch=('i686' 'x86_64')
url='https://github.com/getsolus/brisk-menu'
@@ -18,9 +18,11 @@ options=('!libtool' '!emptydirs')
provides=('brisk-menu')
conflicts=('brisk-menu')
source=(git+https://github.com/getsolus/brisk-menu.git
- mate-122.patch)
+ mate-122.patch
+ fix-launch.patch)
sha1sums=('SKIP'
- '64641c7c67e357220cab52e48a7518e1d99a04b1')
+ '64641c7c67e357220cab52e48a7518e1d99a04b1'
+ '57a888511a70142ee4c1b192cc50ee12661e84d7')
pkgver() {
cd "$srcdir/brisk-menu"
@@ -32,6 +34,8 @@ prepare() {
cd "$srcdir/brisk-menu"
# This patch fixes building with mate 1.22.x
patch -Np1 -i "${srcdir}/mate-122.patch"
+ # This fixes starting with mate 1.22.x but removes categories icon for now
+ patch -Np1 -i "${srcdir}/fix-launch.patch"
}
build() {
diff --git a/fix-launch.patch b/fix-launch.patch
new file mode 100644
index 000000000000..765c2257c47d
--- /dev/null
+++ b/fix-launch.patch
@@ -0,0 +1,12 @@
+diff --git a/src/backend/apps/apps-section.c b/src/backend/apps/apps-section.c
+index 97dcbdb..e333589 100644
+--- a/src/backend/apps/apps-section.c
++++ b/src/backend/apps/apps-section.c
+@@ -69,7 +69,8 @@ static void brisk_apps_section_update_directory(BriskAppsSection *self,
+ self->id =
+ g_strdup_printf("%s.mate-directory", matemenu_tree_directory_get_menu_id(directory));
+ self->name = g_strdup(matemenu_tree_directory_get_name(directory));
+- self->icon = matemenu_tree_directory_get_icon(directory);
++ //self->icon = matemenu_tree_directory_get_icon(directory);
++ self->icon = NULL;
+ }