summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9b4dae87b4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue Mar 21 21:45:39 UTC 2017
+pkgbase = brisk-menu-git
+ pkgdesc = Modern, efficient menu for the MATE Desktop Environment - git version
+ pkgver = v0.3.0.r12.g9d16641
+ pkgrel = 1
+ url = https://github.com/solus-project/brisk-menu
+ arch = i686
+ arch = x86_64
+ groups = mate
+ license = GPL2
+ makedepends = gnome-common
+ depends = mate-panel
+ provides = brisk-menu
+ conflicts = brisk-menu
+ options = !libtool
+ options = !emptydirs
+ source = git+https://github.com/solus-project/brisk-menu.git
+ sha1sums = SKIP
+
+pkgname = brisk-menu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28fa624c18e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Based on work made by Dustin Falgout <dustin@antergos.com>
+
+pkgname=brisk-menu-git
+_gitname=brisk
+pkgver=v0.3.0.r12.g9d16641
+pkgrel=1
+pkgdesc='Modern, efficient menu for the MATE Desktop Environment - git version'
+arch=('i686' 'x86_64')
+url='https://github.com/solus-project/brisk-menu'
+license=('GPL2')
+groups=('mate')
+depends=('mate-panel')
+makedepends=('gnome-common')
+options=('!libtool' '!emptydirs')
+provides=('brisk-menu')
+conflicts=('brisk-menu')
+source=(git+https://github.com/solus-project/brisk-menu.git)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/brisk-menu
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $srcdir/brisk-menu
+
+ autoreconf -i
+ intltoolize
+
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib/${pkgname}
+
+ make
+}
+
+
+package() {
+ cd $srcdir/brisk-menu
+
+ make DESTDIR="${pkgdir}" install
+}
+