summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD14
-rw-r--r--broadcom-wl-ck.install2
-rw-r--r--linux48.patch52
4 files changed, 69 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 177fd91c5a8d..5610b62f0c56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Fri Sep 23 08:22:07 UTC 2016
+# Wed Oct 19 20:26:43 UTC 2016
pkgbase = broadcom-wl-ck
pkgdesc = Broadcom 802.11abgn hybrid Linux networking device driver for linux-ck.
pkgver = 6.30.223.271
- pkgrel = 21
- url = http://www.broadcom.com/support/802.11/linux_sta.php
+ pkgrel = 22
+ url = https://www.broadcom.com/support/802.11
install = broadcom-wl-ck.install
arch = i686
arch = x86_64
license = custom
- makedepends = linux-ck-headers>=4.7
- makedepends = linux-ck-headers<4.8
- depends = linux-ck>=4.7
- depends = linux-ck<4.8
+ makedepends = linux-ck-headers>=4.8
+ makedepends = linux-ck-headers<4.9
+ depends = linux-ck>=4.8
+ depends = linux-ck<4.9
conflicts = broadcom-wl-ck-atom
conflicts = broadcom-wl-ck-barcelona
conflicts = broadcom-wl-ck-bulldozer
@@ -35,6 +35,7 @@ pkgbase = broadcom-wl-ck
source = 001-null-pointer-fix.patch
source = 002-rdtscl.patch
source = 003-linux47.patch
+ source = linux48.patch
sha256sums = b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32
sha256sums = 2f70be509aac743bec2cc3a19377be311a60a1c0e4a70ddd63ea89fae5df08ac
sha256sums = 32e505a651fdb9fd5e4870a9d6de21dd703dead768c2b3340a2ca46671a5852f
diff --git a/PKGBUILD b/PKGBUILD
index f600cc5e203b..d3e5b7a86309 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,16 @@
pkgname=broadcom-wl-ck
pkgver=6.30.223.271
-pkgrel=21
+pkgrel=22
_pkgdesc='Broadcom 802.11abgn hybrid Linux networking device driver for linux-ck.'
-_extramodules="extramodules-4.7-ck"
+_extramodules="extramodules-4.8-ck"
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
pkgdesc="${_pkgdesc}"
arch=('i686' 'x86_64')
-url='http://www.broadcom.com/support/802.11/linux_sta.php'
+url='https://www.broadcom.com/support/802.11'
license=('custom')
-depends=('linux-ck>=4.7' 'linux-ck<4.8')
-makedepends=('linux-ck-headers>=4.7' 'linux-ck-headers<4.8')
+depends=('linux-ck>=4.8' 'linux-ck<4.9')
+makedepends=('linux-ck-headers>=4.8' 'linux-ck-headers<4.9')
conflicts=('broadcom-wl-ck-atom' 'broadcom-wl-ck-barcelona' 'broadcom-wl-ck-bulldozer' 'broadcom-wl-ck-corex' 'broadcom-wl-ck-core2' 'broadcom-wl-ck-haswell' 'broadcom-wl-ck-broadwell' 'broadcom-wl-ck-skylake' 'broadcom-wl-ck-ivybridge' 'broadcom-wl-ck-kx' 'broadcom-wl-ck-k10' 'broadcom-wl-ck-nehalem' 'broadcom-wl-ck-p4' 'broadcom-wl-ck-piledriver' 'broadcom-wl-ck-pentm' 'broadcom-wl-ck-sandybridge' 'broadcom-wl-ck-silvermont')
#replaces=()
#groups=('ck-generic')
@@ -23,7 +23,8 @@ source=('modprobe.d'
'license.patch'
'001-null-pointer-fix.patch'
'002-rdtscl.patch'
-'003-linux47.patch')
+'003-linux47.patch'
+'linux48.patch')
source_i686+=("http://www.broadcom.com/docs/linux_sta/hybrid-v35-nodebug-pcoem-${pkgver//./_}.tar.gz")
source_x86_64+=("http://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-${pkgver//./_}.tar.gz")
sha256sums=('b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32'
@@ -40,6 +41,7 @@ prepare() {
patch -p1 -i license.patch
patch -p1 -i 001-null-pointer-fix.patch
patch -p1 -i 003-linux47.patch
+ patch -p1 -i linux48.patch
sed -e "/BRCM_WLAN_IFNAME/s:eth:wlan:" -i src/wl/sys/wl_linux.c
diff --git a/broadcom-wl-ck.install b/broadcom-wl-ck.install
index 9b5373c45ef5..1275e9453114 100644
--- a/broadcom-wl-ck.install
+++ b/broadcom-wl-ck.install
@@ -1,5 +1,5 @@
post_upgrade() {
- EXTRAMODULES='extramodules-4.7-ck'
+ EXTRAMODULES='extramodules-4.8-ck'
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
}
diff --git a/linux48.patch b/linux48.patch
new file mode 100644
index 000000000000..0f3e81906226
--- /dev/null
+++ b/linux48.patch
@@ -0,0 +1,52 @@
+Reference: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=839629
+
+--- a/src/wl/sys/wl_cfg80211_hybrid.c 2016-10-03 10:53:55.588036464 +0200
++++ b/src/wl/sys/wl_cfg80211_hybrid.c 2016-10-03 10:54:11.911695944 +0200
+@@ -2386,8 +2386,15 @@
+ s32 err = 0;
+
+ if (wl->scan_request) {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
++ struct cfg80211_scan_info info = {
++ .aborted = true
++ };
+ WL_DBG(("%s: Aborting scan\n", __FUNCTION__));
+- cfg80211_scan_done(wl->scan_request, true);
++ cfg80211_scan_done(wl->scan_request, &info);
++#else
++ cfg80211_scan_done(wl->scan_request, true);
++#endif
+ wl->scan_request = NULL;
+ }
+
+@@ -2488,7 +2495,14 @@
+
+ scan_done_out:
+ if (wl->scan_request) {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
++ struct cfg80211_scan_info info = {
++ .aborted = false
++ };
++ cfg80211_scan_done(wl->scan_request, &info);
++#else
+ cfg80211_scan_done(wl->scan_request, false);
++#endif
+ wl->scan_request = NULL;
+ }
+ rtnl_unlock();
+@@ -2913,7 +2927,14 @@
+ s32 err = 0;
+
+ if (wl->scan_request) {
+- cfg80211_scan_done(wl->scan_request, true);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
++ struct cfg80211_scan_info info = {
++ .aborted = true
++ };
++ cfg80211_scan_done(wl->scan_request, &info);
++#else
++ cfg80211_scan_done(wl->scan_request, true);
++#endif
+ wl->scan_request = NULL;
+ }
+