summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD13
-rw-r--r--brother-dcp365cn.install27
-rw-r--r--fix_lp.patch1
3 files changed, 19 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4554766db56c..90f3aecff53e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,24 +14,23 @@ md5sums=('bea93ac27ae27cbd0916414e5a7f630b'
'0c62592b0c185bc6c2610b5407aaafb2')
source=(
- "fix_lp.patch" \
+ "fix_lp.patch" \
"https://download.brother.com/welcome/dlf005418/dcp365cnlpr-1.1.3-1.i386.rpm" \
- "https://download.brother.com/welcome/dlf005420/dcp365cncupswrapper-1.1.3-1.i386.rpm"
+ "https://download.brother.com/welcome/dlf005420/dcp365cncupswrapper-1.1.3-1.i386.rpm"
)
build() {
cd "$srcdir"
- patch -Np0 < fix_lp.patch
+ patch -Np0 < fix_lp.patch
}
post_install() {
- /opt/brother/Printers/dcp365cn/cupswrapper/cupswrapperdcp365cn
+ /opt/brother/Printers/dcp365cn/cupswrapper/cupswrapperdcp365cn
}
package() {
install -d $pkgdir/usr/bin
- install -d $pkgdir/var/spool/lpd
+ install -d $pkgdir/var/spool/lpd
install -Dm755 "$srcdir"/usr/bin/brprintconf_dcp365cn "$pkgdir"/usr/bin/
- cp -R $srcdir/opt $pkgdir/opt
+ cp -R $srcdir/opt $pkgdir/opt
}
-
diff --git a/brother-dcp365cn.install b/brother-dcp365cn.install
index d76499a308ce..c558e82d412b 100644
--- a/brother-dcp365cn.install
+++ b/brother-dcp365cn.install
@@ -1,27 +1,26 @@
post_install() {
- # lpr
- /opt/brother/Printers/dcp365cn/inf/setupPrintcapij dcp365cn -i
-
- # cupswrapper
- /opt/brother/Printers/dcp365cn/cupswrapper/cupswrapperdcp365cn
-
- systemctl restart cups.service
+ # lpr
+ /opt/brother/Printers/dcp365cn/inf/setupPrintcapij dcp365cn -i
+
+ # cupswrapper
+ /opt/brother/Printers/dcp365cn/cupswrapper/cupswrapperdcp365cn
+
+ systemctl restart cups.service
}
post_upgrade() {
- /bin/true
+ /bin/true
}
pre_remove() {
- # lpr
- /opt/brother/Printers/dcp365cn/inf/setupPrintcapij dcp365cn -e
-
- # cupswrapper
- /opt/brother/Printers/dcp365cn/cupswrapper/cupswrapperdcp365cn -e
+ # lpr
+ /opt/brother/Printers/dcp365cn/inf/setupPrintcapij dcp365cn -e
+
+ # cupswrapper
+ /opt/brother/Printers/dcp365cn/cupswrapper/cupswrapperdcp365cn -e
}
op=$1
shift
$op "$@"
-
diff --git a/fix_lp.patch b/fix_lp.patch
index 4b646d3d2e26..a403aba01a46 100644
--- a/fix_lp.patch
+++ b/fix_lp.patch
@@ -8,4 +8,3 @@
+ chown root $SPOOLER_NAME
chgrp lp $SPOOLER_NAME
chmod 700 $SPOOLER_NAME
-